1 2 Previous Next 25 Replies Latest reply: Apr 26, 2016 8:38 AM by smsnaqvi RSS

    RIPv2 Challenge

    narbik


      Drawing1.jpg


      You are in CCIE lab, the above topology is the logical topology.

      R1 and R5 are running RIPv2, R1 is advertising its loopback0 in this routing domain.

      R2, R3 and R4 are running OSPF. R2 is also running OSPF on its loopback0 interface.

      Without route redistribution, GRE, IPnIP, MPLS, AToM, L2TPv3, Static routes, or running another routing protocol on these routers, R5 should see R1’s Lo0 interface in its routing table.

       

      Provide a solution from layer two's perspective, and another from layer three's perspective.

        • 1. Re: RIPv2 Challenge

          Full bridge on R2
          Half bridge on R4

          Add loopbacks as required, where required :-)

          • 2. Re: RIPv2 Challenge
            narbik

            I am looking for two solutions, one from layer two's perspective and the second one from layer three's perspective. Please show me the configs. I forgot to mention that you can not use bridging, but it's cool if you show me your config, I will take it, but that is one solution.

             

             

             

            Narbik Kocharians
            CCSI#30832, CCIE# 12410 (R&S, SP, Security)
            www.MicronicsTraining.com
            Sr. Technical Instructor, and a Cisco Press Author

            A Cisco Learning Partner

            • 3. Re: RIPv2 Challenge
              David Sudjiman

              Hi Narbik, It's been a while.

               

              I hope you don't mind if I try to answer this using the solution that was given to me a while a go from a great CCIE mentor.

               

              Basically we need to convert R1 RIP update to Broadcast messages, received on R2 that converts it to multicast stream. R4 will need to convert it back from multicast to broadcast message so that R5 RIP can accepts that R1 routing updates.

               

              I'm using my own topology in VIRL which are quite similar.

               

              RIPv2ChallengeCLNNarbik.png


              Step 0. Basic configuration.

              Let's begin with the routing topology configuration. All routing configuration below are based on the proposed topology.

              ! R1
              int lo0
               ip addr 1.1.1.1 255.255.255.255
              
              interface GigabitEthernet0/1
               ip address 12.1.1.1 255.255.255.0
              
              router rip
               version 2
               no auto-summary
               network 1.0.0.0
               network 12.0.0.0
              
              ! R2
              int lo0
               ip addr 2.2.2.2 255.255.255.255
              
              interface GigabitEthernet0/1
               ip address 12.1.1.2 255.255.255.0
              interface GigabitEthernet0/2
               ip address 23.1.1.2 255.255.255.0
              
              router ospf 234
               router-id 2.2.2.2
               net 2.2.2.2  0.0.0.0 a 0
               net 23.1.1.2 0.0.0.0 a 0
              
              ! R3
              int lo0
               ip addr 3.3.3.3 255.255.255.255
              
              interface GigabitEthernet0/1
               ip address 34.1.1.3 255.255.255.0
              interface GigabitEthernet0/2
               ip address 23.1.1.3 255.255.255.0
              
              router ospf 234
               router-id 3.3.3.3
               net 3.3.3.3  0.0.0.0 a 0
               net 23.1.1.3 0.0.0.0 a 0
               net 34.1.1.3 0.0.0.0 a 0
              
              
              ! R4
              int lo0
               ip addr 4.4.4.4 255.255.255.255
              
              interface GigabitEthernet0/1
               ip address 34.1.1.4 255.255.255.0
              interface GigabitEthernet0/2
               ip address 45.1.1.4 255.255.255.0
              
              router ospf 234
               router-id 4.4.4.4
               net 4.4.4.4  0.0.0.0 a 0
               net 34.1.1.4 0.0.0.0 a 0
              
              ! R5
              int lo0
               ip addr 5.5.5.5 255.255.255.255
              
              interface GigabitEthernet0/1
               ip address 45.1.1.5 255.255.255.0
              
              router rip
               version 2
               no auto-summary
               network 5.0.0.0
               network 45.0.0.0
              
              


              Step 1. Create multicast network between R1 and R5 (R1 and R5 are not included).

               

              You can use DM or SM it doesn't really matter. I'm not going to elaborate this multicast steps in here but feel free to ask if something is unclear.

               

              R2, R3, and R4 will be in multicast network with static RP on 3.3.3.3

              ! R2
              ip multicast-routing
              ip pim rp-addr 3.3.3.3
              
              int g0/1
               ip pim sparse-mode
              int g0/2
               ip pim sparse-mode
              
              ! note that G0/1 is the receiving interface from R1.
              
              ! R3
              ip multicast-routing
              ip pim rp-addr 3.3.3.3
              
              int g0/1
               ip pim sparse-mode
              int g0/2
               ip pim sparse-mode
              
              
              ! R4
              ip multicast-routing
              ip pim rp-addr 3.3.3.3
              
              int g0/1
               ip pim sparse-mode
              
              ! note that G0/2 is the egress to R5.
              

               

              Once Step 1 is done, you should be able to see the PIM neighbor on R3 for both interfaces.

              R3#sh ip pim nei
              PIM Neighbor Table
              Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
                    P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
                    L - DR Load-balancing Capable
              Neighbor          Interface                Uptime/Expires    Ver   DR
              Address                                                            Prio/Mode
              34.1.1.4          GigabitEthernet0/1       00:41:51/00:01:19 v2    1 / DR S P G
              23.1.1.2          GigabitEthernet0/2       00:42:08/00:01:19 v2    1 / S P G
              

               

              Make sure that on R2, R3, and R4 are configured with the correct RP.

              R3#sh ip pim rp mapping 
              PIM Group-to-RP Mappings
              
              Group(s): 224.0.0.0/4, Static
                  RP: 3.3.3.3 (?)
              

               

              One last verification, R2, R2, and R4 should be able to see (*.224.0.1.40) with RP 3.3.3.3.


              Step 2. This is the fun part, convert R1 RIP update to R2 to broadcast and make R2 accept the broadcast and converts it to multicast stream (234.234.234.234).

              ! R1
              interface GigabitEthernet0/1
               ip rip v2-broadcast
              
              ! R2
              ip forward-protocol udp rip
              
              ip access-list ext ACL
               permit udp host 12.1.1.1 eq rip host 255.255.255.255 eq rip
              
              int g0/1
              ip multicast helper-map broadcast 234.234.234.234 ACL ttl 2
              
              ! Note. The ACL is to capture the specific broadcast packet sourced from 12.1.1.1 RIP (UDP 520). The TTL is to make the converted packet extra hop from R3 to R4 (2 hops).
              

               

              If R2 can convert the RIP update correctly, the mroute table will show the new stream appears.

              R2#sh ip mroute
              ...
              
              (*, 234.234.234.234), 00:39:07/stopped, RP 3.3.3.3, flags: SPF
                Incoming interface: GigabitEthernet0/2, RPF nbr 23.1.1.3
                Outgoing interface list: Null
              
              (12.1.1.1, 234.234.234.234), 00:39:07/00:02:24, flags: PFT
                Incoming interface: GigabitEthernet0/1, RPF nbr 0.0.0.0, Registering
                Outgoing interface list: Null
              
              (*, 224.0.1.40), 00:56:22/00:02:41, RP 3.3.3.3, flags: SJPL
                Incoming interface: GigabitEthernet0/2, RPF nbr 23.1.1.3
                Outgoing interface list: Null
              

               

              Step 3. Convert back from multicast stream to broadcast on R4 interface G0/1 (connecting to R3) and sends to R5 via interface G0/2.

              ! R4
              
              ip access-list extended ACL
               permit udp host 12.1.1.1 any eq rip
              
              interface GigabitEthernet0/1
               ip multicast helper-map 234.234.234.234 45.1.1.255 ACL
              
              int g0/2
               ip directed-broadcast
              


              Step 4. Accepts in R5.

               

              At this stage R5 receives the update on interface G0/2, but due to the source is not coming from any of its interface, the update is dropped.

              *Apr 19 12:33:09.523: RIP: ignored v2 update from bad source 12.1.1.1 on GigabitEthernet0/2
              

               

              Disable source validation on R5 RIP.

              ! R5
              router rip
               no validate-update-source
              
              Now R5 begin to accept the update 
              
              *Apr 19 12:30:48.226: RIP: received v2 update from 12.1.1.1 on GigabitEthernet0/2
              *Apr 19 12:30:48.227:      1.1.1.1/32 via 0.0.0.0 in 1 hops
              
              R5#sh ip route
              
              ...
              
                    1.0.0.0/32 is subnetted, 1 subnets
              R        1.1.1.1 [120/1] via 12.1.1.1, 00:00:01
                    5.0.0.0/32 is subnetted, 1 subnets
              C        5.5.5.5 is directly connected, Loopback0
                    45.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
              C        45.1.1.0/24 is directly connected, GigabitEthernet0/2
              L        45.1.1.5/32 is directly connected, GigabitEthernet0/2
              

              I've read there are another way of doing this using unicast instead of multicast. I'll read more about it.

               

              BTW, I don't actually understand your way of asking L2 and L3. I guess this multicast is considered a L3 solution. Is this correct?

               

              For L2 solution, I've been thinking to use Q-in-Q but this is not and 802.1q network so I'm waiting for your answer if I may

               

              Thx

              DSU

              • 4. Re: RIPv2 Challenge

                for L3: Ipv6 connection between R1 and R5

                Use RIPv6 - it is not "another routing protocol" it is just RIPv6 :-)

                • 5. Re: RIPv2 Challenge

                  Quick question: with the above config, does a ping work between R5 and R1's loopback?

                  • 6. Re: RIPv2 Challenge
                    narbik

                    No the pings will not work. BTW, this is IPv4, so you can't run IPv6, and even if you run IPv6 you won't be able to get the 1.1.1.1/32 into R5's routing table.

                     

                     

                     

                     

                    Narbik Kocharians
                    CCSI#30832, CCIE# 12410 (R&S, SP, Security)
                    www.MicronicsTraining.com
                    Sr. Technical Instructor, and a Cisco Press Author

                    A Cisco Learning Partner

                    • 7. Re: RIPv2 Challenge
                      narbik

                      You got the first part correct. Good job. Where did you see this scenario?

                       

                      Now you need to come up with the second one.

                       

                       

                       

                      Narbik Kocharians
                      CCSI#30832, CCIE# 12410 (R&S, SP, Security)
                      www.MicronicsTraining.com
                      Sr. Technical Instructor, and a Cisco Press Author

                      A Cisco Learning Partner

                      • 8. Re: RIPv2 Challenge

                        Sorry, I was sketching a solution here, I am actually at work

                        • 9. Re: RIPv2 Challenge
                          Dmcneil

                          Wait. Isn't PIM a multicast routing protocol? I thought the only protocols allowed were OSPF and RIP that were already configured.

                           

                          I was trying to come up with a solution without adding any routing protocols as mentioned in the OP. It's kind of misleading.

                           

                          Are the questions on the CCIE Lab Exam written in this way?

                          • 10. Re: RIPv2 Challenge
                            sarah

                            Yes Narbik, The question was misleading. You did specify without another routing protocol.

                            • 11. Re: RIPv2 Challenge
                              David Sudjiman

                              I attended your class.

                               

                              Ok, I take it that I need to work on the unicast.

                               

                              Thx

                              DSU

                              • 12. Re: RIPv2 Challenge
                                David Sudjiman

                                Ok, I've tried to use broadcast update on R1, R2 uses helper-address to convert that.. however, I'm not seeing the unicast packet on R3, R4, nor R5?

                                 

                                Is this even the right approach?

                                 

                                Thx

                                DSU

                                • 13. Re: RIPv2 Challenge
                                  narbik

                                  David, I never remember names, but I never forget faces.

                                   

                                  I am so sorry. I guess sometimes I am trying to do too many things at once. I am teaching a class in Poland/Warsaw, and I am trying to start our challenge series so we can all learn some stuff together.

                                   

                                  Yes, what I meant was unicast routing, so you can not configure another unicast routing. Did anyone figure out the challenge from layer two's perspective?

                                   

                                  Once again I am sorry Dmcneil, 1001QA.Net and Sarah.

                                   

                                  Narbik Kocharians
                                  CCSI#30832, CCIE# 12410 (R&S, SP, Security)
                                  www.MicronicsTraining.com
                                  Sr. Technical Instructor, and a Cisco Press Author

                                  A Cisco Learning Partner

                                  • 14. Re: RIPv2 Challenge
                                    narbik

                                    OK, we can use SPAN to direct the traffic from one interface to another. Obviously on R5 we have to use another interface and we also have to configure "no validate-update-source" because the route is coming in from another network.

                                    We never use SPAN in this manner but we could if we had to.

                                     

                                    I will give you all another one soon.

                                     

                                    Narbik Kocharians
                                    CCSI#30832, CCIE# 12410 (R&S, SP, Security)
                                    www.MicronicsTraining.com
                                    Sr. Technical Instructor, and a Cisco Press Author

                                    A Cisco Learning Partner

                                    1 2 Previous Next