11 Replies Latest reply: May 21, 2019 6:37 AM by Ashish RSS

    EIGRP Neighborship flapping every 1min 20secs

    Xavier

      I am seeing this very strange neighborship flapping on one sub-interface of the gigabit ethernet connection. Neighborship breaks and is restarted every 80 secs and the logs on both devices are identical and reversed as when when Router-01 says retry limit exceeded Router-02 says PEER-TERMINATION received also the sequence number does not increment at all in one device. I have checked MTU mismatch as suspected in some other forums and rule that out here. Please explain this behaviour and what is wrong here.

       

      Router-01#sh ip eigrp neighbors
      EIGRP-IPv4 Neighbors for AS(200)
      H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                  (sec)         (ms)       Cnt Num
      4   10.200.121.3            Gi0/0.121         14 00:01:19    1  5000  1  0
      6   10.200.118.195          Gi0/0.118         14 1d06h       1   200  0  9547
      5   10.200.122.3            Gi0/0.122         12 1d06h       1   200  0  9546
      3   10.200.120.3            Gi0/0.120         12 1d06h       1   200  0  9549
      2   10.200.119.3            Gi0/0.119         13 1d06h       1   200  0  9550
      1   10.200.117.3            Gi0/0.1           14 1d06h       1   200  0  9548
      0   10.200.118.6            Gi0/1             12 1d06h       1   200  0  9545

       

      Router-02#sh ip ei neighbors
      EIGRP-IPv4 Neighbors for AS(200)
      H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                  (sec)         (ms)       Cnt Num
      4   10.200.121.2            Gi0/0.121         13 00:00:57    1  5000  1  9615
      6   10.200.118.194          Gi0/0.118         10 1d06h       1   200  0  9612
      5   10.200.122.2            Gi0/0.122         10 1d06h       1   200  0  9613
      3   10.200.120.2            Gi0/0.120         11 1d06h       1   200  0  9610
      2   10.200.119.2            Gi0/0.119         11 1d06h       1   200  0  9609
      1   10.200.117.2            Gi0/0.1           14 1d06h       1   200  0  9611
      0   10.200.118.5            Gi0/1             14 1d06h       1   200  0  9614

       

       

      Logs#:

      Router-01

      000260: Oct 23 18:54:27.649 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.3 (GigabitEthernet0/0.121) is down: retry limit exceeded
      000261: Oct 23 18:54:30.229 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.3 (GigabitEthernet0/0.121) is up: new adjacency
      000262: Oct 23 18:55:49.741 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.3 (GigabitEthernet0/0.121) is down: retry limit exceeded
      000263: Oct 23 18:55:52.965 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.3 (GigabitEthernet0/0.121) is up: new adjacency
      000264: Oct 23 18:57:12.469 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.3 (GigabitEthernet0/0.121) is down: Interface PEER-TERMINATION received
      000265: Oct 23 18:57:14.985 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.3 (GigabitEthernet0/0.121) is up: new adjacency
      000266: Oct 23 18:58:34.488 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.3 (GigabitEthernet0/0.121) is down: Interface PEER-TERMINATION received

       

      Router-02

      000253: Oct 23 18:54:27.642 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.2 (GigabitEthernet0/0.121) is down: Interface PEER-TERMINATION received
      000254: Oct 23 18:54:30.230 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.2 (GigabitEthernet0/0.121) is up: new adjacency
      000255: Oct 23 18:55:49.733 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.2 (GigabitEthernet0/0.121) is down: Interface PEER-TERMINATION received
      000256: Oct 23 18:55:52.965 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.2 (GigabitEthernet0/0.121) is up: new adjacency
      000257: Oct 23 18:57:12.477 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.2 (GigabitEthernet0/0.121) is down: retry limit exceeded
      000258: Oct 23 18:57:14.985 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.2 (GigabitEthernet0/0.121) is up: new adjacency
      000259: Oct 23 18:58:34.497 EDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 200: Neighbor 10.200.121.2 (GigabitEthernet0/0.121) is down: retry limit exceeded

        • 1. Re: EIGRP Neighborship flapping every 1min 20secs
          umair

          First, check Hello Interval(timer) values of both neightbours.

           

          command is # show ip eigrp 200 interfaces detail gigaethernet 0/0.121

           

          Just to clarify, hello and hold timers don't have to match on the  neighbors, but one of the reasons that the flapping would occur is if  you configure the hold time wrong so it would expire before the next  hello packet is sent.

          • 2. Re: EIGRP Neighborship flapping every 1min 20secs
            Patrick

            I agree with Umair. Would it be possible to see the configs of both routers?

             

            Sent from HTC

            • 3. Re: EIGRP Neighborship flapping every 1min 20secs
              Xavier

              Here is the detail you required. It has been long, I called ATT and this guy, he told me that it is a circuit flapping issue .

               

              Router-01#sh ip eigrp 200 interfaces detail gi0/0.121
              EIGRP-IPv4 Interfaces for AS(200)
                                      Xmit Queue   Mean   Pacing Time   Multicast    Pending
              Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
              Gi0/0.121          1        0/0         0       0/1         1380        1728
                Hello-interval is 5, Hold-time is 15
                Split-horizon is enabled
                Next xmit serial 1
                Un/reliable mcasts: 0/1270  Un/reliable ucasts: 5970/34463
                Mcast exceptions: 11  CR packets: 11  ACKs suppressed: 22
                Retransmissions sent: 32164  Out-of-sequence rcvd: 111
                Topology-ids on interface - 0
                Authentication mode is not set
              Router-01#


              Router-02#sh ip eigrp 200 interfaces detail gi0/0.121
              EIGRP-IPv4 Interfaces for AS(200)
                                      Xmit Queue   Mean   Pacing Time   Multicast    Pending
              Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
              Gi0/0.121          1        0/0         0       0/1           50        1733
                Hello-interval is 5, Hold-time is 15
                Split-horizon is enabled
                Next xmit serial 1
                Un/reliable mcasts: 0/5458  Un/reliable ucasts: 2547/38399
                Mcast exceptions: 18  CR packets: 18  ACKs suppressed: 20
                Retransmissions sent: 36090  Out-of-sequence rcvd: 3687
                Topology-ids on interface - 0
                Authentication mode is not set
              Router-02#

              • 4. Re: EIGRP Neighborship flapping every 1min 20secs
                umair

                OK XAVIER

                as you know in troubleshooting we have to consider many options so

                 

                1- change hello and hold time on any router (r1, r2) and see if error removed,

                                                     if not

                2- use a bidirectional link for both unicast and multicast.

                 

                (my english is not so good but i hope u understand)

                • 5. Re: EIGRP Neighborship flapping every 1min 20secs
                  umair
                  Command
                  • Description
                  ip hello-interval eigrp AS# timeinseconds#This command is executed in interface configuration mode to manually  configure an EIGRP hello interval on a per-interface per autonomous  system basis. Time is specified in seconds.
                  ip hold-time eigrp as# timeinseconds#

                   

                  This command is executed in interface configuration mode to manually  configure an EIGRP dead interval on a per-interface per autonomous  system basis. Time is specified in seconds.

                  • 6. Re: EIGRP Neighborship flapping every 1min 20secs
                    Paul Stewart  -  CCIE Security

                    I have seen this behavior when the subnet mask was mismatched between the local and peer router. It doesn't seem to happen with all versions, but I have seen it before.

                    • 7. Re: EIGRP Neighborship flapping every 1min 20secs
                      Xavier

                      Here is some more information. I tried to ping extended for the neighbor address 10.200.121.3 from Router-01 and found its timing out for large packets. On checking its route, I see another strange thing. Route 10.200.121.2 is being advertised by eigrp 200 as well as bgp 65218. I am confused.

                       

                      Also checked cisco docs on neighborship issueshttp://www.cisco.com/networkers/nw04/presos/docs/RST-3300.pdf

                      Found that 200 is the minimum RTO for a neighbor and 5000 is maximum RTO value which is when router has tried 16 retransmit attempts involving 50 to 80 secs.

                       

                      Router-02#sh ip route 10.200.121.2
                      Routing entry for 10.200.121.0/24
                      Known via "connected", distance 0, metric 0 (connected, via interface)
                      Redistributing via eigrp 200
                      Advertised by eigrp 200
                                     bgp 65218

                       

                      Router-01#sh ip route 10.200.121.3
                      Routing entry for 10.200.121.0/24
                      Known via "connected", distance 0, metric 0 (connected, via interface)
                      Redistributing via eigrp 200
                      Advertised by bgp 65218
                      Routing Descriptor Blocks:
                      * directly connected, via GigabitEthernet0/0.121


                      Router-02#sh ip eigrp neighbors
                      EIGRP-IPv4 Neighbors for AS(200)
                      H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                                  (sec)         (ms)       Cnt Num
                      4   10.200.121.2            Gi0/0.121         12 00:00:31    1  5000  1  20046
                      6   10.200.118.194          Gi0/0.118         13 3d07h       1   200  0  20039
                      5   10.200.122.2            Gi0/0.122         11 3d07h       1   200  0  20041
                      3   10.200.120.2            Gi0/0.120         14 3d07h       1   200  0  20040
                      2   10.200.119.2            Gi0/0.119         11 3d07h       1   200  0  20042
                      1   10.200.117.2            Gi0/0.1           12 3d07h       1   200  0  20043
                      0   10.200.118.5            Gi0/1             14 3d07h       1   200  0  20038
                      Router-02#sh ip rou
                      Router-02#sh ip route 10.200.121.2
                      Routing entry for 10.200.121.0/24
                        Known via "connected", distance 0, metric 0 (connected, via interface)
                        Redistributing via eigrp 200
                        Advertised by eigrp 200
                                      bgp 65218

                        Routing Descriptor Blocks:
                        * directly connected, via GigabitEthernet0/0.121
                            Route metric is 0, traffic share count is 1
                      Router-02#sh run | sec eigrp
                      router eigrp 200
                      default-metric 1000 100 250 100 1500
                      network 10.0.0.0
                      redistribute bgp 65218
                      snmp-server enable traps eigrp

                      Router-02#sh run | sec bgp
                      redistribute bgp 65218
                      router bgp 65218
                      bgp log-neighbor-changes
                      network 10.200.117.0 mask 255.255.255.0
                      network 10.200.118.1 mask 255.255.255.255
                      network 10.200.118.2 mask 255.255.255.255
                      network 10.200.118.4 mask 255.255.255.252
                      network 10.200.118.192 mask 255.255.255.192
                      network 10.200.119.0 mask 255.255.255.0
                      network 10.200.120.0 mask 255.255.255.0
                      network 10.200.121.0 mask 255.255.255.0
                      network 10.200.122.0 mask 255.255.255.0
                      timers bgp 15 45
                      neighbor 10.200.117.2 remote-as 65218
                      neighbor 10.200.117.2 timers 15 45
                      neighbor 10.200.117.2 next-hop-self
                      neighbor 10.200.118.5 remote-as 65218
                      neighbor 10.249.40.53 remote-as 13979
                      snmp-server enable traps bgp

                       

                      Router-02#


                      Router-01#sh ip eigrp nei

                      EIGRP-IPv4 Neighbors for AS(200)
                      H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                                  (sec)         (ms)       Cnt Num
                      6   10.200.118.195          Gi0/0.118         13 3d07h       1   200  0  24046
                      5   10.200.122.3            Gi0/0.122         13 3d07h       1   200  0  24042
                      3   10.200.120.3            Gi0/0.120         14 3d07h       1   200  0  24047
                      2   10.200.119.3            Gi0/0.119         14 3d07h       1   200  0  24043
                      1   10.200.117.3            Gi0/0.1           13 3d07h       1   200  0  24044
                      0   10.200.118.6            Gi0/1             14 3d07h       1   200  0  24045
                      Router-01#sh ip route 10.200.121.3
                      Routing entry for 10.200.121.0/24
                        Known via "connected", distance 0, metric 0 (connected, via interface)
                        Redistributing via eigrp 200
                        Advertised by bgp 65218
                        Routing Descriptor Blocks:
                        * directly connected, via GigabitEthernet0/0.121
                            Route metric is 0, traffic share count is 1
                      Router-01#sh run | sec eigrp
                      router eigrp 200
                      default-metric 1000 100 250 100 1500
                      network 10.0.0.0
                      redistribute bgp 65218
                      snmp-server enable traps eigrp
                      Router-01#sh run | sec bgp
                      redistribute bgp 65218
                      router bgp 65218
                      bgp log-neighbor-changes
                      network 10.200.117.0 mask 255.255.255.0
                      network 10.200.118.0 mask 255.255.255.0
                      network 10.200.118.1 mask 255.255.255.255
                      network 10.200.118.2 mask 255.255.255.255
                      network 10.200.118.4 mask 255.255.255.252
                      network 10.200.118.192 mask 255.255.255.192
                      network 10.200.119.0 mask 255.255.255.0
                      network 10.200.120.0 mask 255.255.255.0
                      network 10.200.121.0 mask 255.255.255.0
                      network 10.200.122.0 mask 255.255.255.0
                      timers bgp 15 45
                      neighbor 10.200.117.3 remote-as 65218
                      neighbor 10.200.117.3 timers 15 45
                      neighbor 10.200.117.3 next-hop-self
                      neighbor 10.200.118.6 remote-as 65218
                      neighbor 10.249.40.57 remote-as 13979
                      snmp-server enable traps bgp
                      Router-01#

                      • 8. Re: EIGRP Neighborship flapping every 1min 20secs
                        Xavier

                        Hi Umair,

                         

                        I didnt understand this solution.

                         

                        "use a bidirectional link for both unicast and multicast"

                        • 9. Re: EIGRP Neighborship flapping every 1min 20secs
                          Xavier

                          Verified subnet mask.

                           

                          Router-02#sh run int gi0/0.121
                          Building configuration...

                          Current configuration : 503 bytes
                          !
                          interface GigabitEthernet0/0.121
                          description VLAN_121 1st Floor
                          encapsulation dot1Q 121
                          ip address 10.200.121.3 255.255.255.0

                           

                          Router-01#sh run int gi0/0.121
                          Building configuration...

                          Current configuration : 529 bytes
                          !
                          interface GigabitEthernet0/0.121
                          description VLAN_121 1st Floor
                          encapsulation dot1Q 121
                          ip address 10.200.121.2 255.255.255.0

                          • 10. Re: EIGRP Neighborship flapping every 1min 20secs
                            umair

                            i pick that solution from a forum here is the copy paste of that forum

                             

                             

                            A router on a unidirectional link can be able to receive hello packets,  but the hello packets sent out are not received at the other end. The  existence of this state is usually indicated by the retry limit exceeded  messages on one end. If the routers generating retry limit exceeded  messages has to form neighborship, then make the link bidirectional for  both unicast and multicast. In case tunnel interfaces are used in the  topology make sure that the interfaces are advertised properLY......

                             

                            (means give nei.. another way to communicate with each other)

                            • 11. Re: EIGRP Neighborship flapping every 1min 20secs
                              Ashish

                              Thank you Paul.

                              in my case subnetmask were mismatching.