1 2 Previous Next 21 Replies Latest reply: Jan 13, 2014 6:33 AM by bob RSS

    2950G Switch - No terminal output

    Micah

      Hi all,

       

      I have a home lab setup with 3 routers and 3 switches along with an ASA device and an access server. I have setup reverse telnet through the access server and can access everything except for my "second switch" (2950G), so it shouldn't be a PuTTY configuration issue and I've tried another console cable after adding a new reverse telnet entry for cable 8. Now I know getting another switch isn't that expensive but I would like to see if I can salvage this one if possible - a learning experience at least.

       

       

       

      My ideas would be maybe reloading the IOS (c2950-i6k2l2q4-mz.121-22.EA14.bin or c2950-i6q4l2-mz.121-22.EA14.bin) or using another method for management like telnet or if supported by its IOS, SSH. However, the trick would be blindly using the CLI as I believe it accepts commands but I cannot get any visual confirmation through PuTTY and its serial/console connection. I get the below response which is normal but no prompt after hitting enter from the switch which is not normal. The LED lights are green (SYST and STAT) and plugging a crossover cable from a working switch to the problem switch results in green connectivity lights shortly after. Is it worth trying to you guys or should I just grab a new switch?

       

      AccessServer>S2

      Trying S2 (10.1.1.1, 2006)... Open

        • 1. Re: 2950G Switch - No terminal output
          Navneet.Gaur

          Hi Micah.

           

          1. Maybe this is a stupid question on my part, but have you tried to connect the console cable directly between the PC and the 2960 switch?

           

          Navneet.

          • 2. Re: 2950G Switch - No terminal output
            Aaron

            It might be baud rate issue. If you are using putty set the speed to 115200 and see what happens.

            • 3. Re: 2950G Switch - No terminal output
              bob

              Hi,

               

              As mentioned by Navneet, try to make a direct console connection to the switch.  You might have a bad octal cable going from the access server to the switch.  You can also try switching cables from the octal to the switch with a known good one.

               

              We need to know if you receive any output.  Even garbage.

               

              As 99% of the time if you get garbage, it is a baud rate issue.  Then you can reset the unit back to 9600 baud and be fine.  The way you reset it back to default is as follows.  Unplug the power.  Hold the mode button in while you plug the power cord in the back of the switch(yes, you need 3 hands to do this), keep the mode button held for about 15 to 20 seconds  and then release it.  See if you get any output then.

              • 4. Re: 2950G Switch - No terminal output
                Techietype

                Does the switch otherwise seem to be OK?  Do the lights sequence correctly through the POST?  Can the switch pass traffic?  If so, it seems unlikely that the console port is bad, but you never know.  If there is a speed mismatch between the console port and your terminal software, you will see garbage characters scrolling across the screen during the boot up.  It's a good sign that all you have to do is fix the console data rate, or number of stop or parity bits.

                 

                You can check the serial cable from your access server by trying it on one of your other devices.  It's OK to hot switch the cable between console ports.  In fact, if you open the reverse telenet session to a give device, the session should stay open even with the cable disconnected.

                 

                One more thing.  If you had a problem with the IOS image, the switch would probably boot into ROMON and you would see console output.  Just not the output you would expect.

                • 5. Re: 2950G Switch - No terminal output
                  bob

                  Techie...I have seen many times where the switch passes data just fine...but the console port went bad.  Just fyi.

                   

                  Micah...Techie just had me think of another thing to check.  Make sure none of the metal wires in the console port are shorted together.  Sometimes I seen techs jam console cables in there and damage the port.

                  • 6. Re: 2950G Switch - No terminal output
                    Micah

                    Bypassing the access server and plugging directly into the console port did not produce any output. I use a USB to serial adapter that has lights that blink during use (one for send, one for recieve) and only the send light responds on that switch connection.

                    • 7. Re: 2950G Switch - No terminal output
                      Micah

                      I created an 115200 baud rate connection and it did not pass any output either.

                      • 8. Re: 2950G Switch - No terminal output
                        Navneet.Gaur

                        Hi Micah.

                         

                        1. I am assuming that the USB adaptor works with other devices.

                         

                        2. Next thing that you may check is the functioning of the switch. Connect two devices to two of its ports & check if they are able to communicate with each other.

                         

                        3. The lights status of the switch that you have mentioned do not seem to indicate any malfunction as such.

                         

                        Take care,

                        Navneet.

                        • 9. Re: 2950G Switch - No terminal output
                          Navneet.Gaur

                          It does seem to narrow down to consol port malfunction. If possible, replace the console port set from another one of the switches that you have & see if that makes any difference.

                           

                          It is not very difficult. Once you open the chasis, you have to gently but firmly pull out the connector wire strip from the motherboard. Make sure that the connecting arrangment does not have any movable clips - you may need to remove it first, if that is the case, to detach the connecting wire strip.

                           

                          That is, if the equipment that you have does not have any replacement coverage.

                           

                          Navneet.

                          • 10. Re: 2950G Switch - No terminal output
                            Micah

                            I have 2 2950Gs and rebooting the one I have access to gives me the same POST lights as the switch that does not give me any output. I'm not sure how I can test connectivity besides what the lights tell me on the ports as I have not configured this router at all yet (purchased over the internet).

                             

                            I've tried directly connecting the rollover cable and using another cable on the octal after adding a new entry for reverse telnet and no luck so far.

                            • 11. Re: 2950G Switch - No terminal output
                              Micah

                              I checked the console port with a flashlight and it looks good, nothing crossed up or jammed in there.

                              • 12. Re: 2950G Switch - No terminal output
                                Micah

                                I can confirm I can ping from one device to another while they are connected to the problem switch.

                                • 13. Re: 2950G Switch - No terminal output
                                  Navneet.Gaur

                                  That is good news. Now you may try to replace the console cable from the one in the other switch - only if the switch you have is not covered under replacement warranty. In that case, send it for replacement.

                                   

                                  I have the photographs. I am preparing them before upload.

                                   

                                  Navneet.

                                  • 14. Replace console cable
                                    Navneet.Gaur

                                    Update:

                                    Please read post numbered 16 before you follow the instructions below.

                                     

                                    Here are the pictures. These are from 2950.

                                     

                                    1. Once you have unscrewed the screws on the rear of the switch, slide the cover - do not lift -{ you may need to apply some force to slide it }- to remove it and open the switch.

                                     

                                    Follow the console connector to relate to the picture below. This is the other end of the console connector inside the switch.

                                    Replace - Console cable - Cable clip and connector.png

                                     

                                    2.

                                    Replace - Console cable - Clip closed.png

                                     

                                    3. Pull the clip upwards - gently. It is a movable part of the connector on the motherboard and will remain attached to it.

                                     

                                    Replace - Console cable - Pull up to open.png

                                     

                                    4. Now gently pull up the ribbon wire to detach it from the motherboard connector.

                                     

                                    Replace - Console cable - 4.png

                                     

                                    5.

                                     

                                    Replace - Console cable - Console connector.png

                                     

                                    6. Repeat the same process on the other switch & use its console cable with this switch. If the problem is solved, well and good. If not, then I am afraid, I can not be of much help.

                                     

                                    Take care,

                                    Navneet.

                                    1 2 Previous Next