1 2 Previous Next 21 Replies Latest reply: May 16, 2018 10:51 AM by jay.johnson1, CCNA (IOS Security), CCNA (R/S), CCNA (Voice), CCDA, CCNP (R/S) RSS

    NTP Issue CUCM 8

    Bilal

      Hey Guys! i Need help here. I still cannot resolve my issue with NTP if anyone can help me ill be thankful. Im trying to Use GNs3 to set a NTP router. Im connecting a C1 cloud to a router. Here is a detailed instillation:

       

       

      First on my PC

      I open Control Panel >Network & Internet > Networking & sharing center> i have two connection 1- Vmware Network Adapter VmNet 1 with ip address 192.168.203.1/24

      2- Vmnet 8 ip add: 192.168.174.1/24

      Then i disable Firewall

      Note: my sony PC ip address is 192.168.1.103

      ---------------------------------------------------------------------------------------------------------

      GNS3

      Well from my understanding we are trying to connect Vmare to GNS3, so the virtual PC should be connected to the VM adapter as shown above. Therefore, on Gns3, i configured a router and cloud 1. C1 node > NIO UDP click on add. Then open VPC and configure an ip and a gw but im not sure what ip i should use. i think here is my miss understanding. if i will use Vmnet 1, then im using the subnet mask 192.168.203.0/24. Anyways, i open vpc and typed> "ip 192.168. 203.3 192.168.203.2 24" i gave my Virtual PC and ip address and a gw. notice above my VM adapter is 192.168.203.1

      Also not sure of the Gw

       

       

      Router:

      enable

      clock set 5:05:00 29 NOV 2013

      configure terminal

      ntp master

      exit

      show ntp status

      configure terminal

      interface FastEthernet0/0

      ip address 192.168.203.4 255.255.255.0

      no shutdown

      do copy run start

      Try to ping host that i give an ip address 192.168.203.3.... R1# p 192.168.203.3

      and its a success

      ------------------------------------------------------------------------------------------------------------------

      Vmware.

      I upload the image.. Operating system > Linux red hat enterprise 3>Disk size >80 Gb>Custom Hardware> Memory to 2 GB and under NAT>Custom Specific virtual network >

      Here as i said in the beginning that i have Vmnet 1 and Vmnet 8.. Under Vmware Vmnet 1(Host-only) and Vmnet 8 (NAT).. Anyways i chose Vmnet 1.Then i power on my VM and things work very well.

      Now when  it comes to giving the CUCM an ip

       

       

      Name: CUCM

      Ip address: 192.168.203.5

      Subnet: 255.255.255.0

      Gatway: 192.168.203.1

      As u can see, i gave the CUCM an ip address with the same subnet used, and the Gw i gave it the Vmnet1 Adpter Ip address, please check the first thing i wrote.

       

       

       

       

      Now when it comes to NTP

      I enter the ip of the Cisco Router which i configured NTP on GNS3.

      Ip address: 192.168.203.4

       

       

      Sadly after installation it says that NTP is not configued well and its inaccessibly

       

       

      Can anyone help me here. What i did wrong, i just feel i have issues with setting my Virtual PC on GNS3.

      ----------------------------------------------------------------------------------------------------

       

       

      I look forward for anyone to help me and many thanx 

        • 1. Re: NTP Issue CUCM 8
          Patrick Geschwindner - CCIE R&S, CCSI

          Since you can ping the IP-address of the UCM, your layer 2/3 is working. UCM wants a stratum of your NTP server better than 10 (as far I recall).

           

          Configure your router as "ntp master 4", that should fix the precision problem UCM is complaining about

          • 2. Re: NTP Issue CUCM 8
            Bilal

            Hey Patrick

             

            Thank you for your reply. What i was able to ping is the virtual PC i made. Please review my post again, i have given the CUCM an ip address 192.168.203.5 but my gns3 router was not able to ping it. I think i have issues with the virtual PC i made. probably the gw.

            • 3. Re: NTP Issue CUCM 8
              Patrick Geschwindner - CCIE R&S, CCSI

              There is no difference in the configuration if you connect a virtual PC or the Virtual machine of the CUCM. If you cannot ping the CUCM, you have a VMware interface mismatch to whatever interface you are using to bing your GNS3-Router and the Virtual PC together. Once you have this fixed your CUCM should be pingable.

               

              For the VMs use bridged mode or host only. You don't need any IP on the VMware adapters. Don't use NAT or UDP tunnel as you described it. VMware does not support UDP tunnel. There is no possibility to add the UDP ports either. All these added functionalities are making communication unnecessary complex.

              • 4. Re: NTP Issue CUCM 8
                Bilal

                What im trying to do is to install my CUCM on a VMware. I created a virtual PC so i can link between my NTP router and CUCM. Whatt im trying to do is to connect to VM to GNS3

                 

                I created a virtual PC and gave it the IP address 192.168.203.3 and a gateway 192.168.203.2
                The link between the cloud and my router has the subnet of 192.168.203.0/24 and the port connected to the NTP router f0/0 has the gateway ip add 192.168.203.2

                then i installed my CUCM on Vmare using Custom VMet 1 (host only) whos ip is 192.168.203.1/24

                THe CUCM on vmware is given the name of CUCM > IP 192.168.203.5 and for the gatway i also entered the VMnet 1 ip address 192.168.203.1

                For NTP ip address on CUCM i also entered the gw ip address 192.168.203.2

                 

                with all of this i cant access my NTP router

                 

                is there is anything wrong with my Ip's? IS the gatway ip address of virtual PC is also the NTP routers ip that i applied on CUCM?

                • 5. Re: NTP Issue CUCM 8
                  Patrick Geschwindner - CCIE R&S, CCSI

                  What you are lacking is L2 connectivity. As you described above, you are using UDP tunnel between your router connected cloud and the VPC. VMware has no possibility to communicate via a UDP tunnel, Virtualbox can, but VMware cannot.

                   

                  You need to use bridged networks between VMware and your GNS cloud. Do not use the VMware interfaces 1 and 8, theses are for NAT and DHCP.

                   

                  Your VPC (if this is the DOS-BOX like application) will not help you connecting to CUCM because it cannot do SSH. CUCM will accept SSH connections only.

                   

                  To manage CUCM you need a browser interface (do not use IE11, use IE10 or firefox). The best would be to use the browser on your physical PC. To connect all these together (GNS-router, VMware and your PC), put your PC into the same subnet than your router and the CUCM. In the VM network setting check "bridged" and to make your router connect to your PC interface use the NIO Ethernet tab in GNS3. I added two screenshots for these settings

                   

                  Screenshot_11.png

                  Screenshot_12.png

                  • 6. Re: NTP Issue CUCM 8
                    Alamedian

                    Hi Bilal,

                     

                    Are you using the VMware player? If so... make sure that you are using the latest. The latest version of player allows you to select which interface to bridge with. If you are not using the latest version of player, I suggest that you upgrade. Older version of player did not give you the option of selection which net to bridge with.

                     

                    -Next turn off your firewall (I know you said this was already done.

                     

                    -Create a PC loopback with a private address. Do not use the same network as your home network (ust to be cautious).

                     

                    -Start GNS and create a cloud interface. Select the virtual  interface you just created.

                     

                    -Create a router and enable an Ethernet interface. Put this interface in the same net as the PC loopback address.

                     

                    - Make this router a time server with the following commands "ntp master" and "ntp server x.x.x.x" Use the enet interface address that you just created.

                     

                    -From the router interface ping the PC loopback address. Just to be carfull, from the PC ping the router.

                     

                    - Create a VM and make certain that your VM is bridged to a virtual interface on your PC. (Do not go into windows networing and make any changes!)

                     

                    -Just fill in the blanks when you do the install. If the pings worked than the install should be smooth sailing.

                    • 7. Re: NTP Issue CUCM 8
                      Bilal

                      Thanx buddy and ill try what you told me, check out this link ppl did it how i dont know thats why im asking for help and as i said ill do what you guys told me http://cisconerd.wordpress.com/2012/01/24/cucm-install-in-vmware-ntp-issue/

                      • 8. Re: NTP Issue CUCM 8
                        Patrick Geschwindner - CCIE R&S, CCSI

                        yes, this is a good example, but as I mentioned above, it is using bridged networking, not UDP tunnel in GNS3 or NAT on the VMware side

                        • 9. Re: NTP Issue CUCM 8
                          jay.johnson1, CCNA (IOS Security), CCNA (R/S), CCNA (Voice), CCDA, CCNP (R/S)

                          Hey guys...

                           

                          Bilal, my thoughts are in line with both Patrick and Alamedian for the most part.  Being that they've alread suggested some tried and true methods, I'll just volunteer something a little off the beaten path based on what I've been doing with installing CUCM in virtual enviroments...

                           

                          NTP Server Installation:  As Patrick stated,it's recommended you use stratum 4 (just don't use "5" or higher); however, if you just issue the command "NTP Master," that's all that the CUCM server requires for the most part to register (not the most optimum, but it works).

                           

                          Now, if you're NTP server is not registering from the beginning, you shouldn't even be able to complete the installation of CUCM.  So, before I ask anymore questions, are you actually getting through the full installation of CUCM or are you stuck at the part during install where CUCM is still looking for an NTP server?  I'm familiar with this as of late because of messing this part up a lot..

                           

                          As has been stated, you need to make sure that the adapter you're using to bridge your CUCM server into GNS3 is configured correctly:  https://learningnetwork.cisco.com/videos/2152

                           

                          Take a look at the 4:40 mark of this video (this is going to reinforce to a degree what Patrick was referring to).  Personally, I like to specifically identify the adapter I'm planning to use (Custom: Specific Network Adapter) because sometimes it gets overlooked that there's an additional menu setting that you need to check to ensure the adapter connects (found under edit ---> virtual network editor).

                           

                          Once under "virtual network editor," you should see all of the available vmnet adapters as well as the bridged adapter for that particular computer you're using.  For example, if you choose "vmnet 8" under either "host only" or "Custom: Specific Network Adapter," you need to make sure that adapter is configured for the correct subnet you want it to take part on.  Let's say you choose (as an example) "vmnet8" under the "Custom: Specific Network Adapter" drop down menu from the first settings page; once you go to "edit ---> virtual network editor," highlight the adapter you chose on the first menu (again, vmnet in this example).

                           

                          Once you highlight the adapter you're going to use, look towards the bottom and make sure choose the "host only" option towards the bottom of the dialog box as well as putting a check in the "connect a virtual host adapter to this network" box (leave the dhcp server option blank unless you plan on using one).  Next, you just need to specify the subnet "and" mask that machine is going to be participating on.  Click apply and save; from there you "should" be good.

                           

                          I could have sworn I made a video of something and highlighted this aspect; if not, I will in the future :-)

                           

                          Let us know if this helps.

                           

                          Jay

                          • 10. Re: NTP Issue CUCM 8
                            Bilal

                            Thank you so much it worked well and just finished installation. It works well just Vmware makes my laptop heavy and keeps on freezing for few seconds. Again many thanx for ur help and patience. Now i will just click on VMare " i finished installing" and the CUCM will be saved?

                            • 11. Re: NTP Issue CUCM 8
                              Bilal

                              Hey! thanx alot i used patricks method and it worked fine as i told him its Vmare makes my laptop heavy and from time to time it freezes for few seconds but its not harmfull. Now after im done ill click on "i finished installation and CUCM will be saved on VM?

                              • 12. Re: NTP Issue CUCM 8
                                Bilal

                                Thank you i used patrick method and it worked well

                                • 13. Re: NTP Issue CUCM 8
                                  jay.johnson1, CCNA (IOS Security), CCNA (R/S), CCNA (Voice), CCDA, CCNP (R/S)

                                  Yep, that should be it...  :-)

                                   

                                  Jay

                                  1 2 Previous Next