3 Replies Latest reply: Jun 6, 2009 2:35 AM by Conwyn RSS

    How to change 'bridge 1 route ip' to 'bridge 21 route ip' ??

    Lawrence

      Hi,

       

      I have configured 2 vlans on my Cisco AP1242, will only broadcast 1 vlan. Details below;

       

      vlan 21 - management vlan (native)

      vlan 51 - guest vlan

       

      i am having problem removing or change the default 'bridge 1 route ip' to support 'bridge 21 route ip'.

       

      Anybody, please assist !!

       

      Best regards,

      Lawrence Chew

        • 1. Re: How to change 'bridge 1 route ip' to 'bridge 21 route ip' ??
          Conwyn

          Hi Lawerence

           

          What do you have for your BVI1 or BVI21?

           

           

          bridge route

          To enable the routing of a specified protocol in a specified bridge group, use the bridge route command in global configuration mode. To disable the routing of a specified protocol in a specified bridge group, use the no form of this command.

          bridge bridge-group route protocol

          no bridge bridge-group route protocol

          Syntax Description

          bridge-group

          Bridge group number specified in the bridge protocol command.

          protocol

          One of the following protocols:

          appletalk

          clns

          decnet

          ip

          ipx.

           

           

           

           

          My config below.

           

          Regards Conwyn

           

          dot11 ssid Conwyn Phone
             vlan 2
             authentication open eap eap_methods1
             authentication network-eap eap_methods1
             authentication key-management wpa
             accounting acct_methods1
             mbssid guest-mode
          !
          dot11 ssid Conwyn Guest
             vlan 1
             authentication open
             authentication key-management wpa
             accounting acct_methods1
             guest-mode
             mbssid guest-mode
             wpa-psk ascii  TheCLNetwork
          !
          dot11 ssid Conwyn Secure
             vlan 4
             authentication open eap eap_methods1
             authentication network-eap eap_methods1
             authentication key-management wpa
             accounting acct_methods1
             mbssid guest-mode

          bridge irb
          !
          !
          interface Dot11Radio0
          no ip address
          no ip route-cache
          !
          encryption vlan 1 mode ciphers aes-ccm tkip
          !
          encryption vlan 4 mode ciphers aes-ccm tkip
          !
          encryption vlan 2 mode ciphers aes-ccm tkip
          !
          ssid Conwyn Phone
          !
          ssid Conwyn Guest
          !
          ssid Conwyn Secure
          !
          mbssid
          station-role root
          !
          interface Dot11Radio0.1
          encapsulation dot1Q 1 native
          no ip route-cache
          no snmp trap link-status
          bridge-group 1
          bridge-group 1 subscriber-loop-control
          bridge-group 1 block-unknown-source
          no bridge-group 1 source-learning
          no bridge-group 1 unicast-flooding
          bridge-group 1 spanning-disabled
          !
          interface Dot11Radio0.2
          encapsulation dot1Q 2
          no ip route-cache
          no snmp trap link-status
          bridge-group 2
          bridge-group 2 subscriber-loop-control
          bridge-group 2 block-unknown-source
          no bridge-group 2 source-learning
          no bridge-group 2 unicast-flooding
          bridge-group 2 spanning-disabled
          !
          interface Dot11Radio0.4
          encapsulation dot1Q 4
          no ip route-cache
          shutdown
          no snmp trap link-status
          bridge-group 4
          bridge-group 4 subscriber-loop-control
          bridge-group 4 block-unknown-source
          no bridge-group 4 source-learning
          no bridge-group 4 unicast-flooding
          bridge-group 4 spanning-disabled
          !
          interface Dot11Radio1
          no ip address
          no ip route-cache
          shutdown
          no dfs band block
          channel dfs
          station-role root
          bridge-group 1
          bridge-group 1 subscriber-loop-control
          bridge-group 1 block-unknown-source
          no bridge-group 1 source-learning
          no bridge-group 1 unicast-flooding
          bridge-group 1 spanning-disabled
          !
          interface FastEthernet0
          no ip address
          no ip route-cache
          duplex auto
          speed auto
          !
          interface FastEthernet0.1
          encapsulation dot1Q 1 native
          no ip route-cache
          no snmp trap link-status
          bridge-group 1
          no bridge-group 1 source-learning
          bridge-group 1 spanning-disabled
          !
          interface FastEthernet0.2
          encapsulation dot1Q 2
          no ip route-cache
          no snmp trap link-status
          bridge-group 2
          no bridge-group 2 source-learning
          bridge-group 2 spanning-disabled
          !
          interface FastEthernet0.4
          encapsulation dot1Q 4
          no ip route-cache
          no snmp trap link-status
          bridge-group 4
          no bridge-group 4 source-learning
          bridge-group 4 spanning-disabled
          !
          interface BVI1
          ip address 10.0.0.1 255.255.255.0
          no ip route-cache
          !
          ip default-gateway 10.0.0.254

          bridge 1 route ip

          • 2. Re: How to change 'bridge 1 route ip' to 'bridge 21 route ip' ??
            Lawrence

            Hi Conwyn,

             

            Your native is vlan 1, so if i set my native to vlan 21 should i also need to do 'bridge 21 route ip' instead of 'bridge 1 route ip' ? I was do an experiment on this and works fine for 'bridge 1 route ip' if my native is on vlan 1. So now, my native vlan is 21. Please assist.

             

            I also noticed you used single guest-mode for guest, and assigned mbssid guest-mode for all. Why is this?

             

            Best regards,

            Lawrence Chew

            • 3. Re: How to change 'bridge 1 route ip' to 'bridge 21 route ip' ??
              Conwyn

              Hi Lawerence

               

              Have tried setting the native vlan to 21

               

              and no bridge 1 route ip

                         bridge 21 route  ip

               

              The guest keywords were just copied blindly. I am not a wireless man I was just testing my 7921 WiFi phone. Sorry if the guest keywords confused you.

               

              Regards Conwyn