9 Replies Latest reply: Feb 11, 2014 4:57 PM by net99 RSS

    HSRP Configuration

    Sathish Kumar

      HSRP Configuration:


      R1 Configuration:

      R1(Config)#interface fa0/0

      R1(Config-if)#ip address 10.0.0.1 255.0.0.0

      R1(Config-if)#no shutdown

      R1(Config-if)#standby 1 priority 190

      R1(Config-if)#standby 1 ip 10.0.0.5

      R1(Config-if)#standby 1 preempt

      R1(Config)#interface fa0/1

      R1(Config-if)#ip address 20.0.0.1 255.0.0.0

      R1(Config-if)#no shutdown

      R1(config)#router rip

      R1(config-router)#network 10.0.0.0

      R1(config-router)#network 20.0.0.0


       

      R2 Configuration:

      R2(Config)#interface fa0/0

      R2(Config-if)#ip address 10.0.0.1 255.0.0.0

      R2(Config-if)#no shutdown

      R2(Config-if)#standby 1 priority 200

      R2(Config-if)#standby 1 ip 10.0.0.5

      R2(Config-if)#standby 1 preempt

      R2(Config-if)#standby 1 track fa0/1 20

      R2(Config)#interface fa0/1

      R2(Config-if)#ip address 30.0.0.1 255.0.0.0

      R2(Config-if)#no shutdown

      R2(config)#router rip

      R2(config-router)#network 10.0.0.0

      R2(config-router)#network 30.0.0.0

       

      R3 Configuration:

      R3(Config)#interface fa0/0

      R3(Config-if)#ip address 30.0.0.2 255.0.0.0

      R3(Config-if)#no shutdown

      R3(Config)#interface fa0/1

      R3(Config-if)#ip address 20.0.0.2 255.0.0.0

      R3(Config-if)#no shutdown

      R3(Config)#interface fa2/0

      R3(Config-if)#ip address 40.0.0.1 255.0.0.0

      R3(Config-if)#no shutdown

      R3(config)#router rip

      R3(config-router)#network 20.0.0.0

      R3(config-router)#network 30.0.0.0

      R3(config-router)#network 40.0.0.0

       

      PC C1 IP Add: 10.0.0.2 255.0.0.0 10.0.0.5(GW Virtual IP of HSRP)

      PC C2 IP Add: 40.0.0.1 255.0.0.0 40.0.0.1(GW)


       

      HSRP.jpg

       

      Notes:

      1. HSRP is a Cisco proprietary

      2. HSRP hello time 3sec

      3. HSRP hold time 10sec

      4. HSRP preempt want to manually enable.

      5. HSRP Particular port can be monitor Due to that Router priority can be decrement. Highest priority in HSRP Group became active.

      6. HSRP adjacency states Init, learn, listen, speak, standby, active.

       

       


       

      Message was edited by: Sathish

       

      Message was edited by: Sathish