7 Replies Latest reply: Feb 13, 2013 2:13 PM by jgmarr RSS

    multiple vlan need to assign in switch access port

    Prakash

      Hi,

       

      I want to connect different Vlan Pc in a single access port of cisco 2690. When i'm connecting single PC in single port it is normal. I'm doning below configuration

      interface GigabitEthernet1/0/39

      switchport mode access

      switchport access vlan 101

       

      But i need to connect multiple laptops(from different network) in discussion room using same switch port throug hub.

       

      Could u pls anyone help me on thi.

        • 1. Re: multiple vlan need to assign in switch access port
          cadetalain

          Hi,

          if you do this then all hosts will be considered as belonging to the same VLAN but they are  in  different subnets so you would have to configure secondary addresses on the L3 device doing the intervlan routing.

           

          Regards

           

          Alain

          • 2. Re: multiple vlan need to assign in switch access port
            Deepak

            Hi,

             

            If i understand it correctly you want to assign single switch port to multiple VLAN's right? if thats yes then its not possible because basic rule of VLAN is we have to assign single port to single VLAN at given point of time. Using subinterfaces is different thing.

            Yes you can try above solution provided by Cadetalain.

             

             

            HTH,

            Deepak

            • 3. Re: multiple vlan need to assign in switch access port
              JamesVallespin

              but if you really wanted to create that setup you should replace that hub with a manageable switch, then trunk it and assign each access port on its designated vlan.

               

              hi Alain,

               

              out of curiosity i try what you said on PT, but its not working on me.

              only one user can ping its gateway ( all pc's are correctly configure )

              am i missing something

               

              3 pc ( 3 different subnets )< -> hub <-> Layer 3 switch (3560) (fa0/1)

               

               


               

              Building configuration...

               

               

              Current configuration : 1390 bytes

              !

              version 12.2

              no service timestamps log datetime msec

              no service timestamps debug datetime msec

              no service password-encryption

              !

              hostname Switch

              !

              !

              !

              !

              !

              ip routing

              !

              !

              !

              !

              !

              !

              !

              !

              !

              !

              spanning-tree mode pvst

              !

              !

              !

              !

              interface FastEthernet0/1

              switchport access vlan 2

              switchport mode access

              spanning-tree portfast

              !

              interface FastEthernet0/2

              !

              interface FastEthernet0/3

              switchport access vlan 3

              switchport mode access

              !

              interface FastEthernet0/4

              switchport access vlan 4

              !

              interface FastEthernet0/5

              !

              interface FastEthernet0/6

              !

              interface FastEthernet0/7

              !

              interface FastEthernet0/8

              !

              interface FastEthernet0/9

              !

              interface FastEthernet0/10

              !

              interface FastEthernet0/11

              !

              interface FastEthernet0/12

              !

              interface FastEthernet0/13

              !

              interface FastEthernet0/14

              !

              interface FastEthernet0/15

              !

              interface FastEthernet0/16

              !

              interface FastEthernet0/17

              !

              interface FastEthernet0/18

              !

              interface FastEthernet0/19

              !

              interface FastEthernet0/20

              !

              interface FastEthernet0/21

              !

              interface FastEthernet0/22

              !

              interface FastEthernet0/23

              !

              interface FastEthernet0/24

              !

              interface GigabitEthernet0/1

              !

              interface GigabitEthernet0/2

              !

              interface Vlan1

              no ip address

              shutdown

              !

              interface Vlan2

              ip address 192.168.1.1 255.255.255.0

              !

              interface Vlan3

              ip address 172.16.1.1 255.255.0.0

              !

              interface Vlan4

              ip address 10.10.10.1 255.0.0.0

              !

              ip classless

              !

              !

              !

              !

              !

              !

              • 4. Re: multiple vlan need to assign in switch access port
                cadetalain

                Hi,

                 

                PT doesn't support secondary addresses.

                 

                Regards.

                 

                Alain

                • 5. Re: multiple vlan need to assign in switch access port
                  Prakash

                  Yes, Creating secondary ip address in L3 switch will come under the single vlan and multiple address. It will change the whole setup. I need to connect my disscussion room with multiple vlan.

                  • 6. Re: multiple vlan need to assign in switch access port
                    Prakash

                    but in this i'm connecting (3different users) -> (L2 2960) -> (L3 4506E). Totally 5 Vlans assigned, and Each PC connected ports are assingned with single vlan. If we connected like this.

                     

                    I need some vialation to connect the disscusion room in this setup, that need to connect any kind of IP segments in disscussion room.

                    • 7. Re: multiple vlan need to assign in switch access port
                      jgmarr

                      Perhaps dynamic vlan membership helps. In this case vlan are assigned regarding the user MAC address.

                      Check the section dynamic vlan in the bellow link.

                       

                      http://www.ciscopress.com/articles/article.asp?p=29803&seqNum=2

                       

                      Hope helps.