0 Replies Latest reply: Nov 20, 2012 1:17 PM by Ravi LUCHMUN RSS

    CME + SIP (endpoints registering with sip provider instead of router)

    Ravi LUCHMUN

      Hi,

       

      I am new to VoIP and experimenting with Cisco CME and using a SIP trunk to reach the PSTN.

      I am unable to make external calls and when I checked with the SIP provider, they said my end points (extensions) are trying to register with the SIP provider instead of my router itself.

       

      CME_2821#sh sip register st

      Line          peer           expires(sec)  registered

      ============  =============  ============  ===========

      1001          20001            19            no

      1002          20002            70            no

      1003          20003            67            no

      1004          20004            67            no

       

      If the ephone-dn for one of the above is changed to 3213765584, which is the SIP account number, the call will go through but only for that extension.

       

      The SIP service is up.

      I am not too sure how to start troubleshooting this.

       

      !
      version 12.4
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname CME_2821
      !
      boot-start-marker
      boot system flash:c2800nm-advipservicesk9-mz.124-7c.bin
      boot-end-marker
      !
      enable secret 5 $1$PZG6$P881l5QSKZIOKWyZQSWQJ/
      !
      no aaa new-model
      !
      resource policy
      !
      clock timezone London 0
      !
      !
      
      ip cef
      no ip dhcp use vrf connected
      ip dhcp excluded-address 10.0.0.1 10.0.0.10
      !
      ip dhcp pool ITS
         network 10.0.0.0 255.255.255.0
         option 150 ip 10.0.0.1
         default-router 10.0.0.1
      !
      !
      !
      !
      voice-card 0
       no dspfarm
      !
      !
      !
      voice service voip
       allow-connections h323 to h323
       allow-connections h323 to sip
       allow-connections sip to h323
       allow-connections sip to sip
       sip
       bind control source-interface GigabitEthernet0/0
        bind media source-interface GigabitEthernet0/0
        registrar server expires max 3600 min 3600
        no call service stop
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      voice translation-rule 1
       rule 1 /\(^9\)/ //
      !
      !
      voice translation-profile DiscardDigit9
       translate called 1
      !
      !
      !
      interface GigabitEthernet0/0
       description LAN
       ip address 10.0.0.1 255.255.255.0
       ip nat inside
       ip virtual-reassembly
       duplex auto
       speed auto
      !
      interface GigabitEthernet0/1
       description UPLINK to Adsl router
       ip address dhcp
       ip nat outside
       ip virtual-reassembly
       duplex auto
       speed auto
      !
      no ip http server
      no ip http secure-server
      ip nat inside source list 1 interface GigabitEthernet0/1 overload
      !
      access-list 1 remark allow Internet
      access-list 1 permit 10.0.0.0 0.0.0.255
      !
      !
      !
      !
      control-plane
      !
      !
      !
      !
      !
      !
      !
      dial-peer voice 100 voip
       translation-profile outgoing DiscardDigit9
       destination-pattern 9T
      session protocol sipv2
       session target sip-server
       dtmf-relay sip-notify rtp-nte
       codec g711alaw
       no vad
      !
      sip-ua
       authentication username 3213765584 password 0876185642455355
       no remote-party-id
       retry invite 2
       retry register 10
       registrar dns:ha-sip01.directvoip.co.uk expires 3600
       sip-server dns:ha-sip01.directvoip.co.uk
      !
      !
      !
      !
      telephony-service
       max-ephones 2
       max-dn 10
       ip source-address 10.0.0.1 port 2000
       auto assign 1 to 2
       network-locale GB
      time-format 24
       date-format dd-mm-yy
       create cnf-files version-stamp Jan 01 2002 00:00:00
       max-conferences 8 gain -6
       transfer-system full-consult
      !
      !
      ephone-dn  1  dual-line
       number 1001
       name Test 7941
      !
      !
      ephone-dn  2  dual-line
       number 1002
       description Ravi-Home
      !
      !
      ephone-dn  3  dual-line
       number 1003
      !
      !
      ephone-dn  4  dual-line
       number 1004
      ephone  1
       description Cisco IPC
       mac-address 0050.B650.1A1A
       type CIPC
       button  1:3 2:4 3:1
      !
      !
      !
      ephone  2
       description Cisco 7941
       mac-address 001D.450C.12F1
       button  1:1 2:2
      !
      !
      
      Please, can someone help me understand what's wrong with the above ?