7 Replies Latest reply: Oct 3, 2014 1:52 PM by CARLOS RSS

    Configuring VRF lite IOS XR

    raul-moya

      Hello, I need to configure VRF lite with IOS XR, help me.

       

      Normal IOS:


      ip vrf example
      rd 7:20
      route-target export 7:20
      route-target import 7:20

      int vlan 200
      ip vrf forwarding example
      ip address 192.168.0.1 255.255.255.0

      router ospf 1
      network 192.168.0.1 0.0.0.255 area 0

       

       

      IOS XR:

       

      ???

       

       

       

       

      Good bye, good luck

        • 1. Re: Configuring VRF lite IOS XR
          Leon van Dongen

          Hi Raul,

           

          Actually it's simpler than you'd expect.

           

          The configuration for VRF lite is only slightly different than what you're used to do on classic IOS.

           

          vrf example
          ! 
           export route-target
            7:20
           import route-target
            7:20
          !
          interface GigabitEthernet0/0/0/0.200
           encapsulation dot1q 200
           vrf example
           ipv4 address 192.168.0.1 255.255.255.255.0
          !
          router ospf 1
           vrf example
            area 0
             interface GigabitEthernet0/0/0/0.200


          I recommend that you to read IOS XR Fundamentals book or simply refer to the configuration guides on Cisco.com.

          http://www.cisco.com/en/US/products/ps5845/products_installation_and_configuration_guides_list.html

           

          Regards,

          Leon

          • 2. Re: Configuring VRF lite IOS XR
            raul-moya

            Thank very much.

             

            Good luck, friend.

            • 3. Re: Configuring VRF lite IOS XR
              fernandesdb

              Hello everyone ! Isnt it mandatory to use the rd (route distinguisher)?

               

              ip vrf blue

              rd 100:1

               

              Thanks in advance...

              • 4. Re: Configuring VRF lite IOS XR
                Leon van Dongen

                Hi,

                 

                The route-distinguisher is used to exchange prefixes (7:20:192.168.1.0/24) between MP-BGP speakers and is not mandatory when configuring VRF-Lite.

                 

                In IOS-XR the configuration for the RD does not go under the VRF configuration hierachy, but rather under the BGP hierarchy.

                 

                vrf example
                !
                export route-target
                  7:20
                import route-target
                  7:20
                !
                router bgp
                 !
                 address-family ipv4 unicast
                  allocate-label all
                 !
                 address-family vpnv4 unicast
                 !
                 neighbor 192.168.1.1
                  remote-as 100
                  update-source Loopback0
                  !
                  address-family vpnv4 unicast
                   vrf example
                     rd 7:20
                   !
                  !
                 !
                !
                

                 

                Hope this clarifies it for you.

                • 5. Re: Configuring VRF lite IOS XR
                  Ayesha...

                  Hi Leon,

                   

                   

                  When it comes to VRF Lite it is mandatory to add the RD value in-order to send/receive traffic and at the same time to activate the VRF. Isn't it?

                   

                  Sorry I am very new to it but I have read it on the cisco doc.

                   

                  Thank you for clarifying.

                  ...

                  Ayesha

                  • 6. Re: Configuring VRF lite IOS XR
                    Scott Morris - CCDE/4xCCIE/2xJNCIE

                    When it comes to creating a VRF, you must specify an RD.  Even locally, this is used to distiguish the routes from one VRF to the next.  If you aren't running MBGP, then you simply aren't passing the information to anyone else.

                     

                    A while ago, the behavior was that if you didn't create an RD, once you left the VRF config portion, it would disappear.  I'm not sure if that is still the case, but that used to be.

                     

                    Scott

                    • 7. Re: Configuring VRF lite IOS XR
                      CARLOS

                      Dear maybe can help me ?

                       

                      In the ER effect Colgate IP segment 186.166.131.0/28 known in the VRF BGP DM-COL through PED76CAN03, however not in the same VRF segment 200.6.27.0/24 it is observed that owns the IP destination peer.
                      · The peer 200.6.27.0/24 containing the destination is in the Global routing table that is through which all Internet routing table is known as it is this which communicates with the IR, this table overall no known 186.166.131.0/28 through the developing countries but by a / 24 as published in the IR Null.
                      · Under the above scenario if the ASA M2M try to create the tunnel against traffic 200.6.27.X hit the ER in the VRF-COL DM who does not have the destination in the routing table so it will use the default route and flow eventually be discarded. In the opposite direction to get the traffic originated by the 200.6.27.X the ICOR for the IP 186.166.131.4 will treat routed by having the IR / 24 segment pointing to a Null0.
                      · You need to know the global table for 186.166.131.0/28 in this manner will be announced to the IR and ICOR this route more specifically achieving traffic so that segment is sent to the ER.
                      · It is necessary that the VRF DM-LOC 200.6.27.X to know the traffic is sent to the ICOR and this is finally routed.
                            From the above it follows that such selective imports and exports from the VRF to the global table and vice versa are necessary.
                      In the ER effect Colgate IP segment 186.166.131.0/28 known in the VRF BGP DM-COL through PED76CAN03, however not in the same VRF segment 200.6.27.0/24 it is observed that owns the IP destination peer.

                       

                      · The peer 200.6.27.0/24 containing the destination is in the Global routing table that is through which all Internet routing table is known as it is this which communicates with the IR, this table overall no known 186.166.131.0/28 through the developing countries but by a / 24 as published in the IR Null.

                       

                      · Under the above scenario if the ASA M2M try to create the tunnel against traffic 200.6.27.X hit the ER in the VRF-COL DM who does not have the destination in the routing table so it will use the default route and flow eventually be discarded. In the opposite direction to get the traffic originated by the 200.6.27.X the ICOR for the IP 186.166.131.4 will treat routed by having the IR / 24 segment pointing to a Null0.

                       

                      · You need to know the global table for 186.166.131.0/28 in this manner will be announced to the IR and ICOR this route more specifically achieving traffic so that segment is sent to the ER.

                       

                      · It is necessary that the VRF DM-LOC 200.6.27.X to know the traffic is sent to the ICOR and this is finally routed.

                       

                       

                            From the above it follows that such selective imports and exports from the VRF to the global table and vice versa are necessary.