12 Replies Latest reply: Sep 11, 2012 11:35 PM by Anders Jul Jensen RSS

    Cisco Voice-VLAN

    Chad Spears CCNP CCDA CCNAS

      Hello All-

       

      Doing some remote work tonight and running into a strange issue, just wanted to see if anyone has seen this before or have any other insight.

       

      I have the following:

       

      Catalyst 2960

      Vlan 1= Data

      Vlan 2= Voice

       

      Interface fa0/2 connects to a router that provides DHCP services and acts as a default gateway for the Voice vlan (VLAN 2).

      !

      interface FastEthernet0/2

      switchport access vlan 2

      switchport mode access

      spanning-tree portfast

      end

       

      Interface fa0/22 connects to a router that provides DHCP services and acts as a default gateway for the data vlan (VLAN 1).

       

      !

      interface FastEthernet0/22

      switchport mode access

      spanning-tree portfast

      end

       

      Issue I am having is the phones that I have connected to acces ports on the same switch are not pulling IP addresses from the voice vlan (VLAN 2).  If I assign the port directly for vlan 2 via the switchport access vlan command it will get the correct ip address.  Using the switchport voice vlan 2 command is where I am having the issue.

       

      Please let me know if you have any questions or thoughts.  below is more information.

       

      PPA-B-SW1#show cdp nei

      Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                        S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                        D - Remote, C - CVTA, M - Two-port Mac Relay

       

      Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

      PPA-WLC-1        Fas 0/1           166               H    AIR-WLC21 Fastethernet0/0/1

      PPA-B-SW2        Gig 0/2           177              S I   WS-C2960- Gig 0/1

      SIPA8B1D41EDD15  Fas 0/23          135              H P   IP Phone  Port 1

      PPA-2-SW1        Gig 0/1           169              S I   WS-C2960- Gig 0/1

      PPA-B-SW1#

       

       

      PPA-B-SW1#show cdp neig fa0/23 detail

      -------------------------

      Device ID: SIPA8B1D41EDD15

      Entry address(es):

        IP address: 192.168.14.131

      Platform: Cisco IP Phone 7960,  Capabilities: Host Phone

      Interface: FastEthernet0/23,  Port ID (outgoing port): Port 1

      Holdtime : 168 sec

       

      Version :

      P0S3-08-7-00

       

      advertisement version: 2

      Duplex: full

      Power drawn: 6.300 Watts

      Management address(es):

       

      PPA-B-SW1#

       

       

      PPA-B-SW1#show ru int fa0/23

      Building configuration...

       

      Current configuration : 157 bytes

      !

      interface FastEthernet0/23

      switchport mode access

      switchport voice vlan 2

      mls qos trust cos

      spanning-tree portfast

      end

       

      PPA-B-SW1#ping 192.168.150.1

       

      Type escape sequence to abort.

      Sending 5, 100-byte ICMP Echos to 192.168.150.1, timeout is 2 seconds:

      !!!!!

      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

      PPA-B-SW1#