Skip navigation
Cisco Learning Home > Certifications > Routing & Switching (CCNA) > Discussions

_Communities

1257 Views 7 Replies Latest reply: Aug 1, 2012 5:43 AM by borzol CCNP (CCIE R&S candidate) RSS

Currently Being Moderated

Floating Static Routes

Jul 27, 2012 7:39 AM

bedrock1977 98 posts since
Nov 21, 2008

Here is the scenario...

 

I have a network setup with a frame relay multi-point WAN connecting R1, R2, and R3.  R1 is the hub in the hub-n-spoke config.  The frame network is on its own subnet, 129.168.123.0.  Each router has it's own ethernet connection to one of two switches, and each switch interface is assigned a specific VLAN.  There is another router acting as Rout-on-a-stick to route between VLANs.  If I am sitting on router R3 and want to reach 192.168.10.2, which is in VLAN 10 for Router R1, it immediately goes over the ethernet connection instead of the frame-relay WAN connection.  I believe it's because the ethernet route is much faster and maybe has a lower AD.  I could be wrong on that.  Well if I break the ethernet connection to R3, and try and ping that address, it times out.  Shouldn't it automatically go over the frame-relay network?  Maybe I should add more network statements into RIP?  I believe before when I was setting up this rack, I used the ethernet connection as a backup, in case the frame-relay went down.

 

Hopefully you can follow the thought-process here.

 

Chris

  • cadetalain 2,642 posts since
    Sep 18, 2008
    Currently Being Moderated
    1. Jul 27, 2012 12:18 PM (in response to bedrock1977)
    Re: Floating Static Routes

    Hi,

     

    could you post the configs and the topology.

     

    Regards.

     

    Alain.

  • cadetalain 2,642 posts since
    Sep 18, 2008
    Currently Being Moderated
    3. Jul 30, 2012 1:41 PM (in response to bedrock1977)
    Re: Floating Static Routes

    Hi,

     

    if you've found out what is the problem then no need to post the configs but for other people benefit you could post what was the solution to the problem.

    But it would have been great posting also the logical topology in one diagram with the vlans and frame-relay altogether.

     

    Regards.

     

    Alain

  • borzol CCNP (CCIE R&S candidate) 276 posts since
    Apr 6, 2012
    Currently Being Moderated
    5. Jul 31, 2012 12:39 PM (in response to bedrock1977)
    Re: Floating Static Routes

    hi,

     

    As I see your problem is that routers use ethernet connection not frame-relay because ethernet interfaces has better eigrp composite metric than FR's.

     

    On R3:

     

    Please see on R3 the sh ip eig topology all-links to see every possible routes to R1 E0.

     

    To set FR backup line you can use static route to 192.168.10.0/24 point to FR and keep eigrp to ethernet or configure offset list on R3 E0 interface.

     

    I can see default static routes set AD to 91 but it is not influence routing to R1 E0 because 192.168.10.0/24 is in your routing table as eigrp route so your router will ignore default static when send packets to 192.168.10.0/24. And on R3 you don't have default-static.

     

    Well if I break the ethernet connection to R3, and try and ping that address, it times out.

     

    Can you see eigrp neighbor via FR network? As I see your configuration if you broke eth connection you have to have eigrp routes via FR. If not, or if you don't have eigrp neighbor via FR check your FR configuration.

     

    Regards,

     

    borzol

  • borzol CCNP (CCIE R&S candidate) 276 posts since
    Apr 6, 2012
    Currently Being Moderated
    7. Aug 1, 2012 5:43 AM (in response to bedrock1977)
    Re: Floating Static Routes

    hi,

    i tried to modelling your problem.

    If you use only eigrp you can see that ethernet is the outgoing interface to R1 loopback (192.168.1.0).

     

    Gateway of last resort is not set

     

         1.0.0.0/24 is subnetted, 1 subnets

    C       1.1.1.0 is directly connected, FastEthernet0/0

         2.0.0.0/24 is subnetted, 1 subnets

    C       2.2.2.0 is directly connected, Serial0/0

    D    192.168.1.0/24 [90/409600] via 1.1.1.1, 00:02:52, FastEthernet0/0

    R2#

     

    If you config a static route AD=91 pointing to fa 0/0 nothing will be happen because eigrp route will be better.

     

    R2(config)#ip route 192.168.1.0 255.255.255.0 fastEthernet 0/0 2.2.2.1 91

     

          1.0.0.0/24 is subnetted, 1 subnets

    C       1.1.1.0 is directly connected, FastEthernet0/0

         2.0.0.0/24 is subnetted, 1 subnets

    C       2.2.2.0 is directly connected, Serial0/0

    D    192.168.1.0/24 [90/409600] via 1.1.1.1, 00:09:11, FastEthernet0/0

    R2(config)#

     

    If you want use FR as primary interface and eth to backup (and you want to use floating static which pointing to eth) first you should make FR better than Eth.

     

    I think this is only can be a labor solution!

     

    We should manipulate eigrp metric.

     

    R2#sh int ser 0/0

    Serial0/0 is up, line protocol is up

      Hardware is GT96K Serial

      Internet address is 2.2.2.2/24

      MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,

    !

    FastEthernet0/0 is up, line protocol is up

      Hardware is Gt96k FE, address is c401.0d80.0000 (bia c401.0d80.0000)

      Internet address is 1.1.1.2/24

      MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,

    !

    R2#sh int ser 0/0 | i DLY

      MTU 1500 bytes, BW 10000 Kbit/sec, DLY 900 usec,

    R2#sh int fa 0/0 | i DLY

      MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,

    R2#

    R2#sh ip route eigrp

    D    192.168.1.0/24 [90/407040] via 2.2.2.1, 00:00:04, Serial0/0

     

    Than you shold filter out eigrp routes on fa 0/0 because if you use eigrp on both interface floating static route will be ignored. (if set AD to 91 when FR interface goes down eigrp route on Eth interface will be placed into routing table not static)

     

    Simpliest way is to disable eigrp on Eth is passive interface

     

    R2(config-if)#do sh ip eig top

    IP-EIGRP Topology Table for AS(1)/ID(2.2.2.2)

    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

           r - reply Status, s - sia Status

     

    P 1.1.1.0/24, 1 successors, FD is 281600

            via Connected, FastEthernet0/0

    P 2.2.2.0/24, 1 successors, FD is 279040

            via Connected, Serial0/0

    P 192.168.1.0/24, 1 successors, FD is 407040

            via 2.2.2.1 (407040/128256), Serial0/0

            via 1.1.1.1 (409600/128256), FastEthernet0/0

    R2(config-if)#router eig 1

    R2(config-router)#pass

    R2(config-router)#passive-interface fa 0/0

    R2(config-router)#

    R2(config-router)#

    *Mar  1 00:23:42.387: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 1.1.1.1 (FastEthernet0/0) is down: interface passive

    !

    R2#sh ip eig to

    IP-EIGRP Topology Table for AS(1)/ID(2.2.2.2)

    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

           r - reply Status, s - sia Status

     

    P 1.1.1.0/24, 1 successors, FD is 281600

            via Connected, FastEthernet0/0

    P 2.2.2.0/24, 1 successors, FD is 279040

            via Connected, Serial0/0

    P 192.168.1.0/24, 1 successors, FD is 407040

            via 2.2.2.1 (407040/128256), Serial0/0

    R2#

     

    And floating static:

     

    R2(config)#ip route 192.168.1.0 255.255.255.0 fa 0/0 1.1.1.1 91

    IP routing debugging is on

    R2#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    R2(config)#int ser 0/0

    R2(config-if)#shu

    R2(config-if)#shutdown

    R2(config-if)#

    *Mar  1 00:25:48.995: RT: is_up: Serial0/0 0 state: 6 sub state: 1 line: 0 has_route: True

    *Mar  1 00:25:48.999: RT: interface Serial0/0 removed from routing table

    *Mar  1 00:25:48.999: RT: del 2.2.2.0/24 via 0.0.0.0, connected metric [0/0]

    *Mar  1 00:25:48.999: RT: delete subnet route to 2.2.2.0/24

    *Mar  1 00:25:48.999: RT: NET-RED 2.2.2.0/24

    *Mar  1 00:25:49.003: RT: delete network route to 2.0.0.0

    *Mar  1 00:25:49.003: RT: NET-RED 2.0.0.0/8

    *Mar  1 00:25:49.003: RT: Pruning routes for Serial0/0 (1)

    *Mar  1 00:25:49.067: RT: delete route to 192.168.1.0 via 2.2.2.1, Serial0/0

    *Mar  1 00:25:49.067: RT: no routes to 192.168.1.0, flushing

    *Mar  1 00:25:49.067: RT: NET-RED 192.168.1.0/24

    *Mar  1 00:25:49.067: RT: SET_LAST_RDB for 192.168.1.0/24

      NEW rdb: via 2.2.2.1

     

    *Mar  1 00:25:49.067: RT: add 192.168.1.0/24 via 1.1.1.1, static metric [91/0]

    .

    R2#sh ip rou

    R2#sh ip route

    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

           E1 - OSPF external type 1, E2 - OSPF external type 2

           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

           ia - IS-IS inter area, * - candidate default, U - per-user static route

           o - ODR, P - periodic downloaded static route

     

    Gateway of last resort is not set

     

         1.0.0.0/24 is subnetted, 1 subnets

    C       1.1.1.0 is directly connected, FastEthernet0/0

    S    192.168.1.0/24 [91/0] via 2.2.2.1, FastEthernet0/0

    R2#

     

    If you use FR as primary take care about eigrp default hold time. This will reduce your time to switch to floating static.

     

    full configs:

    R1#sh run

    Building configuration...

     

    Current configuration : 1207 bytes

    !

    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname R1

    !

    boot-start-marker

    boot-end-marker

    !

    !

    no aaa new-model

    memory-size iomem 5

    ip cef

    !

    !

    !

    !

    no ip domain lookup

    ip domain name lab.local

    ip auth-proxy max-nodata-conns 3

    ip admission max-nodata-conns 3

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    interface Loopback0

    ip address 192.168.1.1 255.255.255.0

    !

    interface FastEthernet0/0

    ip address 1.1.1.1 255.255.255.0

    duplex auto

    speed auto

    !

    interface Serial0/0

    ip address 2.2.2.1 255.255.255.0

    ip hello-interval eigrp 1 1

    ip hold-time eigrp 1 3

    encapsulation frame-relay

    shutdown

    clock rate 2000000

    frame-relay interface-dlci 101

    !

    interface FastEthernet0/1

    no ip address

    shutdown

    duplex auto

    speed auto

    !

    !

    router eigrp 1

    network 0.0.0.0

    no auto-summary

    !

    ip forward-protocol nd

    ip route 192.168.20.0 255.255.255.0 FastEthernet0/0 1.1.1.2 91

    !

    !

    no ip http server

    no ip http secure-server

    !

    !

    !

    !

    control-plane

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    line con 0

    exec-timeout 0 0

    privilege level 15

    logging synchronous

    line aux 0

    exec-timeout 0 0

    privilege level 15

    logging synchronous

    line vty 0 4

    login

    !

    !

    end

     

    R1#

     

    hostname R2

    !

    boot-start-marker

    boot-end-marker

    !

    !

    no aaa new-model

    memory-size iomem 5

    ip cef

    !

    !

    !

    !

    no ip domain lookup

    ip domain name lab.local

    ip auth-proxy max-nodata-conns 3

    ip admission max-nodata-conns 3

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    interface Loopback0

    ip address 192.168.20.1 255.255.255.0

    !

    interface FastEthernet0/0

    ip address 1.1.1.2 255.255.255.0

    duplex auto

    speed auto

    !

    interface Serial0/0

    bandwidth 10000

    ip address 2.2.2.2 255.255.255.0

    ip hello-interval eigrp 1 1

    ip hold-time eigrp 1 3

    encapsulation frame-relay

    delay 90

    clock rate 2000000

    frame-relay interface-dlci 101

    !

    interface FastEthernet0/1

    no ip address

    shutdown

    duplex auto

    speed auto

    !

    !

    router eigrp 1

    passive-interface FastEthernet0/0

    network 0.0.0.0

    no auto-summary

    !

    ip forward-protocol nd

    ip route 192.168.1.0 255.255.255.0 FastEthernet0/0 1.1.1.1 91

    !

    !

    no ip http server

    no ip http secure-server

    !

    !

    !

    !

    control-plane

    !

    !

    !

    !

    !

    !

    !

    !

    !

    !

    line con 0

    exec-timeout 0 0

    privilege level 15

    logging synchronous

    line aux 0

    exec-timeout 0 0

    privilege level 15

    logging synchronous

    line vty 0 4

    login

    !

    !

    end

     

    R2#

     

    I hope this help to you.

     

    regrds,

     

    borzol

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)