5 Replies Latest reply: May 16, 2012 4:24 PM by macd RSS

    configuring rip route redistribution

    Philip

      Hello, I have two routers. Taupo router is running RIP version2. Huntly Router is running OSPF. They are both communicating using Frame Relay.

      I want to redistribute RIP routes from Taupo into Huntly. I have attached my relevant running-config details for each router.

      Can anyone please tell me where I am going wrong, as this is not working.

      I have also attached an image of the network. The two routers I am talking about here are on the ones on the far right hand side.

      Thanks for any help.

       

      Taupo router:

      router rip

      version 2

      redistribute ospf 43 metric 1

      network 172.26.0.0

      no auto-summary

       

       

      Huntly Router:

      router ospf 43

      log-adjacency-changes

      passive-interface FastEthernet0/0

      passive-interface FastEthernet0/0.15

      passive-interface FastEthernet0/0.25

      passive-interface FastEthernet0/0.86

      network 172.26.252.4 0.0.0.3 area 0

      network 172.26.15.0 0.0.0.127 area 0

      network 172.26.25.0 0.0.0.127 area 0

      network 172.26.86.0 0.0.0.15 area 0

      !

      ip classless

        • 1. Re: configuring rip route redistribution
          macd

          redistribute rip cmd is missing on Huntly router from what l can see!

          • 2. Re: configuring rip route redistribution
            Philip

            thanks for that. I have added that command but still no RIP routes are being shared from Taupo to Huntly.

            Does anyone know how to implement this ?

             

            Also, is it actually necessary to use "redistribute rip" on Huntly route ? I only really want to send RIP routes from Taupo to Huntly, not vice versa.

            thanks kindlly

             

            HUNTY ROUTER:

            router ospf 43

            log-adjacency-changes

            redistribute rip

            passive-interface FastEthernet0/0

            passive-interface FastEthernet0/0.15

            passive-interface FastEthernet0/0.25

            passive-interface FastEthernet0/0.86

            network 172.26.252.4 0.0.0.3 area 0

            network 172.26.15.0 0.0.0.127 area 0

            network 172.26.25.0 0.0.0.127 area 0

            network 172.26.86.0 0.0.0.15 area 0

            !

            ip classless

             

            TAUPO ROUTER:

            router rip

            version 2

            redistribute ospf 43 metric 1

            network 172.26.0.0

            no auto-summary

            !

            ip classless

            • 3. Re: configuring rip route redistribution
              Erick

              Hi.

               

              So here are some things to check. 

               

              • Do you have an OSPF neighbor relationship over your frame relay network and can you ping across before redistribution?
              • Are there RIP routes in the Taupo routing table?  A router will only redistribute what it has installed in the routing table.

               

              You should do your redistribution at the router that has the RIP and OSPF routes installed.  If the Taupo router has the RIP and OSPF routes, then you redistriubte RIP and OSPF on that one router.

              • 4. Re: configuring rip route redistribution
                Cristian F. Stoica

                When troubleshooting it would be helpful to post the whole relevant sections from the running-config on both routers. However, I suspect that you are only running OSPF on Haunty and RIP on Taupo. Please remember that in order to do redistribution, both protocols, i.e. RIP and OSPF, should be running on the router doing redistribution, i.e. you can't "send" RIP routes from Taupo to Hunty if Hunty doesn't run RIP. Redistribution happens on the same router, i.e. Hunty will redistribute its OSPF learned routes into its own RIP process to be advertised to the neighbors (if any).

                • 5. Re: configuring rip route redistribution
                  macd

                  do you have rip and ospf up and running on hunty router?  The routes you want to redistribute, are they on hunty rip routing table?