Skip navigation
Cisco Learning Home > Certifications > Routing & Switching (CCNA) > Discussions

_Communities

This Question is Not Answered 1 Correct Answer available (4 pts) 2 Helpful Answers available (2 pts)
5592 Views 25 Replies Latest reply: May 18, 2012 8:40 AM by Daniel RSS 1 2 Previous Next

Currently Being Moderated

NO ping on directly connected routers

May 10, 2012 4:44 AM

jawad 8 posts since
May 10, 2012

i am new to CCNA I have small GNS3 lab with 7 cisco c2691 routers they all directly connected with FE interfaces all into sam esubnets tried RIP but can not ping any of the router need help please as I can not resolve this over 2 weeks any will be great

 

 

Thanks

 

 

Jawad

  • Currently Being Moderated
    1. May 10, 2012 6:05 AM (in response to jawad)
    Re: NO ping on directly connected routers

    Hello Jawad,

     

    Can you post your router configurations?

     

    Regards,

    DelVonte

  • Daniel 197 posts since
    Jul 21, 2011
    Currently Being Moderated
    3. May 11, 2012 2:07 AM (in response to jawad)
    Re: NO ping on directly connected routers

    Hi Jawad,

     

    To help you fix "all" the possible configurations would be a long post. So i'll help you with the connection between R1 and R3 and perhaps you can figure out whats wrong with the rest?

     

    First you need to understand that to be able to ping, each router needs to know where the other routers belong. And to be able to transfer packes BETWEEN each other they need to be interconnected on the same subnet SOMEWHERE so that packets can travel between the routers.

     

    On R1 you have FastEthernet0/0 configured with ip-address  192.168.1.3 255.255.255.0 (/24). That cable is connected to Router 3's FastEthernet0/1 interface.

     

     

    Taking a look at your R3 configuration there is NO ip-address configured on interface FA0/1. What you need to do is put this interface in the SAME subnet as the other router it interconnects with (R1). MEaning, you need an ip-address in the subnet 192.168.1.0 /24 configured. So let's fix that....

     

    From R3:

    enable

    configure terminal

    int fa0/1

    ip address 192.168.1.254 255.255.255.0

    no shutdown

    end

     

     

    Now you can try and ping between R1 and R3 using the addresses 192.168.1.3 and 192.168.1.254.

     

    Now this only solves your connection between R1 and R3, and you have several more to address. But i think this is a good place to start and understand what have happened, and why . When you have all the local connections configured correctly and the ping works, we can start helping you move on to how the routers will be "aware of all remote networks".

     

    HTH

    -Daniel

  • Darlington 90 posts since
    Aug 3, 2011
    Currently Being Moderated
    4. May 11, 2012 2:55 AM (in response to jawad)
    Re: NO ping on directly connected routers

    Like Daniel indicated ,most of your interface IP address configuration is not complete. Like the link between R11 and R10 ,on F0/1 the link to R11 there is no IP address. Make sure all connected interfaces have IP addresses in the correct subnet and dont 4get the "no shutdown "command

  • Vivek Nagar 141 posts since
    Jan 25, 2010
    Currently Being Moderated
    6. May 12, 2012 12:34 PM (in response to jawad)
    Re: NO ping on directly connected routers

    If you face ip overlap then please use diffrent subnet.

     

    thanks

    Vivek

  • Daniel 197 posts since
    Jul 21, 2011
    Currently Being Moderated
    9. May 12, 2012 7:34 PM (in response to jawad)
    Re: NO ping on directly connected routers

    Hi again Jawad,

     

    Glad to hear that you got some of the things working. That was the good news. Now let's start clearing out your mess above to help you understand how things work and what you need to know in order to get this thing to work.

     

    First of all, each router needs to be connected to a DIFFERENT subnet. You have used only two subnets between all your routers. The networks:

    192.168.1.0/24

    192.168.2.0/24

     

    So if we count your routers i count to a total of: 7 routers. And the way you have connected them i count a total of 6 interconnections, which means you need access to 6 different subnets.

     

    The rule is that EACH router-interface needs to be connected to a different subnet....meaning: on each router in your topology it can't be connected to the same network twice. Then, to make connectivity all your routers need to have different networks and not the same like you currently have. You have 6 inter-router-connections so it means 6 different subnets. Using the ip-addresses you have assigned would give you an ip-address assignment that would put more than one router connected to the same network,  and in the end mess up your routing tables when using RIP. It's also very important to know what i stated in my previous post....two routers interconnected need to have their own interfaces assigned with an ip-address in the SAME subnetwork/network to be able to reach each other.

     

    You get your "overlaping" error because you tried to assign ip-addresses to more than one interface, on the same single router, that belongs to the same subnet - that's when you get that error message.

     

    To solve it you have two options.

    Option 1: Subnet the 192.168.1.0/24 and 192.168.2.0/24 networks to get more networks.

    Option 2: use 6 different /24 subnetworks meaning use.... 192.168.1.0 - 192.168.6.0 /24 networks and use one on each of your links.

     

    Now this isn't really complicated, but judging from your current addressing you need to know about subneting and how the subnet mask is connected with the ip-address. It's a long and "complicated" topic to teach you so i will cut it down into a short one:

     

    The subnet mask determines how to split the host-portion from the network-portion of the ip-address. In essence, it tells your computers/interfaces which network the ip-address belong to and you are free to choose the subnetmask to get as many hosts as you need for your networks.

     

    Your topology consists of only two end-points, or a point-to-point connection. The best subnetmask is to use a subnetmask of 255.255.255.252 or /30 since you only get 2 available hosts then, and you only need 2 hosts....one for each end of the router connections.

     

    Now i see that you are using RIP version 2 and no auto-summary, that makes it interesting to lab around with.....VLSM which is why i suggested a /30 subnet mask.

     

    First what we will do is split your 192.168.1.0/24 and 192.168.2.0/24 networks into smaller networks, i'll start with the first three:

    192.168.1.0/30

    192.168.1.4/30

    192.168.1.8/30

    192.168.2.0/30

    192.168.2.4/30

    192.168.2.8/30

     

    Which means you will have the following ip-addresses available to use:

    192.168.1.1

    192.168.1.2

    192.168.1.5

    192.168.1.6

    192.168.1.9

    192.168.1.10

    192.168.2.1

    192.168.2.2

    192.168.2.5

    192.168.2.6

    192.168.2.9

    192.168.2.10

     

    so lets assign them between your routers:

    R1 fa0/0: 192.168.1.1 255.255.255.252

    R3 fa0/1: 192.168.1.2 255.255.255.252

    R3 fa0/0: 192.168.2.1 255.255.255.252

    R5 fa0/0: 192.168.2.2 255.255.255.252

    R5 fa0/1: 192.168.1.5 255.255.255.252

    R11 fa0/0: 192.168.1.6 255.255.255.252

     

    And on each router that you want to enable rip you need to use these commands:

    enable

    configure terminal

    router rip

    version 2

    network 192.168.1.0 (if they are connected to the CLASSFULL network 192.168.1.0/24)

    network 192.168.2.0 (if they are connected to the CLASSFULL network 192.168.2.0/24)

    exit

    end

     

     

    That should help you get started in clearing this up . What you need to learn about to be able to understand what just happened is.....how the subnet mask works, and how a router actually works. Router:

     

    Every single router interface needs to be connected to a DIFFERENT network. In your toplogy you have a lot of routers connected to the SAME network which means it simply wouldn't work. If you connect routers in your network to the same subnet it means you want redundancy or more than one path to the same network for backups! So do not confuse my above terminology of "DIFFERENT" networks with " it can't be done, and is not allowed"....for now, learn that each router you configure needs to be configured with every single interface in a different subnet should you need to use all interfaces....and the interconnected router interface must be configured in the same subnet.

     

    Puh, this became a rather long post.....and probably messy and hard to understand, so ... ask your questions if you have any and we'll try to help you, but do remember that.....we can't help you unless you know what a subnet mask is because that's where you did wrong! When you have learned what happened above, we can move on to the actual routing process and how to solve it .

     

    HTH

    -Daniel

  • chemilio 243 posts since
    May 31, 2009
    Currently Being Moderated
    10. May 12, 2012 10:14 PM (in response to jawad)
    Re: NO ping on directly connected routers

    Hi Jawad,

     

    Connect the routers either with a switch between or with a serial cable. ( I have experienced this before)

     

    The problem is unlike packet tracer, GNS3 has no option for fastethernet crossover only option is to use straighthrough which doesn't work between two routers without a switch in between. (Remember Layer 1 OSI model)

     

    gns3_straighthrough.PNG

     

    Router#ping 192.168.1.31

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 192.168.1.31, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/56/160 ms

     

    Also like daniel said, ensure the segments' ip addresses are on the same subnet.(Layer 3 OSI model)

     

    HTH

     

    Chemillio.

  • Daniel 197 posts since
    Jul 21, 2011
    Currently Being Moderated
    11. May 13, 2012 2:59 AM (in response to chemilio)
    Re: NO ping on directly connected routers

    Or you can interconnect them with a switch like chemillio said, however then we are talking about redesigning your topology to fix it - and there's nothing wrong with your topology!

     

    And then they would be able to ping each other because they would be connected to the same broadcast-domain, with several redundant connections so there would be almost no need for routing since two networks connected to a single switch with 7 different routers is....too much redundancy ...and there'd only be need to route between the 192.168.1.0 and 192.168.2.0 networks.

     

    So if you are going to use a switch in this scenario you should know what really happens, and not just see that you can ping from one router to the other router - it's really not just that simple.

     

    It's true what chemillio said, that the routers are more or less always connected to a switched network somewhere...but you want to learn about routing and how routers can learn about remote networks - then i think a switch is not a good sollution here, until you know what a switch actually is and how it works!

     

    HTH

    -Daniel

  • chemilio 243 posts since
    May 31, 2009
    Currently Being Moderated
    12. May 13, 2012 6:59 AM (in response to Daniel)
    Re: NO ping on directly connected routers

    Hi Daniel,

     

    What I was trying to point out to OP is that he can't connect two routers back to back with a straight through fastethernet cable. So his topology is basically wrong from a layers 1 perspective.

     

    He has to use a crossover cable (fastethernet or serial.) _OR_ use a straight-through with a switch in between as a workaround.

     

    BUT GNS3 has no fastethernet crossover cable ! So you remain with either serial crossover or the straighthrough with switch workaround.

     

    I would personaly choose the serial crossover, way much more simpler.

     

    HTH

     

    Chemillio

  • Daniel 197 posts since
    Jul 21, 2011
    Currently Being Moderated
    13. May 13, 2012 6:59 AM (in response to chemilio)
    Re: NO ping on directly connected routers

    Hey Chemillio,

     

    Well he actually can do that, and it will work very well because of the Auto-MDIX function. IMO, the "straight-through" and "cross-over" cables have surved their purposes ...since we can now control this in the circuit. I know people disagree with me here but i think of it as networkings "plug and play" feature, so we don't have to care about hardware-limitations and jumpers. Point is, it will work if both devices are not older than 10 years or so.

     

    I agree though, it's best practice and should be done with a cross-over cable. Today though with modern technology it will work very well using a straight-through cable, or a cross-over cable...under the circumstances where you don't need manual control over speed and duplex settings.

     

    Jawad: What chemillio means is that it's best practice and for the CCNA, or any other network exam, you must use a cross-over cable between two routers or it will not "work". IF you're using packet-tracer it will stop working until you connect it properly according to the curriculums.

     

    How you as a network administrator chooses to administer your network is entirely up to you...and the downside of using Auto-MDIX is that both ends need to be set with duplex and speed as AUTO or it will not work...as an administrator you may want to / need to control these settings manually, and then you can't use AUTO-MDIX and thus need to use "proper" cablings for things to work.

     

    Chemillio: I didn't mean to step on your toes, i just thought that the OP wanted to learn about routing and behaviour and thus a switch was imo not needed, and nor is "proper" cabling. (after all, the topic is about routing and we can't be sure that he knows about the L1 or L2 features....yet, or so it seems to me)

     

    -Daniel

  • chemilio 243 posts since
    May 31, 2009
    Currently Being Moderated
    14. May 13, 2012 7:48 AM (in response to Daniel)
    Re: NO ping on directly connected routers

    Hey Daniel,

     

    I kinda sympathised with Jawad because I went through the same thing once while working with GNS3. I took me hours to troubleshoot complex routing issues until  I just realised the connectivity issue was a simple cabling mistake.. So lesson learned, GNS3 is not real life.

     

     

    EDIT: I tested just now with a recent IOS in GNS3. and it works back to back with a straight through. I must have been using an old ios back then where AUTO-MDIX was not implemented yet. Daniel, thanks i've learned something new today.

     

    Router#ping 192.168.1.1

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

    .!!!!

    Success rate is 80 percent (4/5), round-trip min/avg/max = 4/43/100 ms

     

    Router#sh ver

    Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)

     

    Regards

     

    Chemillio

     

    Message was edited by: chemilio

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)