4 Replies Latest reply: May 3, 2012 1:59 AM by DEEPAK ARORA RSS

    Route Redistribution

    black-cisco01

      I was looking at video of a wel know CCIE ( wont mention his name to keep his integrity intact... -_- ) instructor

      the subject was about route redistribution. its was redistribution between RIP and OSPF.

      he mention that in this case we needed to redistribute also the connected route to have full connectivity.

       

      I doubt it what he was saying because i had practice route redistribution before and never had any problems

      with connectivity without redistributing the connecting routes. I could see the picture though what he was talking about but because

      of former experience i had some doubt so I builded the same lab in gns3 and didn't redistributed the connected route and had full connectivity.

       

      R5 could reach R4 and R4 could reach the loopbacks of R5.

       

      After this short story here's the question..-__-..... How is it possible that for example R4 could ping the loopbacks of R5 without

      redistributing the connected route between R1 and R5...because RIP indeed ( obvious) does not sees that route as an

      RIP learned route but as an connected route.

       

      If its not to much trouble could some1 provide an example where we should redistribute the connected route to have full connectivy.

       

      See the image to have a good picture

       

      cheers...

        • 1. Re: Route Redistribution
          borzol CCNP (CCIE R&S candidate)

          hi,

           

          "

          .because RIP indeed ( obvious) does not sees that route as an

          RIP learned route but as an connected route. "

           

          it is the normal behaviour of ospf and rip. when you have connected interfaces, and you advertise those under rip or ospf via network statement (or under interface - ospf) , and then redistrubute rip into ospf and/or ospf into rip the connected interfaces will be redistributed too, because those connected interfaces are rip and/or ospf routes in rip/ospf domains.

           

          I did a little topology:

          top1.png

          And the outputs:

           

          on R2:

          R2#sh ip int brie

          Interface                  IP-Address      OK? Method Status                Protocol

          Serial0/0                  1.1.1.2         YES manual up                    up

          Serial0/1                  2.2.2.2         YES manual up                    up

          Serial0/2                  unassigned      YES unset  administratively down down

          Serial0/3                  unassigned      YES unset  administratively down down

          Loopback1                  11.0.0.1        YES manual up                    up

          Loopback2                  12.0.0.1        YES manual up                    up

          R2#sh ip os int brie

          Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

          Se0/1        1     0               2.2.2.2/24         64    P2P   1/1

          Lo2          1     0               12.0.0.1/24        1     LOOP  0/0

          R2#sh ip rip

          R2#sh ip rip ?

            database  IP RIP database

           

          R2#sh ip rip da

          R2#sh ip rip database

          1.0.0.0/8    auto-summary

          1.1.1.0/24    directly connected, Serial0/0

          2.0.0.0/8    auto-summary

          2.2.2.0/24    redistributed

              [3] via 0.0.0.0,

          11.0.0.0/8    auto-summary

          11.0.0.0/24    directly connected, Loopback1

          12.0.0.0/8    auto-summary

          12.0.0.0/24    redistributed

              [3] via 0.0.0.0,

          R2#sh ip route

          Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                 E1 - OSPF external type 1, E2 - OSPF external type 2

                 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                 ia - IS-IS inter area, * - candidate default, U - per-user static route

                 o - ODR, P - periodic downloaded static route

           

          Gateway of last resort is not set

           

               1.0.0.0/24 is subnetted, 1 subnets

          C       1.1.1.0 is directly connected, Serial0/0

               2.0.0.0/24 is subnetted, 1 subnets

          C       2.2.2.0 is directly connected, Serial0/1

               11.0.0.0/24 is subnetted, 1 subnets

          C       11.0.0.0 is directly connected, Loopback1

               12.0.0.0/24 is subnetted, 1 subnets

          C       12.0.0.0 is directly connected, Loopback2

          R2#

           

          on R1:

           

          R1#sh ip route

          Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                 E1 - OSPF external type 1, E2 - OSPF external type 2

                 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                 ia - IS-IS inter area, * - candidate default, U - per-user static route

                 o - ODR, P - periodic downloaded static route

           

          Gateway of last resort is not set

           

               1.0.0.0/24 is subnetted, 1 subnets

          C       1.1.1.0 is directly connected, Serial0/0

               2.0.0.0/24 is subnetted, 1 subnets

          R       2.2.2.0 [120/3] via 1.1.1.2, 00:00:21, Serial0/0

               11.0.0.0/24 is subnetted, 1 subnets

          R       11.0.0.0 [120/1] via 1.1.1.2, 00:00:21, Serial0/0

               12.0.0.0/24 is subnetted, 1 subnets

          R       12.0.0.0 [120/3] via 1.1.1.2, 00:00:21, Serial0/0

          R1#

           

          on R3:

           

          R3#sh ip route os

               1.0.0.0/24 is subnetted, 1 subnets

          O E2    1.1.1.0 [110/20] via 2.2.2.2, 00:01:30, Serial0/0

               11.0.0.0/24 is subnetted, 1 subnets

          O E2    11.0.0.0 [110/20] via 2.2.2.2, 00:01:30, Serial0/0

               12.0.0.0/32 is subnetted, 1 subnets

          O       12.0.0.1 [110/65] via 2.2.2.2, 00:03:44, Serial0/0

          R3#

          R3#

          R3#

          R3#sh ip route os

               1.0.0.0/24 is subnetted, 1 subnets

          O E2    1.1.1.0 [110/20] via 2.2.2.2, 00:02:54, Serial0/0

               11.0.0.0/24 is subnetted, 1 subnets

          O E2    11.0.0.0 [110/20] via 2.2.2.2, 00:02:54, Serial0/0

               12.0.0.0/32 is subnetted, 1 subnets

          O       12.0.0.1 [110/65] via 2.2.2.2, 00:05:08, Serial0/0

          R3#

           

          On R2 I don't redistribute connected interfaces (serial and loopbacks), but on r1 and r3 these are appear.

           

          R2 config:

           

          !

          !

          interface Loopback1

          description rip connected

          ip address 11.0.0.1 255.255.255.0

          !

          interface Loopback2

          description ospf conn

          ip address 12.0.0.1 255.255.255.0

          ip ospf 1 area 0

          !

          interface Serial0/0

          ip address 1.1.1.2 255.255.255.0

          serial restart-delay 0

          !

          interface Serial0/1

          ip address 2.2.2.2 255.255.255.0

          ip ospf 1 area 0

          serial restart-delay 0

          !

          interface Serial0/2

          no ip address

          shutdown

          serial restart-delay 0

          !

          interface Serial0/3

          no ip address

          shutdown

          serial restart-delay 0

          !

          router ospf 1

          log-adjacency-changes

          redistribute rip subnets

          !

          router rip

          version 2

          redistribute ospf 1 metric 3

          network 1.0.0.0

          network 11.0.0.0

          no auto-summary

          !

           

          I hope this is the answer you are looking for.

           

          regards,

           

          borzol

          • 2. Re: Route Redistribution
            black-cisco01

            Hi Borzol,

             

            it is the normal behaviour of ospf and rip. when you have connected interfaces, and you advertise those under rip or ospf via network statement (or under interface - ospf) , and then redistrubute rip into ospf and/or ospf into rip the connected interfaces will be redistributed too, because those connected interfaces are rip and/or ospf routes in rip/ospf domains

             

            It was clear with the statement above.

            What i would like the see was a example where as if we dont include the connected routed in redistribution we wont have full connectivity..

             

            TIA...

             

            cheers...

            • 3. Re: Route Redistribution
              borzol CCNP (CCIE R&S candidate)

              hi,

              I agree with you, I don't think it is necessary too.

               

              Maybe just when you don't advertise your connected routes into routing protocolls. (?)

               

              borzol