Skip navigation
Cisco Learning Home > Certifications > IP Networking (CCENT) > Discussions

_Communities

6747 Views 20 Replies Latest reply: Apr 24, 2012 12:43 PM by jack RSS 1 2 Previous Next

Currently Being Moderated

cisco router 871 configuration

Apr 10, 2012 7:30 AM

jack 26 posts since
Apr 10, 2012

I have a cisco router 871, which will serve as a home based router to access the internet thru a COX cable modem.

I am having trouble setting it up to access the internet.

  • Currently Being Moderated
    1. Apr 10, 2012 12:26 PM (in response to jack)
    Re: cisco router 871 configuration

    What exactly are you having a problem with?

  • Currently Being Moderated
    2. Apr 10, 2012 12:56 PM (in response to jack)
    Re: cisco router 871 configuration

    hi Jack,

     

    See this post https://learningnetwork.cisco.com/message/209694#209694

    It might help

  • Currently Being Moderated
    4. Apr 11, 2012 8:33 AM (in response to jack)
    Re: cisco router 871 configuration

    Hi Jack.

     

    Please try modifying your configuration like this.

     

    Add a default route. (This is your router's default gateway)

    ip route 0.0.0.0 0.0.0.0 dhcp

     

    Change your access list to specify the source subnet to be translated instead of using the "any" key word.

    no access-list 1 permit any

    access-list 1 permit 10.0.0.0 0.255.255.255

     

    Change your NAT statment to use PAT on the IP NAT OUTSIDE interface instead of using a NAT pool.  There is no need to use a NATpool here.

    no ip nat pool POOL1 10.10.10.1 10.10.10.254 netmask 255.0.0.0

    no ip nat inside source list 1 pool POOL1 overload

     

    ip nat inside source list 1 interface fastethernet 4 overload

     

     

    In addition, you may want to use the "import all" statement under your DHCP pool configuration.  This will inport the service providers DNS settings so you don't have to manually specify Google's DNS servers.

     

    ip dhcp pool DHCPPOOL

       network 10.0.0.0 255.0.0.0

       import all

       default-router 10.10.10.1

       no dns-server 8.8.8.8

     

     

     

  • Currently Being Moderated
    6. Apr 11, 2012 11:14 AM (in response to jack)
    Re: cisco router 871 configuration

    Hi jack.

     

    The NVI0 is called a NAT Virtual Interface.  It's Cisco's new implementation of NAT.  It was created when you enabled NAT on your interfaces.  In newer implementations of NAT, you can just issue the command ip nat enable on your interfaces without having to specify whether or not the interface should be NAT inside or NAT outside.  The NAT virtual interface takes care of that for you.  For the purposes of the CCENT & CCNA, I wouldn't worry about it.  Just continue to use the ip nat insde and ip nat outside commands.

     

    If you want some extra reading, you can find additional information in the below link.

     

    http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/gtnatvi.html

  • Bradford Chatterjee (CCIEx2/CCDE) 347 posts since
    Jul 7, 2009
    Currently Being Moderated
    7. Apr 11, 2012 11:38 AM (in response to Erick)
    Re: cisco router 871 configuration

    Speaking from experience, Cox's DNS is awful and hardcoding someone else's servers is probably a good idea.

  • I will guess you work in the service provider space, so I'll take your word for it!

  • Currently Being Moderated
    10. Apr 13, 2012 2:47 PM (in response to jack)
    Re: cisco router 871 configuration

    Hi jack.

     

    No problem.  make sur to save your configuration for put it some where as a backup in case you need it later.

  • Currently Being Moderated
    12. Apr 14, 2012 2:47 PM (in response to jack)
    Re: cisco router 871 configuration

    Hi Jack

     

    Ports FE0 - FE3 are normal layer 2 switch ports.  You can't assign IP addresses to them for routing.  FE4 is the only routing interface on that router model. 

     

    If your Netflix device is able to get an address through DHCP, then just plug it into one of the switch ports and enable the interface on the router (no shut command) and you should be good to go.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)