1 2 Previous Next 20 Replies Latest reply: Apr 24, 2012 12:43 PM by jack RSS

    cisco router 871 configuration

    jack

      I have a cisco router 871, which will serve as a home based router to access the internet thru a COX cable modem.

      I am having trouble setting it up to access the internet.

        • 1. Re: cisco router 871 configuration
          Erick

          What exactly are you having a problem with?

          • 2. Re: cisco router 871 configuration
            gloryitak

            hi Jack,

             

            See this post https://learningnetwork.cisco.com/message/209694#209694

            It might help

            • 3. Re: cisco router 871 configuration
              jack

              I have a home labe setup, with 1 laptop hooked up to my cisco router 871.

              The CIsco Router 871 is cabled into a COX modem.

              Cox ISP provides a DHCP IP.

               

              I cannot access the internet thru my laptop, which is using XP OS.

              My laptop can ping the cisco router, and its gateway.

              But my laptop cannot ping the modem, or internet cloud.

              My Cisco router can ping the Cox modem, and can ping the internet cloud.

              My CIsco router can ping www.yahoo.com.

               

              (So I believe the issue is between the laptop and the router)

               

              Posted below is my Cisco Router 871 configuration:

               

              Router#sh run

              Building configuration...

               

               

              Current configuration : 3079 bytes

              !

              version 12.4

              no service pad

              service timestamps debug datetime msec

              service timestamps log datetime msec

              no service password-encryption

              !

              hostname Router

              !

              boot-start-marker

              boot-end-marker

              !

              no logging console

              enable secret 5 $1$I/ia$0Yx1FJfQKGyI5STVjWOf0/

              enable password xxxxxxxxxxx

              !

              no aaa new-model

              !

              resource policy

              !

              ip cef

              no ip dhcp use vrf connected

              ip dhcp excluded-address 10.10.10.1

              !

              ip dhcp pool DHCPPOOL

                 network 10.0.0.0 255.0.0.0

                 default-router 10.10.10.1

                 dns-server 8.8.8.8

              !

              ip dhcp pool DHCPOOL

                 default-router 10.10.10.1

                 dns-server 8.8.8.8

              !

              !

              ip domain lookup source-interface FastEthernet4

              ip address-pool local

              !

              !

              crypto pki trustpoint TP-self-signed-3057892798

              enrollment selfsigned

              subject-name cn=IOS-Self-Signed-Certificate-3057892798

              revocation-check none

              rsakeypair TP-self-signed-3057892798

              !

              !

              crypto pki certificate chain TP-self-signed-3057892798

              certificate self-signed 01

                30820249 308201B2 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

                31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

                69666963 6174652D 33303537 38393237 3938301E 170D3032 30343135 31313431

                31305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

                4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 30353738

                39323739 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

                8100A53D 8435F0F2 47C86811 3590CA50 78159F53 BEC16C74 85E02B31 258A12C4

                3A697788 B7D4192E D646F934 00561F2B A8E8ADC7 C76ED0A2 40C74B22 B3AD184E

                9B130948 A9902A80 451C6796 AC3C7BE8 FF383504 AA6D2295 502934BC 51B2CD9F

                601AAE43 4581A6FD F4940EC9 5BEC572B CC34B52D F39058A0 6CD5313A 7F8C8619

                BD710203 010001A3 71306F30 0F060355 1D130101 FF040530 030101FF 301C0603

                551D1104 15301382 11526F75 7465722E 73642E63 6F782E6E 6574301F 0603551D

                23041830 16801428 CDE24792 90BECFF2 A395BEB8 519FAB80 1EE95130 1D060355

                1D0E0416 041428CD E2479290 BECFF2A3 95BEB851 9FAB801E E951300D 06092A86

                4886F70D 01010405 00038181 007AF2DF DD680F49 D4275664 3C7644A9 E0A8155C

                3C4EEEE6 C5093194 A3414808 F5FB9FC2 56664CCD 697E9B2D 7A742BE8 3A1BE8D0

                6FAC14F3 830CFB28 37918703 63BDA512 30313ED5 9E445998 405EC2F8 F324052B

                C472919A 9752F90A 2F124BDF 08CCACCA 61C0E520 36AAEA6C 3E3F9A53 6DBA0467

                D7ABE730 6F76C2AD 09A9D5F6 9F

                quit

              !

              !

              !

              !

              !

              !

              interface FastEthernet0

              shutdown

              !

              interface FastEthernet1

              !

              interface FastEthernet2

              shutdown

              !

              interface FastEthernet3

              shutdown

              !

              interface FastEthernet4

              ip address dhcp hostname DHCPPOOL

              ip nat outside

              ip virtual-reassembly

              duplex auto

              speed auto

              !

              interface Vlan1

              ip address 10.10.10.1 255.0.0.0

              ip nat inside

              ip virtual-reassembly

              !

              !

              ip http server

              ip http secure-server

              ip dns server

              ip nat pool POOL1 10.10.10.1 10.10.10.254 netmask 255.0.0.0

              ip nat inside source list 1 pool POOL1 overload

              !

              access-list 1 permit any

              !

              !

              !

              control-plane

              !

              !

              line con 0

              no modem enable

              transport output all

              line aux 0

              transport output all

              line vty 0 4

              login

              transport input all

              transport output all

              !

              scheduler max-task-time 5000

              end

               

               

               

               

               

               

              Also here is my sh ip int b:

               

               

              Router>sh ip int b

              Interface                  IP-Address      OK? Method Status                Prot

              ocol

              FastEthernet0              unassigned      YES unset  administratively down down

               

               

              FastEthernet1              unassigned      YES unset  up                    up

               

               

              FastEthernet2              unassigned      YES unset  administratively down down

               

               

              FastEthernet3              unassigned      YES unset  administratively down down

               

               

              FastEthernet4              68.107.26.66    YES DHCP   up                    up

               

               

              Vlan1                      10.10.10.1      YES manual up                    up

               

               

              NVI0                       unassigned      NO  unset  up                    up

              • 4. Re: cisco router 871 configuration
                Erick

                Hi Jack.

                 

                Please try modifying your configuration like this.

                 

                Add a default route. (This is your router's default gateway)

                ip route 0.0.0.0 0.0.0.0 dhcp

                 

                Change your access list to specify the source subnet to be translated instead of using the "any" key word.

                no access-list 1 permit any

                access-list 1 permit 10.0.0.0 0.255.255.255

                 

                Change your NAT statment to use PAT on the IP NAT OUTSIDE interface instead of using a NAT pool.  There is no need to use a NATpool here.

                no ip nat pool POOL1 10.10.10.1 10.10.10.254 netmask 255.0.0.0

                no ip nat inside source list 1 pool POOL1 overload

                 

                ip nat inside source list 1 interface fastethernet 4 overload

                 

                 

                In addition, you may want to use the "import all" statement under your DHCP pool configuration.  This will inport the service providers DNS settings so you don't have to manually specify Google's DNS servers.

                 

                ip dhcp pool DHCPPOOL

                   network 10.0.0.0 255.0.0.0

                   import all

                   default-router 10.10.10.1

                   no dns-server 8.8.8.8

                 

                 

                 

                • 5. Re: cisco router 871 configuration
                  jack

                  Thank You ErickB, I will try the CLI you specified.

                   

                  Under my sh ip int b, there is a :

                  NVI0                       unassigned      NO  unset  up                    up

                   

                  I am not sure how\why i created this, is this just an extra vlan id?

                  • 6. Re: cisco router 871 configuration
                    Erick

                    Hi jack.

                     

                    The NVI0 is called a NAT Virtual Interface.  It's Cisco's new implementation of NAT.  It was created when you enabled NAT on your interfaces.  In newer implementations of NAT, you can just issue the command ip nat enable on your interfaces without having to specify whether or not the interface should be NAT inside or NAT outside.  The NAT virtual interface takes care of that for you.  For the purposes of the CCENT & CCNA, I wouldn't worry about it.  Just continue to use the ip nat insde and ip nat outside commands.

                     

                    If you want some extra reading, you can find additional information in the below link.

                     

                    http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/gtnatvi.html

                    • 7. Re: cisco router 871 configuration
                      Bradford Chatterjee (CCIEx2/CCDE)

                      Speaking from experience, Cox's DNS is awful and hardcoding someone else's servers is probably a good idea.

                      • 8. Re: cisco router 871 configuration
                        Erick

                        I will guess you work in the service provider space, so I'll take your word for it!

                        • 9. Re: cisco router 871 configuration
                          jack

                          Thank u ErikB!

                          Those CLI's u posted worked out perfectly, I am now able to surf the internet from my PC, via my cisco router 871.

                          • 10. Re: cisco router 871 configuration
                            Erick

                            Hi jack.

                             

                            No problem.  make sur to save your configuration for put it some where as a backup in case you need it later.

                            • 11. Re: cisco router 871 configuration
                              jack

                              Erick,

                               

                              I am trying to configure the other interface ports on my Cisco 871 router for internet access.

                              FA1 is up, and funtions proplery.

                              FA0 is down, and needs to be configured. (If I need to make this port avaialbe for internet connectivity, how do configure it?)

                               

                              I want to connect my netflix streaming device to the FA0 interface, but I am not sure how to configure it.

                               

                              Thanks for all your help!!

                               

                              Sandro

                               

                               

                              Router>sh ip int b

                              Interface                  IP-Address      OK? Method Status                Prot

                              ocol

                              FastEthernet0              unassigned      YES unset  administratively down down

                               

                               

                              FastEthernet1              unassigned      YES unset  up                    up

                               

                               

                              FastEthernet2              unassigned      YES unset  administratively down down

                               

                               

                              FastEthernet3              unassigned      YES unset  administratively down down

                               

                               

                              FastEthernet4              68.107.26.66    YES DHCP   up                    up

                               

                               

                              Vlan1                      10.10.10.1      YES manual up                    up

                               

                               

                              NVI0                       unassigned      NO  unset  up                    up

                              • 12. Re: cisco router 871 configuration
                                Erick

                                Hi Jack

                                 

                                Ports FE0 - FE3 are normal layer 2 switch ports.  You can't assign IP addresses to them for routing.  FE4 is the only routing interface on that router model. 

                                 

                                If your Netflix device is able to get an address through DHCP, then just plug it into one of the switch ports and enable the interface on the router (no shut command) and you should be good to go.

                                • 13. Re: cisco router 871 configuration
                                  jack

                                  Thanks again Erick, that worked.

                                  I did not realize it was that easy!

                                  • 14. Re: cisco router 871 configuration
                                    jack

                                    Any recommendations for CLI used to backup configurations?

                                     

                                     

                                    Sandro

                                    1 2 Previous Next