4 Replies Latest reply: Mar 30, 2012 9:03 AM by DelVonte RSS

    ASA ospf routing on sub interface

    Ash

      I have a ASA ha pair running ospf with two routers. I have an exisitng class C route (203.166.219.0/24) that is routed via a subinterface 1.45. Which is visible to two neighbor routers via ospf. I want to advertise antoher class C address (103.6.105.0/24) via a different subinterface. I haved added the route exactly the same way as the exisitng one. Does seem to work. I can't see the new route in the ospf database table.  I have copied some of the relevant config below. Any help will be appreciated.

       

       

       

      router ospf 1

      network 192.168.45.0 255.255.255.0 area 0

      network 192.168.46.0 255.255.255.0 area 0

      network 192.168.245.0 255.255.255.0 area 0

      log-adj-changes

      redistribute static

      !

       

       

      interface GigabitEthernet0/1.45

        vlan xx

      nameif zone1-1

      security-level xx

      ip address 192.168.45.1 255.255.255.0 standby 192.168.45.2

       

       

      interface GigabitEthernet0/1.245

      vlan xxx

      nameif zone1-4

      security-level xx

      ip address 192.168.245.1 255.255.255.0 standby 192.168.245.2

       

       

      FWHOF-DMZEXT01/act/sec# sh route

       

      S    103.6.105.0 255.255.255.0 [1/0] via 192.168.245.1, zone1-4

      S    203.166.219.0 255.255.255.0 [1/0] via 192.168.45.1, zone1-1

       

       

       

      FWHOF-DMZEXT01/act/sec# sh ospf neighbor

       

       

      Neighbor ID     Pri   State           Dead Time   Address         Interface

      192.168.46.5      1   FULL/DR         0:00:35     192.168.46.5    outside

      192.168.46.4      1   FULL/BDR        0:00:31     192.168.46.4    outside

      FWHOF-DMZEXT01/act/sec#

       

       

      FWHOF-DMZEXT01/act/sec# sh ospf database

       

       

             OSPF Router with ID (203.166.119.33) (Process ID 1)

       

       

      xxxxxx

       

                      Type-5 AS External Link States

       

      Link ID         ADV Router      Age         Seq#       Checksum Tag

      0.0.0.0         192.168.46.4    1915        0x800008c0 0x9ad1 1

      203.166.219.0   203.166.119.33  1339        0x80000971 0x6fc6 0

      FWHOF-DMZEXT01/act/sec#

       

       

      FWHOF-DMZEXT01/act/sec# sh ospf interface

       

      zone1-1 is up, line protocol is up

        Internet Address 192.168.45.1 mask 255.255.255.0, Area 0

        Process ID 1, Router ID 203.166.119.33, Network Type BROADCAST, Cost: 10

        Transmit Delay is 1 sec, State DR, Priority 1

        Designated Router (ID) 203.166.119.33, Interface address 192.168.45.1

        No backup designated router on this network

        Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

          Hello due in 0:00:04

        Index 1/1, flood queue length 0

        Next 0x0(0)/0x0(0)

        Last flood scan length is 0, maximum is 0

        Last flood scan time is 0 msec, maximum is 0 msec

        Neighbor Count is 0, Adjacent neighbor count is 0

        Suppress hello for 0 neighbor(s)

      outside is up, line protocol is up

        Internet Address 192.168.46.1 mask 255.255.255.240, Area 0

        Process ID 1, Router ID 203.166.119.33, Network Type BROADCAST, Cost: 10

        Transmit Delay is 1 sec, State DROTHER, Priority 1

        Designated Router (ID) 192.168.46.5, Interface address 192.168.46.5

        Backup Designated router (ID) 192.168.46.4, Interface address 192.168.46.4

        Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

          Hello due in 0:00:08

        Index 2/2, flood queue length 0

        Next 0x0(0)/0x0(0)

        Last flood scan length is 0, maximum is 4

        Last flood scan time is 0 msec, maximum is 0 msec

        Neighbor Count is 2, Adjacent neighbor count is 2

          Adjacent with neighbor 192.168.46.5  (Designated Router)

          Adjacent with neighbor 192.168.46.4  (Backup Designated Router)

        Suppress hello for 0 neighbor(s)

      zone1-4 is up, line protocol is up

        Internet Address 192.168.245.1 mask 255.255.255.0, Area 0

        Process ID 1, Router ID 203.166.119.33, Network Type BROADCAST, Cost: 10

        Transmit Delay is 1 sec, State DR, Priority 1

        Designated Router (ID) 203.166.119.33, Interface address 192.168.245.1

        No backup designated router on this network

        Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

          Hello due in 0:00:04

        Index 3/3, flood queue length 0

        Next 0x0(0)/0x0(0)

        Last flood scan length is 0, maximum is 0

        Last flood scan time is 0 msec, maximum is 0 msec

        Neighbor Count is 0, Adjacent neighbor count is 0

        Suppress hello for 0 neighbor(s)

      FWHOF-DMZEXT01/act/sec#