Skip navigation
Cisco Learning Home > Certifications > Voice (CCNP Voice) > Discussions

_Communities

923 Views 2 Replies Latest reply: Mar 27, 2012 4:02 AM by Stephen RSS

Currently Being Moderated

Help me get basic QoS working

Mar 26, 2012 8:17 AM

Stephen 488 posts since
Apr 22, 2011

Hi guys,

 

I've not learnt much about QoS, so set a small lab up to test.  I've got two PC's, and a 1841 connecting them together; as shown below.

 

PC1  ------->  Router  ---------->  PC2

 

 

Here is the config I've put on the router.

 

R1#

class-map match-all test

match access-group 123

!

!

policy-map test

class test

    bandwidth 10

!

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

speed 100

full-duplex

service-policy output test

!

interface FastEthernet0/1

ip address 192.168.10.1 255.255.255.0

speed 100

full-duplex

!

access-list 123 permit ip 192.168.10.0 0.0.0.255 192.168.0.0 0.0.0.255

!

pe2#sh ver

Cisco IOS Software, 1841 Software (C1841-ADVENTERPRISEK9-M), Version 12.4(24)T1, RELEASE SOFTWARE (fc3)

 

 

An iperf test between them shows I've getting 112MB though the connection.  Even though I've configured the bandwidth to be 10Kbps (shown in the config above).  The commands below verify it should definately be 10 Kbps.

 

pe2(config)#policy-map test

pe2(config-pmap)#class test

pe2(config-pmap-c)#bandwidth ?

  <8-2000000>  Kilo Bits per second

 

 

So can anyone tell me why I'm getting 112Mbps, and this isn't being limited by the bandwidth command?  The ACL is taking hits ) as shown below, so I can only assume I've done something wrong with the QoS part.

 

pe2#sh access-list

Extended IP access list 123

    10 permit ip 192.168.10.0 0.0.0.255 192.168.0.0 0.0.0.255 (300435 matches) !obviously the counter was 0 before I tested using iperf

 

 

When configuring the service-policy, I would have like to used an Input policy, however, this command isn't supported, as shown below:

pe2(config-if)#service-policy input test

Weighted Fair Queueing feature not supported in input policy.

Weighted Fair Queueing feature not supported in input policy.

 

 

So why am I able to get the full speed?

 

 

 

Regards,

Stephen

  • Paul Stewart  -  CCIE Security, CCSI 6,952 posts since
    Jul 18, 2008
    Currently Being Moderated
    1. Mar 26, 2012 6:36 PM (in response to Stephen)
    Re: Help me get basic QoS working

    You are reserving 10Kbps. You aren't limiting to that. So in theory if you could run 100Mbps through the router for something that didn't match the acl then you started running traffic that did match the acl, the matching traffic would have a clear path that equals at least 10Kbps. In reality, reserving 10Kb/s on a 100Mb/s is going to be almost imperceptible. You could probably slip 10Kbps through anyway :-) If you want to limit it, use the "police 10000" command

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)