1 2 3 4 Previous Next 49 Replies Latest reply: Apr 6, 2012 1:15 PM by gregsykes Go to original post RSS
      • 15. Re: OSPF route in BGP neighbor for R0 and R1 not showing
        gregsykes

        Thanks Alejandro,

         

        Would you be able to create this model for us in GNS3 so we have discussion for the group ?

        • 16. Re: OSPF route in BGP neighbor for R0 and R1 not showing
          aaceituno

          I will try tomorrow, right now i dont have time to deal with it.

           

          Br

          Alex.

          • 17. Re: OSPF route in BGP neighbor for R0 and R1 not showing
            aniata

            Hi,

             

            while redistributing OSPF in the BGP, use external keyword. It will work; try and let us know.

             

            router bgp 1

            redistribute ospf 1 match external

            • 18. Re: OSPF route in BGP neighbor for R0 and R1 not showing
              gloryitak

              Hey Greg,

               

              I have a question about R1 on your attached packet tracer. I want to know if the 10.x.x.x network  was supposed to be in  bgp or ospf domain; and/or running both bgp &OSPF. I'm asking this because the 10.x.x.x network command is on both ospf and bgp. Please, clarify

               

              Glory

              • 19. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                gloryitak

                Not sure if you guys were able to ping R1 or R0 from R2 & R3. I wasn't able to ping.

                There was no route from R2 & R3 to the 172.18.1.0 network (Bgp domain).

                 

                = NO need to redistribute bgp to ospf nor vise versa since you have already a static route on R1.

                = Remove all duplicate network statement in R1

                =under OSPF, issue the command

                 

                router ospf 100

                log-adjacency-changes

                network 172.16.0.0 0.0.255.255 area 0

                network 10.10.0.0 0.0.255.255 area 0

                default-information originate

                !

                router bgp 100

                bgp log-neighbor-changes

                no synchronization

                neighbor 172.18.1.2 remote-as 200

                neighbor 172.18.1.2 next-hop-self  ( OPTIONAL)

                network 172.18.1.0 mask 255.255.255.0 (OPTIONAL)

                !

                ip classless

                ip route 0.0.0.0 0.0.0.0 172.18.1.2

                 

                I have tested this already. OK

                 

                This O*E2 0.0.0.0/0 [110/1] via 172.16.1.1, 00:00:48, Serial0/0 now appeared in R2 & R3 routing table.

                 

                I can attach a working network here if need be.

                • 20. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                  gregsykes

                  Glory,

                   

                  Yes please attach the configuration file.. Acutally working on this configuration last night the following was discovered:

                   

                   

                   

                  So initially we had problems with this configuration. I went back and added the following statements as per your suggestion for R1 and now all devices ping... I attached the new configuration. user eddy  pasword eddy.

                   

                  router ospf 100

                  log-adjacency-changes

                  network 172.16.0.0 0.0.255.255 area 0

                  network 10.10.0.0 0.0.255.255 area 0

                  !

                  router bgp 100

                  bgp log-neighbor-changes

                  no synchronization

                  neighbor 172.18.1.2 remote-as 200

                  network 30.30.0.0 mask 255.255.255.255

                  network 10.10.0.0 mask 255.255.255.255

                  network 172.0.0.0 mask 255.255.255.0

                  redistribute ospf 100

                  !

                  • 21. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                    gloryitak

                    all devices cannot ping with the command you pasted. Your 10.10.0.0 network is both bgp and OSPF, why? again, this is EBGP, why are you redistributing ospf instead of using static route ponting to you ISP (R0) . Try your ping again and submit true result here. check R2 and R3 routing table, they don't know how to get to 172.18.x.x network. Try a ping.

                    • 22. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                      gregsykes

                      Glory,

                       

                      Updated via this fix:

                       

                      router ospf 100

                       

                      log-adjacency-changes

                       

                      network 172.16.0.0 0.0.255.255 area 0

                       

                      network 10.10.0.0 0.0.255.255 area 0

                       

                      default-information originate

                       

                      !

                       

                      router bgp 100

                       

                      bgp log-neighbor-changes

                       

                      no synchronization

                       

                      neighbor 172.18.1.2 remote-as 200

                       

                      neighbor 172.18.1.2 next-hop-self  ( OPTIONAL)

                       

                      network 172.18.1.0 mask 255.255.255.0

                       

                      !

                       

                      ip classless

                       

                      ip route 0.0.0.0 0.0.0.0 172.18.1.2

                       

                      I was pinging from PDU not CLI.. Got it now... Routing Tables were as follows:

                       

                       

                           10.0.0.0/32 is subnetted, 3 subnets

                      B       10.10.10.1 [20/20] via 172.18.1.1, 17:47:39

                      B       10.10.11.1 [20/20] via 172.18.1.1, 17:47:39

                      B       10.10.12.1 [20/20] via 172.18.1.1, 17:47:39

                           30.0.0.0/32 is subnetted, 4 subnets

                      B       30.30.30.1 [20/65] via 172.18.1.1, 17:47:39

                      B       30.30.31.1 [20/65] via 172.18.1.1, 17:47:39

                      B       30.30.32.1 [20/65] via 172.18.1.1, 17:47:39

                      B       30.30.33.1 [20/65] via 172.18.1.1, 17:47:39

                           172.16.0.0/24 is subnetted, 2 subnets

                      B       172.16.1.0 [20/20] via 172.18.1.1, 17:47:39

                      B       172.16.2.0 [20/128] via 172.18.1.1, 17:47:39

                           172.18.0.0/24 is subnetted, 1 subnets

                      C       172.18.1.0 is directly connected, Serial0/1

                      S*   0.0.0.0/0 is directly connected, Serial0/1

                       

                      New pkt attached.. Please verify.....

                      • 23. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                        gregsykes

                        I was just informed that my topology has errors...

                         

                        u configured 10.x.x.x network in both bgp and ospf?

                        [12:26:45 AM] Glory Itaketo:  u did that already

                        [12:26:51 AM] Glory Itaketo: and i want to know why?

                        [12:27:01 AM] Gregory Sykes: I don't know.

                        [12:27:03 AM] Glory Itaketo: what are u trying to achieve?

                        [12:27:26 AM] Glory Itaketo: u have to be looking to configs carefully

                        [12:27:34 AM] Gregory Sykes: I took your advise and updated the commands via your direction

                        [12:27:58 AM] Glory Itaketo: you didn't answer my qtns

                        [12:28:27 AM] Gregory Sykes: Obviously you have more experince in this field of expertise..

                        [12:28:56 AM] Gregory Sykes: I am at the beginning starge of learning BGP vs OSPF.

                        [12:28:56 AM] Glory Itaketo: see this----------------------------

                        [12:28:59 AM] Glory Itaketo: !

                        router ospf 100

                        log-adjacency-changes

                        network 172.16.0.0 0.0.255.255 area 0

                        network 10.10.0.0 0.0.255.255 area 0

                        default-information originate

                        !

                        router bgp 100

                        bgp log-neighbor-changes

                        no synchronization

                        neighbor 172.18.1.2 remote-as 200

                        neighbor 172.18.1.2 next-hop-self

                        network 30.30.0.0 mask 255.255.255.255

                        network 10.10.0.0 mask 255.255.255.255

                        network 172.0.0.0 mask 255.255.255.0

                        network 172.18.1.0 mask 255.255.255.0

                        redistribute ospf 100

                        !

                        ip classless

                        ip route 0.0.0.0 0.0.0.0 Serial0/0/0

                        ip route 0.0.0.0 0.0.0.0 172.18.1.2

                        !

                        !

                        !

                        !

                        !

                        !

                        !

                        line con 0

                        exec-timeout 0 0

                        password eddy

                        login local

                        line vty 0 4

                        exec-timeout 0 0

                        password eddy

                        login local

                        !

                        !

                        !

                        end

                         

                         

                        R1#

                        [12:29:06 AM] Gregory Sykes: That questoin came from an exam question..

                        [12:29:39 AM] Glory Itaketo: if this were to be a live network you will be have=ing a serious loop issue

                        [12:30:06 AM] Glory Itaketo: why question came from exam?

                        [12:30:17 AM] Glory Itaketo: Greg,

                        [12:30:26 AM] Glory Itaketo: check that config i pasted

                        [12:30:34 AM] Glory Itaketo: that is from router1

                        [12:31:04 AM] Glory Itaketo: [12:29 AM] Glory Itaketo:

                         

                        <<< ip route 0.0.0.0 0.0.0.0 Serial0/0/0

                        ip route 0.0.0.0 0.0.0.0 172.18.1.2

                        [12:31:44 AM] Glory Itaketo: you need to remove one of this default route. Both means the same thing and does the same job

                        [12:32:19 AM] Glory Itaketo: . router ospf 100

                        log-adjacency-changes

                        network 172.16.0.0 0.0.255.255 area 0

                        network 10.10.0.0 0.0.255.255 area 0

                        default-information originate

                        !

                        router bgp 100

                        bgp log-neighbor-changes

                        no synchronization

                        neighbor 172.18.1.2 remote-as 200

                        neighbor 172.18.1.2 next-hop-self

                        network 30.30.0.0 mask 255.255.255.255

                        network 10.10.0.0 mask 255.255.255.255

                        network 172.0.0.0 mask 255.255.255.0

                        network 172.18.1.0 mask 255.255.255.0

                        redistribute ospf 100

                        [12:32:39 AM] Gregory Sykes: So even though my network is working and is now pinging I have a looping situation

                        [12:33:08 AM] Glory Itaketo: you may

                        [12:33:40 AM] Glory Itaketo: now, the second paste is ur OSPF and BGP config

                        [12:34:45 AM] Glory Itaketo: qtn=== why do you have 10.x.x.x network in both routing protocol then stil redistribute OSPF in bgp

                        [12:34:48 AM] Glory Itaketo: ?

                        [12:34:52 AM | Edited 12:35:00 AM] Glory Itaketo: Answer Me

                        [12:35:10 AM] Gregory Sykes: So you won'

                        [12:35:18 AM] Gregory Sykes: have this looping condition???

                        [12:35:24 AM] Glory Itaketo: can't you see a big problem there?

                        [12:35:31 AM] Gregory Sykes: Slowly

                        [12:35:40 AM] Glory Itaketo: am not about winning

                        [12:35:45 AM] Gregory Sykes: I know

                        [12:35:52 AM] Gregory Sykes: I'm listening

                        [12:35:58 AM] Glory Itaketo: we are in CCIE level and I want us to think like such

                        [12:36:19 AM | Edited 12:36:30 AM] Glory Itaketo: One thing==== this is an EBGP

                         

                        So she posted her copy of how this could be corrected. See attached.,

                        • 24. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                          gloryitak

                          Greg,

                           

                          All of these depends largely on what you intend to achieve: your aim for the lab, your goal for the configurations especially between R0 and R1. Your config could be right if it achieve desired goal or attained expected result. That is why I am asking my questions, just to understand your intentions for your initial configs not to impose mine. As your group member, I want to understand goal so I can better tailor my responses. "why do you have 10.x.x.x network in both routing protocol then stil redistribute OSPF in bgp" and both R0 and R1 has default route pointing to each other. Maybe, there may not be any loop issue, but I still don't get it. Maybe we can attach some workstations and servers then test.

                          • 25. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                            gregsykes

                            Glory,

                             

                            As indicated to you earlier, the goal particularly for myself is to pass the wirtten and lab exam for the CCIE Rns course. I mentioned to you that I am in the earlier stage of understand these concepts on a CCIE level. This particular question was brought to my attention by one of my group members which initially I have very little knowledge on bgp vs OSPF. It could be very advantages to hook up some devices to test out this theory. Now were talking over 2000 test questions. I'm not sure if I want to do that for every scenerio.  Gaining this understanding from a simulated viewpoint gives me at least some ground work to further investigate and research while gaining more knowledge on this subject. It was recommended by my instructors to watch the cbts from beginning to end on these topics. Obviously, this topic can get very involved. Your ability to explain in detail and communicate effectively definitely helps and the questions you ask does bring up a way for the group members and myself to think critically and apply this in a real situation. Another thing you may want to take into considerationis that not all group members have the equipment or resoources necessary to test out these theories. Not to say that it can't be done.  I will look into this myself if time prevails adding this to my calander and will let you know what the results are...

                            • 26. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                              gloryitak

                              no worries. we'll meet in the group chat

                              • 27. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                                Vijay Swaminathan

                                Hi Glory,

                                 

                                Just curious.. I'm still in the process of learning BGP and could not resist myself in posting on this thread.

                                 

                                I was going through the config posted in post # 23, and went through the bgp configuration.

                                 

                                In that, the network 172.18.1.x is advertised on the bgp process.. do we really need them as it is a directly connected interface on R2 and since the other OSPF speaking routers (r3 / r4) has got a default route to R2 (as part of default -originate command) they would obviously have connectivity to the link 172.18.1.1 (R1's interface).. just trying to understnad  what could be the significance?

                                 

                                I have the following configs on R1 and R2 (bgp alone) and this works fine.

                                 

                                On R1:

                                =====

                                 

                                R1#sh run | sec bg

                                router bgp 200

                                no synchronization

                                bgp log-neighbor-changes

                                neighbor 172.18.1.2 remote-as 100

                                no auto-summary

                                R1#

                                 

                                On R2:

                                =====

                                 

                                router bgp 100

                                no synchronization

                                bgp log-neighbor-changes

                                redistribute ospf 1

                                neighbor 172.18.1.1 remote-as 200

                                neighbor 172.18.1.1 next-hop-self

                                no auto-summary

                                R2#

                                 

                                and from R3 / R4 the following ping works:

                                 

                                R4#ping 172.18.1.1

                                 

                                 

                                Type escape sequence to abort.

                                Sending 5, 100-byte ICMP Echos to 172.18.1.1, timeout is 2 seconds:

                                !!!!!

                                Success rate is 100 percent (5/5), round-trip min/avg/max = 4/28/64 ms

                                R4#

                                 

                                R3#ping 172.18.1.1

                                 

                                 

                                Type escape sequence to abort.

                                Sending 5, 100-byte ICMP Echos to 172.18.1.1, timeout is 2 seconds:

                                !!!!!

                                Success rate is 100 percent (5/5), round-trip min/avg/max = 1/32/108 ms

                                R3#

                                 

                                - Vijay

                                • 28. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                                  gloryitak

                                  Hi Vijay,

                                   

                                  No, we don't need to advertise it to outside network. It was meant to be ISP IBGP advertisement, it was my playing around with bgp features. It is not advertise back to OSPF though. My point was to emphasize the use of configured default route instead of redistributing ospf or bgp between R0 and R1. The network statement in bgp I included has nothing to do with original Lab. It personal  additional Lab attached to R0 that is not on that Packet tracer.

                                   

                                  So, please ignore it. That is why I didn't redistribute. Great catch Vijay!

                                  • 29. Re: OSPF route in BGP neighbor for R0 and R1 not showing
                                    aaceituno

                                       Excuse me excuse me, but looking at the Greg configurations looks like have no idea about bgp ...... 

                                     

                                       First, BGP is the internet protocol, so often used for ISP connections to internet.

                                       Never never never redistribute an IGP into BGP, unless you have an output filter or aggregate that propagate only your public pools into a ISP network.

                                       If you redistribute an igp this is very possible you will be banned and your bgp connection disabled from the ISP. There is a maximum prefix feature, if you propagate more prefix than allowed then ISP could disable you bgp connection, could drop the excess routes, and of course will only allow your legitimate public routes.

                                     

                                       You could redistribute an igp into bgp only under MPLS/VPN configurations, not for isp or internet connections. And BGP is not a IGP protocol, dont use this if you dont really need this.

                                     

                                      Since you use a redistribute ospf, your networks command are useless.

                                     

                                      Also, remember, for every network command there should be an exact match route for that network command. You configured several networks with a /32 mask. This mask is not like the access lists mask, this is not a "match this bit", this is the real network mask of the route. For example, if you want to propagate the route 10.1.1.0/24, will have to configure network command 10.1.1.0 netmask 255.255.255.0, if you configure 10.1.1.0 netmask 255.255.255.255 you instruct the router to look for the route 10.1.1.0/32, these are not the same route.

                                     

                                       If you want to redistribute a default route into ospf, whenever the bgp connection is active, its better to use the conditional route advertisement. You have to configure a route-map, that will match on a bgp learned prefix. This way, if you learn this prefix or prefixes, you will propagate the default route.

                                     

                                       There is no need to use default routes with next hop your bgp peer, because if you use a default route then you dont need a bgp session to learn prefixes, you are going to send all outgoing traffic through that connection regardless of what you learn.

                                        If you learn bgp prefixes is because you are going to use this someway. If you dont need lo learn nothing because you are going to use a default route, you should apply an incoming route filter that deny everyting. This way your router will save memory, and cpu. Better if your peer apply this filter and dont send prefix to your router.

                                     

                                       If you need to redistribute ospf into bgp, then you will need the match internal and/or external. If you redistribute bgp into ospf, you will redistribute only EBGP prefixes. from other ***. Will not redistribute internal prefix unless you configure the bgp redistribute internal.

                                     

                                     

                                        There is lot of things you should learn about bgp yet.