3 Replies Latest reply: Feb 17, 2012 9:23 AM by tonypearce1 RSS

    CME 4.1 fxo and pstn voice mail not answering ?

    pat

      Hi All -

       

               I am using cme 4.1 on a 2611xm router and have a fxo card connected to the pstn. I am using connection plar to ring all local extensions upon receipt of a inbound call from the pstn. The local extensions are using 7912 iphones and I have set up button overlays using the same directory number so that plar will ring all phones. This works great except for the voice mail system that is located at the Central office of the pstn provider. This voice mail usually picks up after 4 rings on the old pbx system but with the 2611xm fxo port the voicemail is not picking up at all. It seems like the fxo port answers the call (goes off hook) on the first ring from the pstn and then it rings the local extensions as desired but the remote vmail does not pick up after 4 rings( because the fxo port has gone off hook already). Is there anything that I can do to fix this?

       

      Thanks .....PAt

        • 1. Re: CME 4.1 fxo and pstn voice mail not answering ?
          tonypearce1

          Hi Pat!

          You are correct in your sumarisation. The CME system picks up the inbound call, and provides a secondary ring tone to the caller whilst it rings your IP phones. I also had this problem and used the work around I am about to tell you. The second problem I had with your current method is that when the caller hangs up, the CME system is unable to detect this easily. Therefore your IP phones will continue to ring, even though there is no one on the other end of the line. Sometimes, I would pick up the IP phone and there would be no one there. The below configuration overcomes this issue:

           

          voice-port 0/0/0

          trunk-group POTS

          cptone GB

          timing sup-disconnect 85

          connection plar opx 1000

          impedance complex3

          caller-id enable

          caller-id alerting line-reversal

          caller-id alerting dsp-pre-allocate

           

          The "connection plar opx" command followed by the pilot number or the number you have assigned to your many phones uses the "offline private extension (opx)" command. This allows the CME system to detect the inbound call by the ringing signal, and alert your phones on the number specified but not actually connect, or pick up the call until someone answers one of the IP phones. The caller only ever hears the ringing signal provided by your PSTN. When no one answers the IP phones, your PSTN will divert the call to the voice mail.

           

          The next issues is that how do you know that you have a voice mail? In my case the telco changes the dial tone to signal this fact. I never hear this dial tone as I hear the tone provided by the CME. In my case I either just dial the telco's voicemail system by pressing my "messages" button, or configure a dial-peer with a number that simply picks up the line and allows me to listen to the telco dial tone.

           

          One other way in which I prefer to have all phones ring is by giving each extension a unique number to allow internal calling, but to configure a parallel hunt group so all phones ring simultaneously that are within the hunt group.

           

          If you don't mind me asking, what is your country of residence?

           

          Thanks,

           

          Tony

          • 2. Re: CME 4.1 fxo and pstn voice mail not answering ?
            pat

            Hi Tony -

             

                  Thanks the connection plar opx 1000  worked perfectly. I am located in the USA.  I notice that you have used other configs such as timing sup-disconnect 85 and impedance complex3. I am not sure what those are for.

             

            Thanks - PAt

            • 3. Re: CME 4.1 fxo and pstn voice mail not answering ?
              tonypearce1

              Cool Pat glad that worked!
              I am in Great Britian. I have impedance matched the copper pair for my telco. If you do not do this you can get echo and noise, apparently.

              The timing command allows the CME system to ensure that the far end has actually hung up. http://www.cisco.com/en/US/docs/ios/12_3t/voice/command/reference/vrht_t3_ps5207_TSD_Products_Command_Reference_Chapter.html#wp1627898

               

              Cheers,

              Tony