Skip navigation
Cisco Learning Home > Learning Center > Discussions

_Communities

This Question is Not Answered 1 Correct Answer available (4 pts) 1 Helpful Answer available (2 pts)
1341 Views 20 Replies Latest reply: Feb 6, 2012 11:34 AM by Jeremy M. RSS 1 2 Previous Next

Currently Being Moderated

ROAS not working in home lab

Feb 5, 2012 10:10 AM

Jeremy M. 20 posts since
Dec 18, 2011

Hey all,

I'm having trouble with a router on a stick config.  It seems so simple I don't know why I can't get it to work.  Anyways,  I have 2610xm connected to a 2950 and the current configs are not working.  I can ping the default gateway from a host but that is as far as I can get.  Its weird too, with the 2950 you can only have one VLAN up, up at a time...?.?!  I am going to attach my configs to see if you guys can help, thanks in advance .  Oh yeah, I am trying to ping 192.168.20.1 ( vlan 20) gateway or host on that subnet/vlan from 192.168.10.25 (vlan 10) and it isn't working. Please help!! Thanks!!!

 



Attachments:
  • Currently Being Moderated
    1. Feb 5, 2012 3:13 PM (in response to Jeremy M.)
    Re: ROAS not working in home lab

    I think you're missing the point of ROAS.....all L3 interfaces should reside on the router, save for one L3 IP on the L2 switch for management purposes.

     

    With that said, you need to set the switch port's uplink to the router as a trunk, and define the L2 instance of VLANs 10 and 20 on the switch.  Since 10 and 20 are already tagged on the router you need to ensure they are tagged by the switch, which means you need to leave VLAN1 as native on the 2950.

     

    Also, you need to include the 192.168.10.0 and 192.168.20.0 networks under RIP, if you wish RIP to route between the subnets.

  • Currently Being Moderated
    4. Feb 5, 2012 7:58 PM (in response to Jeremy M.)
    Re: ROAS not working in home lab

    what are you getting when you run: sh int trunk on the switch?

  • Currently Being Moderated
    5. Feb 5, 2012 9:09 PM (in response to Jeremy M.)
    Re: ROAS not working in home lab

    I dropped your configs in packet tracer...change int fa0/12 to speed and duplex auto, it cant negotiate.

  • Currently Being Moderated
    8. Feb 6, 2012 7:41 AM (in response to Jeremy M.)
    Re: ROAS not working in home lab

    Can you provide the output of the following commands on the switch?

     

    show vlan

     

    show interface trunk

     

    show cdp nei

     

    show ip int brie | e notc

     

    Thanks!

  • Currently Being Moderated
    11. Feb 6, 2012 10:55 AM (in response to Jeremy M.)
    Re: ROAS not working in home lab

    Try moving the IP you have on the router physical interface to Fa0/0.1, and set "encap dot1q 1 native".  Then make sure the physical interface is blank other than "no shut" and the duplex/speed settings.

  • Currently Being Moderated
    14. Feb 6, 2012 11:11 AM (in response to Jeremy M.)
    Re: ROAS not working in home lab

    So what does your RIP config look like on the router now? 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)