Skip navigation
Cisco Learning Home > Connections > Cisco Expert-Level Training > For CCIE Routing and Switching > Discussions

_Communities

This Question is Not Answered 1 Correct Answer available (4 pts) 2 Helpful Answers available (2 pts)
1838 Views 1 Reply Latest reply: Dec 1, 2011 5:34 PM by Keith Barker - CCIE RS/Security, CISSP RSS

Currently Being Moderated

Required Help: HSRP on trunk Interfaces

Dec 1, 2011 8:49 AM

VijayD 17 posts since
Jun 7, 2010

We are desinging network where we want to run HSRP on   trunk interface ( Encapsulation DOT1Q) on which were allowing multiple VLANS.We are using Cisco 3925 series router with switch module integrated in it.can anybody help us out to configure HSRP on trunk interface.If possible provide me sample configuration.

 

Thanks in advance......

  • Keith Barker - CCIE RS/Security, CISSP 5,351 posts since
    Jul 3, 2009
    Currently Being Moderated
    1. Dec 1, 2011 5:34 PM (in response to VijayD)
    Re: Required Help: HSRP on trunk Interfaces

    Hello Vijay-

     

     

    Here is the answer to your question:

     

    R1:


    interface FastEthernet1/0.1

    encapsulation dot1Q 10

    ip address 10.0.0.1 255.255.255.0

    standby 1 ip 10.0.0.5

    standby 1 priority 105

    standby 1 preempt

    !

    interface FastEthernet1/0.2

    encapsulation dot1Q 20

    ip address 20.0.0.1 255.255.255.0

    standby 2 ip 20.0.0.5

     

     

    R2:

    interface FastEthernet1/0.1

    encapsulation dot1Q 10

    ip address 10.0.0.2 255.255.255.0

    standby 1 ip 10.0.0.5

    !

    interface FastEthernet1/0.2

    encapsulation dot1Q 20

    ip address 20.0.0.2 255.255.255.0

    standby 2 ip 20.0.0.5

    standby 2 priority 105

    standby 2 preempt

    !


    R2#show standby

    FastEthernet1/0.1 - Group 1

      State is Standby

        4 state changes, last state change 00:01:38

      Virtual IP address is 10.0.0.5

      Active virtual MAC address is 0000.0c07.ac01

        Local virtual MAC address is 0000.0c07.ac01

      Hello time 3 sec, hold time 10 sec

        Next hello sent in 2.464 secs

      Preemption disabled

      Active router is 10.0.0.1, priority 105

      Standby router is local

      Priority 100 (default 100)

      Group name is "hsrp-Fa1/0.1-1" (default)

    FastEthernet1/0.2 - Group 2

      State is Active

        2 state changes, last state change 00:03:18

      Virtual IP address is 20.0.0.5

      Active virtual MAC address is 0000.0c07.ac02

        Local virtual MAC address is 0000.0c07.ac02

      Hello time 3 sec, hold time 10 sec

        Next hello sent in 2.336 secs

      Preemption enabled

      Active router is local

      Standby router is 20.0.0.1, priority 100

      Priority 105 (configured 105)

      Group name is "hsrp-Fa1/0.2-2" (default)

    R2#

     

    Setting the preempt and priority are optional.

     

    Best wishes,

     

    Keith

     

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)