4 Replies Latest reply: Dec 29, 2012 3:13 AM by Annu RSS

    OSPF NBMA Adjacencies

    CCNP R&S/CCNA:Wireless

      I'm struggling with getting my head around OSPF NBMA configuration.

      With the configuration I have right now the adjacency drops and reloads periodically.

       

      The errors are happening about every 60 seconds on all 3 routers:

       

       

      R3

      R3#

      *Nov 17 18:04:23.563: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

      R3#

      *Nov 17 18:04:43.635: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial1/0 from LOADING to FULL, Loading Done

      R3#

      *Nov 17 18:05:33.483: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

      R3#

      *Nov 17 18:05:53.643: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial1/0 from LOADING to FULL, Loading Done

       

       

       

      In the diagram, R1 is the hub and R2 and R3 are spokes.

       

      FR1 has these DLCI mappings:

      port 1, DLCI 102 to port 2, DLCI 201

      port 1, DLCI 103 to port 3, DLCI 301

      Capture.PNG

       

       

       

      R1R2R3

      interface Serial1/0

      ip address 123.1.1.1 255.255.255.0

      encapsulation frame-relay

      ip ospf network broadcast

      serial restart-delay 0

      frame-relay map ip 123.1.1.3 103

      frame-relay map ip 123.1.1.2 102

      !

      interface Loopback0

      ip address 1.1.1.1 255.255.255.255

      ip ospf 1 area 1

      !

      router ospf 1

      log-adjacency-changes

      network 123.1.1.0 0.0.0.255 area 0

      interface Serial1/0

      ip address 123.1.1.2 255.255.255.0

      encapsulation frame-relay

      ip ospf network broadcast

      serial restart-delay 0

      frame-relay interface-dlci 201

      !

      interface Loopback0

      ip address 2.2.2.2 255.255.255.255

      ip ospf 1 area 2

      !

      router ospf 1

      log-adjacency-changes

      network 123.1.1.0 0.0.0.255 area 0

      interface Serial1/0

      ip address 123.1.1.3 255.255.255.0

      encapsulation frame-relay

      ip ospf network broadcast

      serial restart-delay 0

      frame-relay interface-dlci 301

      !

      interface Loopback0

      ip address 3.3.3.3 255.255.255.255

      ip ospf 1 area 3

      !

      router ospf 1

      log-adjacency-changes

      network 123.1.1.0 0.0.0.255 area 0