Skip navigation
Cisco Learning Home > Certifications > CCIE Routing & Switching > Discussions

_Communities

1807 Views 3 Replies Latest reply: Dec 17, 2011 2:51 PM by Scott Morris - CCDE/4xCCIE/2xJNCIE RSS

Currently Being Moderated

Dhcp and intervlan routing over trunking

Oct 16, 2011 1:30 PM

moha 85 posts since
Aug 28, 2011

Dear All experts

IAm now in A project fro configuring dhcp pools on router 1851 router to enAble muli vlAns configured on 2691 switch to get dhcp Addresses from corresponding dhcp pools

Also i Am plAnning to chAnge the mAnAgementvlAn to be vlAn 10

wAht is the correct configurAtion for my situAtion?

And  After configurAtion the pcs couldn't get ip dhcp Address from dhcp ?i dont know why ? whAt is the solution ?

Are there Any AddtionAl commAnds neede on the previous plAtform to mAke this operAtion successfully?

 

 

on Router

 

ip dhcp pool data
network 10.14.16.0 255.255.240.0
default-router 10.14.16.1 255.255.240.0
dns-server 10.14.16.200
lease infinite
!
ip dhcp pool voice
network 10.14.64.0 255.255.240.0
default-router 10.14.64.1 255.255.240.0
dns-server 10.14.16.200
lease infinite
!
ip dhcp pool guest
network 10.14.32.0 255.255.240.0
dns-server 10.14.16.200
default-router 10.14.32.1 255.255.240.0
lease infinite
!
ip dhcp pool old
network 10.14.0.0 255.255.0.0
dns-server 10.14.11.200
default-router 10.14.51.2
lease infinite

 

 

interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 10.14.51.2 255.255.0.0

sutdown
!
interface FastEthernet0/1.2
encapsulation dot1Q 2
ip address 10.14.16.1 255.255.240.0

!
interface FastEthernet0/1.3
encapsulation dot1Q 3
ip address 10.14.32.1 255.255.240.0

!
interface FastEthernet0/1.5
encapsulation dot1Q 5
ip address 10.14.64.1 255.255.240.0

!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 192.168.14.254 255.255.255.0

 

 

On the switch:

interface Vlan1
ip address 10.14.11.1 255.255.0.0
no ip route-cache
!
interface Vlan2
no ip address
no ip route-cache
!

 

 

and vlan 2,3,5,10

are configured on switch

 

the case is:

 

all pcs now are connected to vlan 1

but i want to connect all pcs to vlan 2

and to get ips from dhcp pool of data on the router

which is 10.14.16.0 255.255.240.0

and if i want a port to access vlan 3 i want it to get ip form dhcp pool for guest which is configured on the router

which is 10.14.32.0 255.255.240.0

  • Keneil Facey 200 posts since
    Oct 1, 2010
    Currently Being Moderated
    1. Oct 16, 2011 7:10 PM (in response to moha)
    Re: Dhcp and intervlan routing over trunking

    Hi,

     

    Could you post your show vlan br, and show int trunk for the switch please?

     

    Keneil

  • faizkarimullah 6 posts since
    Sep 14, 2011
    Currently Being Moderated
    2. Dec 17, 2011 4:40 AM (in response to moha)
    Re: Dhcp and intervlan routing over trunking

    Hi,

     

        i have also done same thing and my hosts was not assgined ip address by dhcp server ,when i had typed on router sh ip interface brief ,virtual interface state shutdown so go to all virtual interface and phy interface and give command " no shutdown "  and on switch where router is connected here configure trunk

  • Scott Morris - CCDE/4xCCIE/2xJNCIE 8,398 posts since
    Oct 7, 2008
    Currently Being Moderated
    3. Dec 17, 2011 2:51 PM (in response to moha)
    Re: Dhcp and intervlan routing over trunking

    I'd **** the "old" pool.  I'm not sure that the router's DHCP server gives address in most-specific group or not...

     

    And your "default-router" command doesn't need the netmask on there as it's acting as it that's a second router out (though not valid).

     

    What you have should work fine though.  Especially since your native interface is shutdown since that obviously overlaps with the rest of the groups.

     

    VLAN 10 doesn't have a pool, and doesn't have an "ip helper-address" to forward on to another server...   So you may want to fix one of the two.

     

    Scott

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)