13 Replies Latest reply: Dec 9, 2011 2:33 PM by cadetalain RSS

    OSPF over Frame Relay

    Bogdan

      Hello,

      I know i read something about this in the Official Certification Guide for CCNP Route but I can't find it anymore, and it just bugs me.

      Why does the configuration bellow works if I do a frame-relay map to the ip that is configured on interface ?

      if you use for example on R1 frame-relay map ip 10.0.0.2 102 broadcast and on R2 frame-relay map ip 10.0.0.1 201 broadcast ,neighbors are formed, without broadcast keyword neighbors don't come up of course, but how does it work with this config ?

       

      Below are the configurations

       

      Capture.JPG

       

      R1

      interface Serial0/0

      ip address 10.0.0.1 255.255.255.0

      encapsulation frame-relay

      ip ospf network point-to-point

      clock rate 2000000

      frame-relay map ip 10.0.0.1 102 broadcast

      frame-relay map ip 10.0.0.2 102

      frame-relay interface-dlci 102

      no frame-relay inverse-arp

      router ospf 1

      network 10.0.0.0 0.0.0.255 area 0

       

      R2

      interface Serial0/1

      ip address 10.0.0.2 255.255.255.0

      encapsulation frame-relay

      ip ospf network point-to-point

      clock rate 2000000

      frame-relay map ip 10.0.0.1 201

      frame-relay map ip 10.0.0.2 201 broadcast

      frame-relay interface-dlci 201

      no frame-relay inverse-arp

      router ospf 1

      network 10.0.0.0 0.0.0.255 area 0

       

      FR

      frame-relay switching

      interface Serial0/0

      no ip address

      encapsulation frame-relay

      logging event subif-link-status

      logging event dlci-status-change

      clockrate 56000

      no frame-relay inverse-arp

      frame-relay intf-type dce

      frame-relay route 102 interface Serial0/1 201

      interface Serial0/1

      no ip address

      encapsulation frame-relay

      logging event subif-link-status

      logging event dlci-status-change

      clockrate 56000

      no frame-relay inverse-arp

      frame-relay intf-type dce

      frame-relay route 201 interface Serial0/0 102

       

       

      R1#sh ip ospf neighbor

       

      Neighbor ID     Pri   State           Dead Time   Address         Interface

      10.0.0.2          0   FULL/  -        00:00:33    10.0.0.2        Serial0/0

       

       

      R2#sh ip ospf neighbor

       

      Neighbor ID     Pri   State           Dead Time   Address         Interface

      10.0.0.1          0   FULL/  -        00:00:35    10.0.0.1        Serial0/1

        • 1. Re: OSPF over Frame Relay
          cadetalain

          Hi,

           

          It is working because you changed the ospf network type to point-to-point.The broadcast keyword must be configured once per dlci and it is in the first statement.This statement is configured so the router can ping its own address.You could put the broadcast keyword on second static map and remove it from first and it would still work.

           

          Alain.

          • 2. Re: OSPF over Frame Relay
            Bogdan

            Let me see if I've got this:

            you are saying that if you configure frame relay map ip1 dlci1 with broadcast, then if i use another frame relay map ip2 dlci1 command without broadcast keyword it will also forward broadcasts to ip2 ?

            • 3. Re: OSPF over Frame Relay
              cadetalain

              Hi Bogdan,

               

              Yes, that is exactly what I'm saying.

               

              Alain.

              • 4. Re: OSPF over Frame Relay
                Bogdan

                thank you! you've been very helpful !

                • 5. Re: OSPF over Frame Relay
                  Martin

                  see my 2 posts  with attachments; save those and memorize for exam

                   

                  https://learningnetwork.cisco.com/thread/30374

                  • 6. Re: OSPF over Frame Relay
                    Eddie

                    hi guys, it is interesting topic, i have one quations about FR too!

                     

                    tell me please, how long time elapsed afrer routers dynamicaly discover InARP/IP addresses?

                     

                    when i an sh/no sh interfaces, they long time dont see they IP addresses in FR arp cash.

                     

                    R1(config-router)#do s fram map

                    Serial1/0.1 (up): ip 10.0.0.2 dlci 102(0x66,0x1860), dynamic,

                                  broadcast,

                                  CISCO, status defined, active

                    Serial1/0.1 (up): ip 10.0.0.3 dlci 103(0x67,0x1870), dynamic,

                                  broadcast,

                                  CISCO, status defined, active

                    Serial1/0.1 (up): ip 10.0.0.4 dlci 104(0x68,0x1880), dynamic,

                                  broadcast,

                                  CISCO, status defined, active

                    R1(config-router)#

                     

                    =================================

                     

                    then clear fram inarp

                     

                    =======================

                     

                    R1(config-if)#do sh fram ma
                    Serial1/0.1 (up): ip 10.0.0.4 dlci 104(0x68,0x1880), dynamic,
                                  broadcast,
                                  CISCO, status defined, active
                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#do clear fram ina
                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#do sh fram ma

                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#do sh fram ma

                    R1(config-if)#do s clo
                    *02:16:03.563 UTC Tue Dec 6 2011
                    R1(config-if)#do sh fram ma

                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#
                    *Dec  6 02:16:29: OSPF: end of Wait on interface Serial1/0.1
                    *Dec  6 02:16:29: OSPF: DR/BDR election on Serial1/0.1
                    *Dec  6 02:16:29: OSPF: Elect BDR 1.1.1.1
                    *Dec  6 02:16:29: OSPF: Elect DR 1.1.1.1
                    *Dec  6 02:16:29: OSPF: Elect BDR 0.0.0.0
                    *Dec  6 02:16:29: OSPF: Elect DR 1.1.1.1
                    *Dec  6 02:16:29:        DR: 1.1.1.1 (Id)   BDR: none
                    *Dec  6 02:16:30: OSPF: No full nbrs to build Net Lsa for interface Serial1/0.1
                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#do sh fram ma
                    Serial1/0.1 (up): ip 10.0.0.2 dlci 102(0x66,0x1860), dynamic,
                                  broadcast,, status defined, active
                    Serial1/0.1 (up): ip 10.0.0.3 dlci 103(0x67,0x1870), dynamic,
                                  broadcast,
                                  CISCO, status defined, active
                    Serial1/0.1 (up): ip 10.0.0.4 dlci 104(0x68,0x1880), dynamic,
                                  broadcast,
                                  CISCO, status defined, active
                    R1(config-if)#
                    R1(config-if)#
                    R1(config-if)#

                     

                    ===========================

                    ================================================

                     

                    on the R3 in arp does not work at all after treatment!

                     

                    R3#s fram ma
                    Serial1/0.5 (up): ip 10.0.0.1 dlci 101(0x65,0x1850), dynamic,
                                  broadcast,
                                  CISCO, status defined, active
                    Serial1/0.5 (up): ip 10.0.0.2 dlci 101(0x65,0x1850), static,
                                  broadcast,
                                  CISCO, status defined, active
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#cle
                    R3#clear fra
                    R3#clear frame-relay in
                    R3#clear frame-relay inarp
                    R3#s fram ma
                    Serial1/0.5 (up): ip 10.0.0.2 dlci 101(0x65,0x1850), static,
                                  broadcast,
                                  CISCO, status defined, active
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#s fram ma
                    Serial1/0.5 (up): ip 10.0.0.2 dlci 101(0x65,0x1850), static,
                                  broadcast,
                                  CISCO, status defined, active
                    R3#
                    R3#
                    R3#s fram ma
                    Serial1/0.5 (up): ip 10.0.0.2 dlci 101(0x65,0x1850), static,
                                  broadcast,
                                  CISCO, status defined, active
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#s fram ma
                    Serial1/0.5 (up): ip 10.0.0.2 dlci 101(0x65,0x1850), static,
                                  broadcast,
                                  CISCO, status defined, active
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#p 10.0.0.2\

                    ping 10.0.0.2\
                                      ^
                    % Invalid input detected at '^' marker.

                    R3#p 10.0.0.2

                    Type escape sequence to abort.
                    Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
                    !!!!!
                    Success rate is 100 percent (5/5), round-trip min/avg/max = 120/126/136 ms
                    R3#p 10.0.0.1

                    Type escape sequence to abort.
                    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
                    .....
                    Success rate is 0 percent (0/5)
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#s fram ma
                    Serial1/0.5 (up): ip 10.0.0.2 dlci 101(0x65,0x1850), static,
                                  broadcast,
                                  CISCO, status defined, active
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#
                    R3#

                    • 7. Re: OSPF over Frame Relay
                      Eddie

                      i am reboot serial int, and then all was OK!

                       

                      R3#

                      R3#

                      R3#conf t

                      Enter configuration commands, one per line.  End with CNTL/Z.

                      R3(config)#int ser 1/0

                      R3(config-if)#sh

                      R3(config-if)#

                      *Dec  6 02:27:51: %LINK-5-CHANGED: Interface Serial1/0, changed state to administratively down

                      R3(config-if)#

                      *Dec  6 02:27:51: %ENTITY_ALARM-6-INFO: ASSERT INFO Se1/0 Physical Port Administrative State Down

                      *Dec  6 02:27:52: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down

                      R3(config-if)#

                      R3(config-if)#

                      R3(config-if)#

                      R3(config-if)#

                      R3(config-if)#no sh

                      R3(config-if)#

                      *Dec  6 02:28:01: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up

                      R3(config-if)#

                      *Dec  6 02:28:01: %ENTITY_ALARM-6-INFO: CLEAR INFO Se1/0 Physical Port Administrative State Down

                      *Dec  6 02:28:02: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

                      R3(config-if)#

                      R3(config-if)#

                      R3(config-if)#do s fram ma

                      Serial1/0.5 (up): ip 10.0.0.1 dlci 101(0x65,0x1850), dynamic,

                                    broadcast,

                                    CISCO, status defined, active

                      Serial1/0.5 (up): ip 10.0.0.2 dlci 101(0x65,0x1850), static,

                                    broadcast,

                                    CISCO, status defined, active

                      R3(config-if)#

                      • 8. Re: OSPF over Frame Relay
                        Eddie

                        hi,

                        when ospf do periodical reflooding LSA every 30min, spf algoritm dont run?

                         

                        here we see that spf run executed 2 times

                         

                        R1#s ip os | b Are
                            Area BACKBONE(0)
                                Number of interfaces in this area is 2 (1 loopback)
                                Area has no authentication
                               SPF algorithm last executed 07:51:42.172 ago
                                SPF algorithm executed 2 times
                                Area ranges are
                                Number of LSA 5. Checksum Sum 0x02458C
                                Number of opaque link LSA 0. Checksum Sum 0x000000
                                Number of DCbitless LSA 0
                                Number of indication LSA 0
                                Number of DoNotAge LSA 0
                                Flood list length 0

                        R1#

                         

                        debug ospf

                         

                         

                         

                        R1#

                        *Dec  6 15:20:20: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 15:20:31: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000003

                        *Dec  6 15:20:31: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 15:20:31: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 15:20:40: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 15:20:58: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 15:54:09: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 15:54:14: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000004

                        *Dec  6 15:54:14: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 15:54:14: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 15:54:26: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 15:54:49: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 16:27:48: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 16:27:57: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 16:28:01: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000005

                        *Dec  6 16:28:01: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 16:28:01: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 16:28:17: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 17:01:24: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 17:01:25: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000006

                        *Dec  6 17:01:25: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 17:01:25: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 17:01:33: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 17:02:05: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 17:35:07: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        *Dec  6 17:35:07: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000007

                        *Dec  6 17:35:07: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 17:35:07: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 17:35:27: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 17:35:33: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 18:05:15: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000008

                        *Dec  6 18:05:15: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 18:05:15: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 18:08:30: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 18:08:41: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 18:09:29: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 18:38:19: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000009

                        *Dec  6 18:38:19: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 18:38:19: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 18:39:31: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 18:41:48: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 18:42:30: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 19:11:35: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x8000000A

                        *Dec  6 19:11:35: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 19:11:35: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 19:13:02: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 19:15:19: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 19:16:19: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 19:44:39: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x8000000B

                        *Dec  6 19:44:39: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 19:44:39: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 19:46:28: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 19:49:30: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 19:50:03: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 20:18:05: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x8000000C

                        *Dec  6 20:18:05: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 20:18:05: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 20:20:13: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 20:23:04: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 20:23:48: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 20:51:46: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x8000000D

                        *Dec  6 20:51:46: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 20:51:46: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 20:53:53: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 20:56:27: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 20:57:21: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 21:25:06: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x8000000E

                        *Dec  6 21:25:06: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 21:25:06: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 21:27:36: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 21:29:59: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 21:31:08: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 21:58:34: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x8000000F

                        *Dec  6 21:58:34: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 21:58:34: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 22:00:03: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 22:01:31: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 22:04:49: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 22:32:12: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000010

                        *Dec  6 22:32:12: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        *Dec  6 22:32:12: OSPF: Build network LSA for Serial1/0.1, router ID 1.1.1.1

                        R1#

                        *Dec  6 22:33:11: OSPF: Rcv LS UPD from 4.4.4.4 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 22:34:55: OSPF: Rcv LS UPD from 2.2.2.2 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        *Dec  6 22:38:46: OSPF: Rcv LS UPD from 3.3.3.3 on Serial1/0.1 length 76 LSA count 1

                        R1#

                        • 9. Re: OSPF over Frame Relay
                          Brian McGahan - 4 x CCIE, CCDE

                          Periodic flooding does not cause an SPF run since nothing in the database changed.  Only certain changes cause SPF to run, such as number of links in the LSA, neighbor state change, cost change, etc.

                          • 10. Re: OSPF over Frame Relay
                            Eddie

                            thank you Brian!

                            tell me please, why local ip add dont pingable on the serial links interface Frame Relay encapsulation?

                             

                            becose dont work L2, and router dont know what dlci belong this ip add?

                             

                             

                            R1#s ip int br
                            Interface                  IP-Address      OK? Method Status                Protocol
                            FastEthernet0/0            20.20.20.1      YES manual up                    up
                            Serial1/0                  unassigned      YES NVRAM  up                    up
                            Serial1/0.1                10.0.0.1        YES NVRAM  up                    up
                            Serial1/1                  unassigned      YES NVRAM  administratively down down
                            Serial1/2                  unassigned      YES NVRAM  administratively down down
                            Serial1/3                  unassigned      YES NVRAM  administratively down down
                            Loopback0                  1.1.1.1         YES NVRAM  up                    up
                            R1#s run int s1/0.1
                            Building configuration...

                            Current configuration : 224 bytes
                            !
                            interface Serial1/0.1 multipoint
                            ip address 10.0.0.1 255.255.255.248
                            ip ospf network point-to-multipoint non-broadcast
                            frame-relay interface-dlci 102
                            frame-relay interface-dlci 103
                            frame-relay interface-dlci 104
                            end

                            R1#p 10.0.0.1

                            Type escape sequence to abort.
                            Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
                            .....
                            Success rate is 0 percent (0/5)
                            R1#s fram ma
                            Serial1/0.1 (up): ip 10.0.0.2 dlci 102(0x66,0x1860), dynamic,
                                          broadcast,, status defined, active
                            Serial1/0.1 (up): ip 10.0.0.3 dlci 103(0x67,0x1870), dynamic,
                                          broadcast,, status defined, active
                            Serial1/0.1 (up): ip 10.0.0.4 dlci 104(0x68,0x1880), dynamic,
                                          broadcast,, status defined, active
                            R1#p 10.0.0.2

                            Type escape sequence to abort.
                            Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
                            !!!!!
                            Success rate is 100 percent (5/5), round-trip min/avg/max = 24/40/60 ms
                            R1#

                            • 11. Re: OSPF over Frame Relay
                              cadetalain

                              Hi,

                              in order to ping your own IP address on a multipoint Frame-relay interface you must have a static map for your IP.

                               

                              Regards.

                               

                              Alain

                              • 12. Re: OSPF over Frame Relay
                                Eddie

                                hi cadetalain, thank you.

                                what DLCI i must use in this case?

                                • 13. Re: OSPF over Frame Relay
                                  cadetalain

                                  Hi,

                                   

                                  any one which is belonging to this interface.

                                   

                                  Regards.

                                   

                                  alain