11 Replies Latest reply: Oct 16, 2012 10:57 PM by srikanth RSS

    OSPF Dead timer expired

    Ray

      I was told I might post this here...

       

      In the last few days we've been experiencing OSPF drops between our main site and two branch offices.  I'm seeing no drops on the interfaces, no errors, link remains up/up.  The problem appears only for a few minutes, then goes away.  We have see this happen 4 times in the last few days, no correlation in times.

       

      The logs are showing:

       

      Oct  5 16:34:56: %OSPF-5-ADJCHG: Process 4000, Nbr 172.30.173.253 on Vlan1679 from FULL to DOWN, Neighbor Down: Dead timer expired

      Oct  5 16:35:34: %OSPF-5-ADJCHG: Process 4000, Nbr 172.30.177.253 on Vlan1812 from FULL to DOWN, Neighbor Down: Dead timer expired

      Oct  5 16:47:59: %OSPF-5-ADJCHG: Process 4000, Nbr 172.30.173.253 on Vlan1679 from LOADING to FULL, Loading Done

      Oct  5 16:48:07: %OSPF-5-ADJCHG: Process 4000, Nbr 172.30.177.253 on Vlan1812 from LOADING to FULL, Loading Done

       

      Main office:

       

      interface Vlan1679

      bandwidth 1000000

      ip address 172.30.174.25 255.255.255.252

      no ip redirects

      no ip unreachables

      ip flow ingress

      ip pim sparse-mode

      ip ospf cost 5

      logging event link-status

      ipv6 address FD0B:7CDB:AEFD:7C24::1/64

      ipv6 ospf cost 5

      ipv6 ospf 6000 area 25

       

      interface Vlan1812

      ip address 172.30.176.53 255.255.255.252

      no ip redirects

      no ip unreachables

      ip flow ingress

      ip pim sparse-dense-mode

      ip route-cache same-interface

      ip ospf cost 105

      logging event link-status

      ipv6 address FD0B:7CDB:AEFD:7C27::1/64

      ipv6 ospf cost 110

      ipv6 ospf 6000 area 25

       

      Both VLANs ride a 10Gig link to our ISP, where they split into 1Gig links to our far end routers:

       

      interface TenGigabitEthernet1/4

      switchport

      switchport trunk encapsulation dot1q

      switchport trunk allowed vlan 1679,1812

      switchport mode trunk

      logging event link-status

      mls qos trust dscp

      no cdp enable

       

      At the other end:

       

      interface Vlan1679

      bandwidth 1000000

      ip address 172.30.174.26 255.255.255.252

      no ip redirects

      no ip unreachables

      ip pim sparse-mode

      ip ospf cost 5

      logging event link-status

      ipv6 address FD0B:7CDB:AEFD:7C24::2/64

      ipv6 ospf cost 5

      ipv6 ospf 6000 area 25

       

      interface Vlan1812

      bandwidth 1000000

      ip address 172.30.176.54 255.255.255.252

      no ip redirects

      no ip unreachables

      ip pim sparse-mode

      ip ospf cost 105

      logging event link-status

      ipv6 address FD0B:7CDB:AEFD:7C27::2/64

      ipv6 ospf cost 110

      ipv6 ospf 6000 area 25

       

      I just recently added the bandwidth statements from a suggestion I got from another source.  Would these bandwidth statements have any effect?  I don't see how.  Also, any other ideas on why we seem to not be receiving the OSPF keepalives correctly?

       

      Thanks,

        • 1. Re: OSPF Dead timer expired
          cadetalain

          Hi,

           

          the bandwidth command will have no effect on OSPF adjacency flapping.All it will do is modify the metric of routes as far as OSPF is concerned( here it won't do anything for IPv4 as you entered the cost at the interface) and so may influence downstream path selection.It will also have effect on any QoS you have configured on the interface.

           

          Alain.

          • 2. Re: OSPF Dead timer expired
            Flexin

            Hey try issuing the command

             

            #show ip ospf neighbor detail

             

            this will tell you if there are any ospf retransmissions on the line

             

            Neighbor 133.33.202.1, interface address 133.33.7.10

                In the area 0 via interface Serial0/0

                Neighbor priority is 0, State is FULL, 6 state changes

                DR is 0.0.0.0 BDR is 0.0.0.0

                Options is 0x52

                LLS Options is 0x1 (LR)

                Dead timer due in 00:00:35

                Neighbor is up for 00:04:04

                Index 1/1, retransmission queue length 0, number of retransmission 2

                First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

                Last retransmission scan length is 1, maximum is 1

                Last retransmission scan time is 0 msec, maximum is 0 msec

             

            may give you an indication if the line is over utilised and the ospf packets are getting dropped

             

            HTH

            • 3. Re: OSPF Dead timer expired
              Joshua Johnson - CCNP R&S

              You are only showing one physical interface; why don't you show us the other physical interface: the other side of the trunk?

              • 4. Re: OSPF Dead timer expired
                Joshua Johnson - CCNP R&S

                Also, I'm thinking maybe you have a routing problem... can you show us the routing table please.

                 

                Message was edited by: Joshua, CCNA The routing table on both sides

                • 5. Re: OSPF Dead timer expired
                  Ray

                  The other interfaces :

                   

                  interface GigabitEthernet1/13

                  switchport

                  switchport trunk allowed vlan 1812

                  switchport mode trunk

                  logging event link-status

                  speed 100

                  duplex full

                  mls qos trust dscp

                  no cdp enable

                   

                  interface GigabitEthernet1/37

                  switchport

                  switchport trunk allowed vlan 1679

                  switchport mode trunk

                  logging event link-status

                  mls qos trust dscp

                  no cdp enable

                  • 6. Re: OSPF Dead timer expired
                    Joshua Johnson - CCNP R&S

                    We would really need to see the entire picture here, from end to end Ray.  Do you not have a diagram of your network that you can show us and just edit out the actual IP addresses or something?

                    • 7. Re: OSPF Dead timer expired
                      Flexin

                      Oct  5 16:34:56: %OSPF-5-ADJCHG: Process 4000, Nbr 172.30.173.253 on Vlan1679 from FULL to DOWN, Neighbor Down: Dead timer expired

                       

                      so this proccess is the ipv4 proccess between the two nieghbors right ?

                       

                      there is also an ipv6 proccess of 6000 between the same neighbors right?

                       

                      is the ipv6 proccess flapping between these nieghbors ?

                       

                      what are the hello/dead timers for the ipv6 proccess are they the same as the ipv4 ?

                      if they are not try dialing the hello/dead to the be the same as the ipv6 proccess see if that helps.

                      • 8. Re: OSPF Dead timer expired
                        mrityunajy

                        hello pls somebody help me....i have configured the ospf dead timers and hello timers.i wanna ask since on broadcast hello timer is 10 sec and dead timer is 40 sec.so the first router sends hello packets to second one every 10 sec and when the second router get hello its again update its dead timer to 40 sec.but when i chage the dead timers say dead timers is 36 sec and hello is 10 sec so i want to ask since my hello is 10 sec so why my first router not send hello to another router because it has 36 sec dead timers and hello is sending every 10 sec so when dead timers comes to 26 sec 1 hello will b receive and the dead timers should be updated to 36 sec.but nothing is happening like this.i just waana know why we need dead timers =4x always.

                        • 9. Re: OSPF Dead timer expired
                          Martin

                          First of all, timers must match in ospf; yes, dead is always 4x hello; if u have mismatch, u got no neighbors; you may even see message "timers mismatch";

                          timer starts at dead timer and counts down;

                          before it expires, when and if gets a hello, tim,er starts again from top, from dead timer;

                           

                          Timers do not have to match in EIGRP;

                          • 10. Re: OSPF Dead timer expired
                            srikanth

                            I think dead interval should be the multiples of hello interval.

                            If your hello interval is 10 sec, then the dead interval should be multiples of 10.

                            10*4= 40

                            did you try with the dead interval of 30 (10*3)?

                             

                            As martin said timers should match in OSPF to form adjacency.

                             

                            Message was edited by: srikanth

                            • 11. Re: OSPF Dead timer expired
                              srikanth

                              Here i created adjacency between two routers with hello 10sec and dead 30 sec.

                               

                              R1#show ip ospf int

                              FastEthernet0/0 is up, line protocol is up

                                Internet Address 12.0.0.1/24, Area 0

                                Process ID 1, Router ID 12.0.0.1, Network Type BROADCAST, Cost: 10

                                Transmit Delay is 1 sec, State BDR, Priority 1

                                Designated Router (ID) 12.0.0.2, Interface address 12.0.0.2

                                Backup Designated router (ID) 12.0.0.1, Interface address 12.0.0.1

                                Flush timer for old DR LSA due in 00:02:11

                                Timer intervals configured, Hello 10, Dead 30, Wait 30, Retransmit 5

                                  oob-resync timeout 40

                                  Hello due in 00:00:01

                                Supports Link-local Signaling (LLS)

                                Index 1/1, flood queue length 0

                                Next 0x0(0)/0x0(0)

                                Last flood scan length is 1, maximum is 1

                                Last flood scan time is 0 msec, maximum is 0 msec

                                Neighbor Count is 1, Adjacent neighbor count is 1

                                  Adjacent with neighbor 12.0.0.2  (Designated Router)

                                Suppress hello for 0 neighbor(s)

                              R1#show ip ospf nei

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.2          1   FULL/DR         00:00:24    12.0.0.2        FastEthernet0/0

                              R1#show ip ospf nei

                               

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.2          1   FULL/DR         00:00:23    12.0.0.2        FastEthernet0/0

                              R1#show ip ospf nei

                               

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.2          1   FULL/DR         00:00:22    12.0.0.2        FastEthernet0/0

                              R1#show ip ospf nei

                               

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.2          1   FULL/DR         00:00:21    12.0.0.2        FastEthernet0/0

                              R1#show ip ospf nei

                               

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.2          1   FULL/DR         00:00:20    12.0.0.2        FastEthernet0/0

                              R1#show ip ospf nei

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.2          1   FULL/DR         00:00:29    12.0.0.2        FastEthernet0/0

                               

                               

                               

                              R2#show ip ospf int

                              FastEthernet0/0 is up, line protocol is up

                                Internet Address 12.0.0.2/24, Area 0

                                Process ID 1, Router ID 12.0.0.2, Network Type BROADCAST, Cost: 10

                                Transmit Delay is 1 sec, State DR, Priority 1

                                Designated Router (ID) 12.0.0.2, Interface address 12.0.0.2

                                Backup Designated router (ID) 12.0.0.1, Interface address 12.0.0.1

                                Timer intervals configured, Hello 10, Dead 30, Wait 30, Retransmit 5

                                  oob-resync timeout 40

                                  Hello due in 00:00:08

                                Supports Link-local Signaling (LLS)

                                Index 1/1, flood queue length 0

                                Next 0x0(0)/0x0(0)

                                Last flood scan length is 1, maximum is 1

                                Last flood scan time is 0 msec, maximum is 0 msec

                                Neighbor Count is 1, Adjacent neighbor count is 1

                                  Adjacent with neighbor 12.0.0.1  (Backup Designated Router)

                                Suppress hello for 0 neighbor(s)

                              R2#

                              R2#sh ip ospf nei

                               

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.1          1   FULL/BDR        00:00:25    12.0.0.1        FastEthernet0/0

                              R2#sh ip ospf nei

                               

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.1          1   FULL/BDR        00:00:20    12.0.0.1        FastEthernet0/0

                              R2#sh ip ospf nei

                               

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.1          1   FULL/BDR        00:00:29    12.0.0.1        FastEthernet0/0

                              R2#sh ip ospf nei

                               

                              Neighbor ID     Pri   State           Dead Time   Address         Interface

                              12.0.0.1          1   FULL/BDR        00:00:28    12.0.0.1        FastEthernet0/0