1 2 Previous Next 20 Replies Latest reply: Sep 27, 2011 11:12 AM by Martin RSS

    A basic Question on Frame - Relay

    Vijay Swaminathan

      Dear All,

       

      I would like to ask a very basic question on Frame relay.

       

      I have a Hub and Spoke topolgoy with PVC running between Hub and spokes and not betweek the spokes.

       

      For the communication between the spokes to happen is it mandatory to have a PVC running between those two spokes?

       

      Please clarify..

       

      Thanks

        • 1. Re: A basic Question on Frame - Relay
          Joel Alfredo

          I have only used it routing trough the hub router. I mean, all the spokes routers had routes to all the other spokes routers pointing to the ip address of the subinterface in the hub router, and the hub router, routed the packets between them. Nevertheless, I saw a document where Cisco explains how to configure static mapping between spokes routers on a partially meshed network. I have not tested it yet, but here you have the link:

           

          http://www.ciscopress.com/articles/article.asp?p=170741&seqNum=4

           

          I hope it could help you

           

          Best regards

          • 2. Re: A basic Question on Frame - Relay
            Sri

            You dont need a sepaerate PVC, between 2 spokes

             

            you need to map Hub dlci pointing to spoke IP address, on each spoke

            • 3. Re: A basic Question on Frame - Relay
              Martin

              Hub and Spoke topology is when spokes must use Hub to communicate to each others. There is no link from Spoke to Spoke; just Spoke to Hub. If Hub fails, spoke cannot communicate; backup is needed.

               

              if you make a link Spoke to Spoke in addition to one to Hub, then this is partially mesh topology or Full mesh one.

              • 4. Re: A basic Question on Frame - Relay
                Joel Alfredo

                Hi Martin, I though exactly the same you are telling here, I have even worked with this scenario in real live with a network (Hub and Spoke) in my last job, but after I read the doc from ciscopress that I mentioned (http://www.ciscopress.com/articles/article.asp?p=170741&seqNum=4) I have my doubts about it, because if I have understood this doc, it is possible to map spoke routers directly even if there is not a VC between them. I don´t know how could it work, maybe I have misunderstood that doc. Please, it would be great if you comment that document, when it says:

                 

                “For example, the spoke router R1 uses static mapping to reach router R2 at 172.16.1.2 because there is no direct connectivity between them on the partially meshed network to use dynamic Inverse ARP. Because R1 and R3 are directly connected by a VC, they can rely on dynamic mapping to resolve the next hop protocol address via dynamic Inverse ARP. The same applies between router R2 and hub router R3. On router R1 and R2, static mapping needs to be used to instruct R1 to reach R2 via its local DLCI 103 and for R2 to reach R1 via its local DLCI 203.

                 

                FR Static Map bt spokes.JPG

                Thank you very much for your help to understand this.

                 

                Best regards.

                • 5. Re: A basic Question on Frame - Relay
                  Brian McGahan - 4 x CCIE, CCDE

                  Frame Relay Inverse ARP or Static Mappings perform the same function as ARP does for Ethernet.  In Ethernet you need to find the MAC address for an IP address.  In Frame Relay you need to find the DLCI address for an IP address.

                   

                  What that paragraph is saying is that R1 and R2 only have a connection / PVC / DLCI to the hub (R3).  This means that traffic from R1 to R2 has to go to R3 first.  The problem though is that R1 can't send an Inverse ARP request to R2, because they don't have a connection.  This is fixed by putting a static mapping.  This would be like doing a static ARP entry on an Ethernet interface.  It doesn't change the fact that traffic from R1 to R2 has to go to R3 first, it just changes how the router figures out how to build the layer 2 Frame Relay header.

                  • 6. Re: A basic Question on Frame - Relay
                    Joel Alfredo

                    Thank you Brian for clarifying this topic. Please, could you tell me what´s the advantage between doing the static map in Frame Relay spoke-to-spoke with just letting those spokes routers learn a route to each other through the Hub router. Even with a static default ip route it should work just fine.

                     

                    Thank you very much again,

                     

                    Regards.

                    • 7. Re: A basic Question on Frame - Relay
                      Martin

                      Static Default IP route is Layer 3 and we are talking about layer 2, FR. For Layer 3 to work OK we neeed layer 2 connectivity first;

                      Packet is passed from L3 to L2 FR, and router will say I don't have DLCI for Spoke 2, what I have is ONlY  DLCI to Hub router.

                      Here, Hub-spoke topo, Spokes have no idea what is behind Hub, Spoke knows how to get to Hub but You must tell Spoke to get to other Spoke, aka use this DLCI, which is via Hub, to get to SPoke2.

                      • 8. Re: A basic Question on Frame - Relay
                        Joel Alfredo

                        Hi Martin, we agree that we are talking about two different layers here (IP and FR), and I assuming the objective of this static FR mapping is to let both spokes routers communicate directly through their 172.16.1.0/24 addresses without having a directly connection. If this is ok, I assume that R3, at FR level, is able to “route” the frames received from the spokes to the respective PVC without using its IP layer (but he needs to take the destination IP address from somewhere because he needs to know where to send those frames and all of them arrives with the local dlci). That’s what I can’t imagine how is happening.

                         

                        The alternative I was mentioning is, if we could just add routes (L3 IP) to the hub router, and let him take care of the routing to R2 networks. For example, suppose we have correctly configure the FR PVC between R1-R3 , and R2-R3, and suppose the network behind R1 is 1.1.1.0/24 and the network behind R2 is 2.2.2.0/24. Now, we add static routes (to make it simple) in this way:

                         

                        Route in R1

                         

                        ip route 2.2.2.0 255.255.255.0 172.16.1.3

                         

                        Route in R2

                         

                        ip route 1.1.1.0 255.255.255.0 172.16.1.3

                         

                        Routes in R3

                         

                        ip route 1.1.1.0 255.255.255.0 172.16.1.1

                         

                        ip route 2.2.2.0 255.255.255.0 172.16.1.2

                         

                        Of course, R3 and R2 never communicate directly, and a ping from 172.16.1.1 to 172.16.1.2 won´t work. But the communication of their respective networks will.

                         

                        I’m sorry if something here is trivial, but I´ve never used FR in this way.

                         

                        Thank you very much,

                         

                        Regards.

                        • 9. Re: A basic Question on Frame - Relay
                          Vijay Swaminathan

                          Hi Martin,

                           

                          I have a topology as attached. ( partial Mesh)

                           

                          FR configuration is as folows:

                           

                           

                          [[FRSW FR]]

                              1:102 = 2:201

                                    1:103 = 3:301

                           

                          R1 is the Hub with DLCI's 102 and 103 to reach R2 and R3 respectively.

                           

                          R2 is the spoke with DLCI 201 to reach R1 (Hub)

                          R3 is also a spoke with DLCI 301 to reach R1 (Hub)

                           

                          I have static map statements as show below:

                           

                          Hub's Configuration is:

                          =================

                           

                          R1#sh run int se1/0

                          Building configuration...

                           

                           

                          Current configuration : 213 bytes

                          !

                          interface Serial1/0

                          ip address 10.1.123.1 255.255.255.0

                          encapsulation frame-relay

                          serial restart-delay 0

                          frame-relay map ip 10.1.123.2 102

                          frame-relay map ip 10.1.123.3 103

                          no frame-relay inverse-arp

                          end

                           

                           

                          R1#

                           

                          Spoke configuration:

                          ===============

                           

                          R2#sh run int se1/0

                          Building configuration...

                           

                           

                          Current configuration : 178 bytes

                          !

                          interface Serial1/0

                          ip address 10.1.123.2 255.255.255.0

                          encapsulation frame-relay

                          serial restart-delay 0

                          frame-relay map ip 10.1.123.1 201

                          no frame-relay inverse-arp

                          end

                           

                           

                          R2#

                           

                          R3#sh run int se1/0

                          Building configuration...

                           

                           

                          Current configuration : 178 bytes

                          !

                          interface Serial1/0

                          ip address 10.1.123.3 255.255.255.0

                          encapsulation frame-relay

                          serial restart-delay 0

                          frame-relay map ip 10.1.123.1 301

                          no frame-relay inverse-arp

                          end

                           

                           

                          R3#

                           

                          Now the ping from R2 to R3 does not work....

                           

                          R2#ping 10.1.123.3

                           

                           

                          Type escape sequence to abort.

                          Sending 5, 100-byte ICMP Echos to 10.1.123.3, timeout is 2 seconds:

                          .....

                          Success rate is 0 percent (0/5)

                          R2#trace

                          R2#traceroute 10.1.123.3

                           

                           

                          Type escape sequence to abort.

                          Tracing the route to 10.1.123.3

                           

                           

                            1  *  *  *

                            2

                          R2#  

                           

                          Am i missing something here ??

                          • 10. Re: A basic Question on Frame - Relay
                            Vijay Swaminathan

                            Ok. I got it working.. I missed to configure the map statement to use the same DLCI to reach the other spoke..

                             

                            with the following configuration on R2, it works.

                             

                            interface Serial1/0

                            ip address 10.1.123.2 255.255.255.0

                            encapsulation frame-relay

                            serial restart-delay 0

                            frame-relay map ip 10.1.123.1 201

                            frame-relay map ip 10.1.123.3 201

                            no frame-relay inverse-arp

                            end

                            • 11. Re: A basic Question on Frame - Relay
                              Joel Alfredo

                              Hi Vijay,

                               

                              I think you have to include what ciscopress talk about in the doc I mentioned. Try the following:

                               

                              R2

                              frame-relay map ip 10.1.123.3 201 broadcast

                               

                              R3

                              frame-relay map ip 10.1.123.2 301 broadcast

                               

                              The broadcast here is optional.

                               

                              If it works please let me know.

                               

                              Regards.

                              • 12. Re: A basic Question on Frame - Relay
                                Joel Alfredo

                                We were writing at the same time. Thanks for the info. Now it would be interesting to know what is R1 doing to resend those frames between the spokes (just for curiosity)

                                • 13. Re: A basic Question on Frame - Relay
                                  Vijay Swaminathan

                                  Hi Joel,

                                   

                                  Just curious to know.. when do we use the broadcast keyword?? any specific usecase when we use this?

                                  • 14. Re: A basic Question on Frame - Relay
                                    Joel Alfredo

                                    Hi,

                                     

                                    As far as I can tell you, you should use the broadcast parameter in physical interfaces and point-to-multipoint subinterfaces when you use static mapping (by default it disables the broadcast), in order to allow broadcast and multicast packet go over those PVC. It is useful for routing protocols implementations like OSPF that requires extra configuration parameters if this is not allowed. As a reference you could read this:

                                     

                                    Wendell Odom ICND2 Capter 14, p.518

                                     

                                    http://www.ciscopress.com/articles/article.asp?p=170741&seqNum=4

                                     

                                    http://www.cisco.com/en/US/tech/tk713/tk237/technologies_tech_note09186a008014f8a7.shtml#broadcastkey

                                     

                                    I hope it could help you.

                                    1 2 Previous Next