12 Replies Latest reply: Sep 18, 2011 12:22 PM by tnewshott RSS

    auto summarization

    Stephen

      Hi guys,


      I've read a lot of info about auto summarization, however, I never ever ever ever get questions right about it.  It's like I'm totally misunderstanding it or something.  I need you guys to help.  I had a question (forwarded from a mate who also doesn't understand the answer) regarding a similar layout below:

       

       

       

      EIGRP is configured with the default configuration on all routers.  Autosummarization is enabled on router R2 and R3, but is disabled on router R1.  Which two EIGRP routes will be seen in the routing table of router R3? (choose 2)

      autosummarization.jpg

       

      R1#show running-config

      !

      router eigrp 4

      network 10.0.0.0

      network 172.16.0.0

      no auto-summary

      !

       

       

      A  10.0.0.0/8

      B  10.0.0.0/16

      C  10.10.10.0/24

      D  172.16.0.0/16

      E  172.16.0.0/24

      F  172.16.10.0/24

       

      The correct answers were C and D.

       

      In my head, auto-summarization summarises networks at classful boundaries.  So when the routes hit R2, R2 will summarise the

       

      10.10.10.0/24 network into  ----->10.0.0.0/8 and

      172.16.10.0/24  network into -----> 172.16.0.0/16

       

      So how do you arrive at the answer of C and D?

       

      Cheers,

      Stephen

       

      PS: this is something I've been trying to work out for a while, so any explination is really appreciated!  Thanks in advance

        • 1. Re: auto summarization
          Paul Stewart  -  CCIE Security

          You are correct in how auto summarization would work.  C AND D are correct because auto-summary was disabled with the "no auto-summary" command. 

          • 2. Re: auto summarization
            Jared

            In todays networks, auto-summarization can be dangerous.  I had a jr engineer forget to turn it off and we caused some temporary routing issues there for a while.

            • 3. Re: auto summarization
              Stephen

              Hey Paul.  I don't understand what you mean.  Auto summarisation is enabled on R2 and R3?

              • 4. Re: auto summarization
                Paul Stewart  -  CCIE Security

                My bad.   I didn't read the question thoroughly.  I think you are right and the question is wrong.

                • 5. Re: auto summarization
                  Stephen

                  Hey again

                   

                  I just set this up in a lab and found out the answer is indeed correct.  I just don't understand why or how it ends up like that.  See the outputs below

                   

                   

                  R3#sh ip route

                   

                  D    172.16.0.0/16 [90/2681856] via 192.168.20.1, 00:01:38, Serial1/1

                  C    192.168.20.0/24 is directly connected, Serial1/1

                       10.0.0.0/24 is subnetted, 1 subnets

                  D       10.10.10.0 [90/2809856] via 192.168.20.1, 00:01:38, Serial1/1

                   

                   

                  R3#sh ip eigrp topology

                  IP-EIGRP Topology Table for AS(1)/ID(192.168.20.2)

                  Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

                         r - reply Status, s - sia Status

                   

                   

                  P 10.10.10.0/24, 1 successors, FD is 2809856

                          via 192.168.20.1 (2809856/2297856), Serial1/1

                  P 192.168.20.0/24, 1 successors, FD is 2169856

                          via Connected, Serial1/1

                  P 172.16.0.0/16, 1 successors, FD is 2681856

                          via 192.168.20.1 (2681856/2169856), Serial1/1

                  • 6. Re: auto summarization
                    Paul Stewart  -  CCIE Security

                    I labbed it up and got those exact results. 10.10.10.0 is not summarizes because R2 doesn't handle any 10.0.0.0/8 networks.

                    • 7. Re: auto summarization
                      Stephen

                      So it goes into the routing table on R2 as a 10.10.10.0/24 (as R1 advertises subnet mask information).  Then when EIGRP forwards the routes to R3 (by the rules of summarisation) it will then NOT send any subnet mask information.  So R3 should get the packet as 10.10.10.0, and apply a classful mask of /8.  This would turn the route into 10.0.0.0/8.  So again, I don't see how its coming up as 10.10.10.0/24

                      • 8. Re: auto summarization
                        Brian

                        R2 will not "auto-summarize" the routes received from R1, unless it also has directly connected routes for the same major network.  As Paul pointed out, since R2 does not have any directly connected subnets of the 10.0.0.0/8 network, then he does not "auto-summarize" this network to R3.

                         

                        I did get some very different results between GNS3 and Cisco PT in the above topology.  GNS3 produced the same results as Stephen showed, but Cisco PT included a summary route for the 10.0.0.0/8 network on R2 and advertised both the 10.0.0.0/8 and 10.10.10.0/24 networks to R3.

                         

                        Brian

                         

                        • 9. Re: auto summarization
                          Brian

                          Here are some sample outputs for EIGRP.  R1 has "disabled" auto-summary using the "no auto-summary" command and R2 and R3 have auto-summary "enabled".

                           

                          Notice the outputs below.  The first output shows R3's routing table output and how R2 does NOT auto-summarize the 10.10.10.0/24 network to 10.0.0.0/8.  This is because R2 does NOT have any directly connected subnets of this major network.

                           

                          The second output shows R3's routing table output, but this time R2 summarized the route to 10.0.0.0/8.  This is because I configured a loopback on R2 with the following IP address 10.12.12.2/24 and included this interface in the EIGRP routing process on R2.

                           

                          R3#sh ip rou

                          Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                 E1 - OSPF external type 1, E2 - OSPF external type 2

                                 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                 ia - IS-IS inter area, * - candidate default, U - per-user static route

                                 o - ODR, P - periodic downloaded static route

                           

                          Gateway of last resort is not set

                           

                          D    172.16.0.0/16 [90/2681856] via 192.168.23.2, 00:04:40, Serial0/0

                              10.0.0.0/24 is subnetted, 1 subnets

                          D       10.10.10.0 [90/2809856] via 192.168.23.2, 00:04:40, Serial0/0

                          C    192.168.23.0/24 is directly connected, Serial0/0

                               30.0.0.0/24 is subnetted, 1 subnets

                          C       30.30.30.0 is directly connected, Loopback30

                          R3#

                           

                          ====================================================================

                           

                          R3#sh ip rou

                          Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                 E1 - OSPF external type 1, E2 - OSPF external type 2

                                 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                 ia - IS-IS inter area, * - candidate default, U - per-user static route

                                 o - ODR, P - periodic downloaded static route

                           

                          Gateway of last resort is not set

                           

                          D    172.16.0.0/16 [90/2681856] via 192.168.23.2, 00:00:14, Serial0/0

                          D    10.0.0.0/8 [90/2297856] via 192.168.23.2, 00:00:14, Serial0/0

                          C    192.168.23.0/24 is directly connected, Serial0/0

                               30.0.0.0/24 is subnetted, 1 subnets

                          C       30.30.30.0 is directly connected, Loopback30

                          R3#

                           

                          Brian

                           

                          • 10. Re: auto summarization
                            Stephen

                            oh ok.  So it is only directly connected routes that a router will summarise.

                             

                            Thank you

                            • 11. Re: auto summarization
                              Brian

                              Only in the case of EIGRP.  If you used RIPv2, then RIPv2 would perform the "auto-summarization" regardless if R2 had directly connected routes or not.

                               

                              RIPv2 and EIGRP do behave differently regarding "auto-summarization" across major network boundaries.  Below are the sample outputs for EIGRP vs RIPv2.  I used the same topology you had in the original post, R1 <---> R2 <---> R3.

                               

                              =====================================================================

                              =====================================================================

                              ======= EIGRP CONFIGURATION - AUTO SUMMARY ON R2 AND R3 ONLY ========

                               

                              R1#sh run

                              Building configuration...

                               

                              Current configuration : 823 bytes

                              !

                              version 12.4

                              service timestamps debug datetime msec

                              service timestamps log datetime msec

                              no service password-encryption

                              !

                              hostname R1

                              !

                              boot-start-marker

                              boot-end-marker

                              !

                              no aaa new-model

                              !

                              resource policy

                              !

                              memory-size iomem 5

                              ip cef

                              !

                              interface Loopback10

                              ip address 10.10.10.1 255.255.255.0

                              !

                              interface FastEthernet0/0

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              interface Serial0/0

                              ip address 172.16.12.1 255.255.255.0

                              clock rate 2000000

                              !

                              interface FastEthernet0/1

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              router eigrp 1

                              network 10.0.0.0

                              network 172.16.0.0

                              no auto-summary

                              !

                              ip http server

                              no ip http secure-server

                              !

                              control-plane

                              !

                              line con 0

                              logging synchronous

                              line aux 0

                              line vty 0 4

                              login

                              !

                              end

                               

                              R1#sh ip rou

                              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                     E1 - OSPF external type 1, E2 - OSPF external type 2

                                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                                     o - ODR, P - periodic downloaded static route

                               

                              Gateway of last resort is not set

                               

                                   172.16.0.0/24 is subnetted, 1 subnets

                              C       172.16.12.0 is directly connected, Serial0/0

                                   10.0.0.0/24 is subnetted, 1 subnets

                              C       10.10.10.0 is directly connected, Loopback10

                              D    192.168.23.0/24 [90/2681856] via 172.16.12.2, 00:04:16, Serial0/0

                              R1#

                               

                              =====================================================================

                               

                              R2#sh run

                              Building configuration...

                               

                              Current configuration : 905 bytes

                              !

                              version 12.4

                              service timestamps debug datetime msec

                              service timestamps log datetime msec

                              no service password-encryption

                              !

                              hostname R2

                              !

                              boot-start-marker

                              boot-end-marker

                              !

                              no aaa new-model

                              !

                              resource policy

                              !

                              memory-size iomem 5

                              ip cef

                              !

                              interface Loopback20

                              ip address 20.20.20.2 255.255.255.0

                              !

                              interface FastEthernet0/0

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              interface Serial0/0

                              ip address 172.16.12.2 255.255.255.0

                              clock rate 2000000

                              !

                              interface FastEthernet0/1

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              interface Serial0/1

                              ip address 192.168.23.2 255.255.255.0

                              clock rate 2000000

                              !       

                              router eigrp 1

                              network 172.16.0.0

                              network 192.168.23.0

                              auto-summary

                              !

                              ip http server

                              no ip http secure-server

                              !

                              control-plane

                              !

                              line con 0

                              logging synchronous

                              line aux 0

                              line vty 0 4

                              login

                              !

                              end

                               

                              R2#sh ip rou

                              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                     E1 - OSPF external type 1, E2 - OSPF external type 2

                                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                                     o - ODR, P - periodic downloaded static route

                               

                              Gateway of last resort is not set

                               

                                   20.0.0.0/24 is subnetted, 1 subnets

                              C       20.20.20.0 is directly connected, Loopback20

                                   172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

                              C       172.16.12.0/24 is directly connected, Serial0/0

                              D       172.16.0.0/16 is a summary, 00:04:29, Null0

                                   10.0.0.0/24 is subnetted, 1 subnets

                              D       10.10.10.0 [90/2297856] via 172.16.12.1, 00:04:29, Serial0/0

                              C    192.168.23.0/24 is directly connected, Serial0/1

                              R2#

                               

                              =====================================================================

                               

                              R3#sh run

                              Building configuration...

                               

                              Current configuration : 805 bytes

                              !

                              version 12.4

                              service timestamps debug datetime msec

                              service timestamps log datetime msec

                              no service password-encryption

                              !

                              hostname R3

                              !

                              boot-start-marker

                              boot-end-marker

                              !

                              no aaa new-model

                              !

                              resource policy

                              !

                              memory-size iomem 5

                              ip cef

                              !

                              interface Loopback30

                              ip address 30.30.30.3 255.255.255.0

                              !

                              interface FastEthernet0/0

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              interface Serial0/0

                              ip address 192.168.23.3 255.255.255.0

                              clock rate 2000000

                              !

                              interface FastEthernet0/1

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              router eigrp 1

                              network 192.168.23.0

                              auto-summary

                              !       

                              ip http server

                              no ip http secure-server

                              !

                              control-plane

                              !

                              line con 0

                              logging synchronous

                              line aux 0

                              line vty 0 4

                              login

                              !

                              end

                               

                              R3#sh ip rou

                              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                     E1 - OSPF external type 1, E2 - OSPF external type 2

                                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                                     o - ODR, P - periodic downloaded static route

                               

                              Gateway of last resort is not set

                               

                              D    172.16.0.0/16 [90/2681856] via 192.168.23.2, 00:04:40, Serial0/0

                                   10.0.0.0/24 is subnetted, 1 subnets

                              D       10.10.10.0 [90/2809856] via 192.168.23.2, 00:04:40, Serial0/0

                              C    192.168.23.0/24 is directly connected, Serial0/0

                                   30.0.0.0/24 is subnetted, 1 subnets

                              C       30.30.30.0 is directly connected, Loopback30

                              R3#

                               

                              =====================================================================

                              =====================================================================

                              ======= RIPv2 CONFIGURATION - AUTO SUMMARY ON R2 AND R3 ONLY ========

                               

                              R1#sh run

                              Building configuration...

                               

                              Current configuration : 830 bytes

                              !

                              version 12.4

                              service timestamps debug datetime msec

                              service timestamps log datetime msec

                              no service password-encryption

                              !

                              hostname R1

                              !

                              boot-start-marker

                              boot-end-marker

                              !

                              no aaa new-model

                              !

                              resource policy

                              !

                              memory-size iomem 5

                              ip cef

                              !

                              interface Loopback10

                              ip address 10.10.10.1 255.255.255.0

                              !

                              interface FastEthernet0/0

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              interface Serial0/0

                              ip address 172.16.12.1 255.255.255.0

                              clock rate 2000000

                              !

                              interface FastEthernet0/1

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              router rip

                              version 2

                              network 10.0.0.0

                              network 172.16.0.0

                              no auto-summary

                              !

                              ip http server

                              no ip http secure-server

                              !

                              control-plane

                              !

                              line con 0

                              logging synchronous

                              line aux 0

                              line vty 0 4

                              login

                              !

                              end

                               

                              R1#sh ip rou

                              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                     E1 - OSPF external type 1, E2 - OSPF external type 2

                                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                                     o - ODR, P - periodic downloaded static route

                               

                              Gateway of last resort is not set

                               

                                   172.16.0.0/24 is subnetted, 1 subnets

                              C       172.16.12.0 is directly connected, Serial0/0

                                   10.0.0.0/24 is subnetted, 1 subnets

                              C       10.10.10.0 is directly connected, Loopback10

                              R    192.168.23.0/24 [120/1] via 172.16.12.2, 00:00:16, Serial0/0

                              R1#

                               

                              =====================================================================

                               

                              R2#sh run

                              Building configuration...

                               

                              Current configuration : 898 bytes

                              !

                              version 12.4

                              service timestamps debug datetime msec

                              service timestamps log datetime msec

                              no service password-encryption

                              !

                              hostname R2

                              !

                              boot-start-marker

                              boot-end-marker

                              !

                              no aaa new-model

                              !

                              resource policy

                              !

                              memory-size iomem 5

                              ip cef

                              !

                              interface Loopback20

                              ip address 20.20.20.2 255.255.255.0

                              !

                              interface FastEthernet0/0

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              interface Serial0/0

                              ip address 172.16.12.2 255.255.255.0

                              clock rate 2000000

                              !

                              interface FastEthernet0/1

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              interface Serial0/1

                              ip address 192.168.23.2 255.255.255.0

                              clock rate 2000000

                              !       

                              router rip

                              version 2

                              network 172.16.0.0

                              network 192.168.23.0

                              !

                              ip http server

                              no ip http secure-server

                              !

                              control-plane

                              !

                              line con 0

                              logging synchronous

                              line aux 0

                              line vty 0 4

                              login

                              !

                              end

                               

                              R2#sh ip rou

                              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                     E1 - OSPF external type 1, E2 - OSPF external type 2

                                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                                     o - ODR, P - periodic downloaded static route

                               

                              Gateway of last resort is not set

                               

                                   20.0.0.0/24 is subnetted, 1 subnets

                              C       20.20.20.0 is directly connected, Loopback20

                                   172.16.0.0/24 is subnetted, 1 subnets

                              C       172.16.12.0 is directly connected, Serial0/0

                                   10.0.0.0/24 is subnetted, 1 subnets

                              R       10.10.10.0 [120/1] via 172.16.12.1, 00:00:03, Serial0/0

                              C    192.168.23.0/24 is directly connected, Serial0/1

                              R2#sh ip rip da

                              R2#sh ip rip database

                              10.0.0.0/8    auto-summary

                              10.10.10.0/24

                                  [1] via 172.16.12.1, 00:00:18, Serial0/0

                              172.16.0.0/16    auto-summary

                              172.16.12.0/24    directly connected, Serial0/0

                              192.168.23.0/24    auto-summary

                              192.168.23.0/24    directly connected, Serial0/1

                              R2#

                               

                              =====================================================================

                               

                              R3#sh run

                              Building configuration...

                               

                              Current configuration : 798 bytes

                              !

                              version 12.4

                              service timestamps debug datetime msec

                              service timestamps log datetime msec

                              no service password-encryption

                              !

                              hostname R3

                              !

                              boot-start-marker

                              boot-end-marker

                              !

                              no aaa new-model

                              !

                              resource policy

                              !

                              memory-size iomem 5

                              ip cef

                              !

                              interface Loopback30

                              ip address 30.30.30.3 255.255.255.0

                              !

                              interface FastEthernet0/0

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              interface Serial0/0

                              ip address 192.168.23.3 255.255.255.0

                              clock rate 2000000

                              !

                              interface FastEthernet0/1

                              no ip address

                              shutdown

                              duplex auto

                              speed auto

                              !

                              router rip

                              version 2

                              network 192.168.23.0

                              !       

                              ip http server

                              no ip http secure-server

                              !

                              control-plane

                              !

                              line con 0

                              logging synchronous

                              line aux 0

                              line vty 0 4

                              login

                              !

                              end

                               

                              R3#sh ip rou

                              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                     E1 - OSPF external type 1, E2 - OSPF external type 2

                                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                                     o - ODR, P - periodic downloaded static route

                               

                              Gateway of last resort is not set

                               

                              R    172.16.0.0/16 [120/1] via 192.168.23.2, 00:00:11, Serial0/0

                              R    10.0.0.0/8 [120/2] via 192.168.23.2, 00:00:11, Serial0/0

                              C    192.168.23.0/24 is directly connected, Serial0/0

                                   30.0.0.0/24 is subnetted, 1 subnets

                              C       30.30.30.0 is directly connected, Loopback30

                              R3#sh ip rip da

                              R3#sh ip rip database

                              10.0.0.0/8    auto-summary

                              10.0.0.0/8

                                  [2] via 192.168.23.2, 00:00:16, Serial0/0

                              172.16.0.0/16    auto-summary

                              172.16.0.0/16

                                  [1] via 192.168.23.2, 00:00:16, Serial0/0

                              192.168.23.0/24    auto-summary

                              192.168.23.0/24    directly connected, Serial0/0

                              R3#

                               

                              =====================================================================

                               

                              R2#sh run

                              Building configuration...

                               

                              interface Loopback10

                              ip address 10.12.12.2 255.255.255.0

                              !

                              router eigrp 1

                              network 10.0.0.0

                              network 172.16.0.0

                              network 192.168.23.0

                              auto-summary

                              !

                               

                               

                              R3#sh ip rou

                              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                                     E1 - OSPF external type 1, E2 - OSPF external type 2

                                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                                     o - ODR, P - periodic downloaded static route

                               

                              Gateway of last resort is not set

                               

                              D    172.16.0.0/16 [90/2681856] via 192.168.23.2, 00:00:14, Serial0/0

                              D    10.0.0.0/8 [90/2297856] via 192.168.23.2, 00:00:14, Serial0/0

                              C    192.168.23.0/24 is directly connected, Serial0/0

                                   30.0.0.0/24 is subnetted, 1 subnets

                              C       30.30.30.0 is directly connected, Loopback30

                              R3#

                               

                              =====================================================================

                               

                               

                              Brian

                               

                              • 12. Re: auto summarization
                                tnewshott

                                As Brian noted - R2 is receiving the 10.10.10.0/24 route, as opposed to originating it.  The reason this is important is because unless you change something with a summary command, EIGRP is still distance vector at it's heart and will route by rumor - basically passing along what it received.

                                 

                                Auto-summarization happens when the routes are locally originated and installed in the RIB/FIB - received routes are not affected.

                                 


                                FWIW - took me a while to wrap my mind around this concept as well.  What helped me was starting to think about things at the router level - what exact operations are occurring, in what order, and how does the configuration impact it?  At the CCIE level that is imperative to success, no reason not to start thinking that way at the CCNP level as well.  Set yourself up for success.