9 Replies Latest reply: Aug 15, 2011 8:09 PM by Martin RSS

    Subinterface configuration

    patterson_p

      Hi all,

       

       

      I need a little help with my configuration of subinterfaces on the 2620XM Cisco Router through Packet Tracer 5.3.

       

      MY CONFIGURATION:

       

      I have configured 3 VLANs in a network:

        /26 (192)

      VLAN 1: 192.168.1.0          (default router 192.168.1.1) + 2 PCs

      VLAN 2: 192.168.1.64        (default router 192.168.1.65) + 3 PCs

      VLAN 3: 192.168.1.128      (default router 192.168.1.129) + 3 PCs

       

      Router configuration:

      Fa 0/0 ip address 192.168.1.1 255.255.255.192  (VLAN 1)

      Fa 0/0.1 ip address 192.168.1.65 255.255.255.192  (VLAN 2)

      Fa 0/0.2 ip address 192.168.1.129 255.255.255.192  (VLAN 3)

       

      Router and switches have been configured to encapsulate dot1q.

       

       

      MY PROBLEM:

      I have no issues pinging the PCs on the native VLAN to their default gateway because it's on the physical interface.

      I have no issues pinging from the physical interface to any of the subinterfaces within the router. 

      I do have issues pinging the PCs  in VLANs 2 and 3 to their default gateways which are located on the subinterfaces.

       

       

      Is there something that I'm missing here?

       

       

      Thanks for your help!

        • 1. Re: Subinterface configuration
          James

          it looks like the routers are set up correctly, the area i would look at would be the desktops to make sure that they have the correct gateway information on them and that they match the vlan that you gave to them.

           

          also you may want to check if Ip routing is enabled on the routers also. those would be the first two areas i would check.

          • 2. Re: Subinterface configuration
            Martin

            Check default gateways on those PCs; then check switch ports if those are in correct access vlans; port connected to PC2 in VLan 2 is in access vlan 2, etc

            • 3. Re: Subinterface configuration
              Brian

              Can you post the switch configuration?  I agree with Martin here, check the switch and make sure you have the port in the correct access vlans.  Also, check and make sure the trunk port (the one connected between switch and router) is correctly configured.

               

              Brian

               

              • 4. Re: Subinterface configuration
                patterson_p

                I initially thought it was the default gateway on the PCs myself. Even if that wasn't set, the PCs would still be able to ping to that ip address. In this case, it won't even ping to the default gateway.

                 

                (to Brian)

                 

                Switch Config:

                 

                #show vlan brief

                VLAN Name                             Status    Ports
                ---- -------------------------------- --------- -------------------------------
                1    default                          active    Fa0/3, Fa0/5, Fa0/7, Fa0/8
                                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                2    John                             active    Fa0/4
                3    Paul                             active    Fa0/6
                4    Mike                             active   
                5    Joe                              active  

                 

                (Fa0/3 reports to the router)

                 

                Router Config:

                 

                Router#show interfaces

                FastEthernet0/0 is up, line protocol is up (connected)

                  Hardware is Lance, address is 000a.4153.627b (bia 000a.4153.627b)

                  Internet address is 192.168.1.1/26

                  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

                     reliability 255/255, txload 1/255, rxload 1/255

                  Encapsulation ARPA, loopback not set

                  ARP type: ARPA, ARP Timeout 04:00:00,

                  Last input 00:00:08, output 00:00:05, output hang never

                  Last clearing of "show interface" counters never

                  Input queue: 0/75/0 (size/max/drops); Total output drops: 0

                  Queueing strategy: fifo

                  Output queue :0/40 (size/max)

                  5 minute input rate 0 bits/sec, 0 packets/sec

                  5 minute output rate 0 bits/sec, 0 packets/sec

                     10 packets input, 1280 bytes, 0 no buffer

                     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

                     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

                     0 input packets with dribble condition detected

                     10 packets output, 1280 bytes, 0 underruns

                     0 output errors, 0 collisions, 2 interface resets

                     0 babbles, 0 late collision, 0 deferred

                     0 lost carrier, 0 no carrier

                     0 output buffer failures, 0 output buffers swapped out

                FastEthernet0/0.2 is up, line protocol is up (connected)

                  Hardware is PQUICC_FEC, address is 000a.4153.627b (bia 000a.4153.627b)

                  Internet address is 192.168.1.65/26

                  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

                     reliability 255/255, txload 1/255, rxload 1/255

                  Encapsulation 802.1Q Virtual LAN, Vlan ID 2

                  ARP type: ARPA, ARP Timeout 04:00:00,

                  Last clearing of "show interface" counters never

                FastEthernet0/0.3 is up, line protocol is up (connected)

                  Hardware is PQUICC_FEC, address is 000a.4153.627b (bia 000a.4153.627b)

                  Internet address is 192.168.1.129/26

                  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

                     reliability 255/255, txload 1/255, rxload 1/255

                  Encapsulation 802.1Q Virtual LAN, Vlan ID 3

                  ARP type: ARPA, ARP Timeout 04:00:00,

                  Last clearing of "show interface" counters never

                Router#

                • 5. Re: Subinterface configuration
                  Brian

                  From this output F0/3 is in access VLAN 1.  See below:

                   

                  1    default                          active    Fa0/3, Fa0/5, Fa0/7, Fa0/8

                   

                  Also, since F0/1 and F0/2 are not showing up as belonging to VLAN 1 or any VLAN, it typically means they are configured as trunks.

                   

                  Can you post the router and switch configurations (output of "sh run").

                   

                  Brian

                   

                  • 6. Re: Subinterface configuration
                    Martin

                    good catch; also to see trunks do show int trunk

                    • 7. Re: Subinterface configuration
                      patterson_p

                      Would the Fa0/3 port be access even if it connected to the router?

                       

                      Correct, the Fa0/1 and Fa0/2 ports are configured as trunks for two other switches. Here are the configurations for the Router and Switch:

                       

                      SWITCH:

                      Switch#show running-config
                      Building configuration...

                      Current configuration : 1045 bytes
                      !
                      version 12.1
                      no service timestamps log datetime msec
                      no service timestamps debug datetime msec
                      no service password-encryption
                      !
                      hostname Switch
                      !
                      !
                      !
                      interface FastEthernet0/1
                      switchport mode trunk
                      !
                      interface FastEthernet0/2
                      switchport mode trunk
                      !
                      interface FastEthernet0/3
                      !
                      interface FastEthernet0/4
                      switchport access vlan 2
                      !
                      interface FastEthernet0/5
                      !
                      interface FastEthernet0/6
                      switchport access vlan 3
                      !
                      interface FastEthernet0/7
                      !
                      (omitted)
                      !
                      interface Vlan1
                      no ip address
                      shutdown
                      !
                      !
                      line con 0
                      !
                      line vty 0 4
                      login
                      line vty 5 15
                      login
                      !
                      !
                      end

                       

                       

                       

                       

                      Switch#show in trunk
                      Port        Mode         Encapsulation  Status        Native vlan
                      Fa0/1       on           802.1q         trunking      1
                      Fa0/2       on           802.1q         trunking      1

                      Port        Vlans allowed on trunk
                      Fa0/1       1-1005
                      Fa0/2       1-1005

                      Port        Vlans allowed and active in management domain
                      Fa0/1       1,2,3,4,5
                      Fa0/2       1,2,3,4,5

                      Port        Vlans in spanning tree forwarding state and not pruned
                      Fa0/1       1,2,3,4,5
                      Fa0/2       1,2,3,4,5

                       

                       

                      ROUTER:

                      Router#show running-conf
                      Building configuration...

                      Current configuration : 546 bytes
                      !
                      version 12.2
                      no service timestamps log datetime msec
                      no service timestamps debug datetime msec
                      no service password-encryption
                      !
                      hostname Router
                      !
                      !
                      interface FastEthernet0/0
                      ip address 192.168.1.1 255.255.255.192
                      duplex auto
                      speed auto
                      !
                      interface FastEthernet0/0.2
                      encapsulation dot1Q 2
                      ip address 192.168.1.65 255.255.255.192
                      !
                      interface FastEthernet0/0.3
                      encapsulation dot1Q 3
                      ip address 192.168.1.129 255.255.255.192
                      !
                      ip classless
                      !
                      !
                      !
                      no cdp run
                      !
                      line con 0
                      line vty 0 4
                      login
                      !
                      !
                      !
                      end

                       

                      Router#show interface fa 0/0.2

                      FastEthernet0/0.2 is up, line protocol is up (connected)

                        Hardware is PQUICC_FEC, address is 000a.4153.627b (bia 000a.4153.627b)

                        Internet address is 192.168.1.65/26

                        MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

                           reliability 255/255, txload 1/255, rxload 1/255

                        Encapsulation 802.1Q Virtual LAN, Vlan ID 2

                        ARP type: ARPA, ARP Timeout 04:00:00,

                        Last clearing of "show interface" counters never

                      I hope this provides an answer

                       

                      Router#show interface fa 0/0.3

                      FastEthernet0/0.3 is up, line protocol is up (connected)

                        Hardware is PQUICC_FEC, address is 000a.4153.627b (bia 000a.4153.627b)

                        Internet address is 192.168.1.129/26

                        MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

                           reliability 255/255, txload 1/255, rxload 1/255

                        Encapsulation 802.1Q Virtual LAN, Vlan ID 3

                        ARP type: ARPA, ARP Timeout 04:00:00,

                        Last clearing of "show interface" counters never

                       

                       

                      I hope this provides a solution somewhere, thanks for the help!

                      Paul

                      • 8. Re: Subinterface configuration
                        Rickey

                        YOu'll need to make sure encapsulation is turned on the switchport trunk ports.  Also you'll need to remove the ip address from fa0/0 on the router and add another sub interface for the necessary vlan.  Since you are doing router on a stick I believe you need no ip address under the fa0/0.  That's at least how I have configured it on my setups.

                        • 9. Re: Subinterface configuration
                          Martin

                          You can upload the PT file here; use Advanced Editor and upload your ptk file

                           

                          Well, I used your config to create my example; all Pings work fine; see

                           

                          https://learningnetwork.cisco.com/docs/DOC-12866