8 Replies Latest reply: Jul 26, 2011 10:41 PM by Martin RSS

    Help with a lab setup

    Wayne

      First my apologies for the huge post, I've just started to setup a home lab I have available two each 2610 and 2620 routers and one 2521. The issue I'm experencing is what I go to set the clock rate  on the 2610 and do a "show run" with the cable (DCE End) disconnected  from the  2620 the Clock Rate is present. I connect the DCE cable and perform another "Show Run" and no clcck rate is present in the output. On serial interface Line Up Protocal Down.

       

      Lab 1: Basic IP lab—IP addressing  

           IP addressing
      This is the output with the DCE end of  cable discconected from the 2610. The DTE end is connected to the 2521

       

      RouterA#sh run
      Building configuration...

      Current configuration : 894 bytes
      !
      version 12.1
      no service single-slot-reload-enable
      service timestamps debug uptime
      service timestamps log uptime
      no service password-encryption
      !
      hostname RouterA
      !
      logging rate-limit console 10 except errors
      enable secret 5 $1$jGOY$Nagu9h1qL7bpttb6opVRS0
      !
      username banbury password 0 ccna
      ip subnet-zero
      !
      !
      no ip finger
      !
      ip audit notify log
      ip audit po max-events 100
      !
      !        
      call rsvp-sync
      !
      !
      !
      !
      !
      !
      !
      !
      interface Loopback0
      ip address 172.16.1.10 255.255.0.0
      !
      interface Loopback1
      ip address 172.20.1.1 255.255.0.0
      !
      interface Ethernet0/0
      no ip address
      shutdown
      half-duplex
      !
      interface Serial0/0
      ip address 192.168.1.1 255.255.255.252
      clockrate 64000
      !
      interface Serial0/1
      no ip address
      shutdown
      !
      ip classless
      no ip http server
      !
      !
      dial-peer cor custom
      !
      !
      !
      !
      !
      line con 0
      password letmein
      transport input none
      line aux 0
      line vty 0 4
      login local
      !
      no scheduler allocate
      end

       

       

      This is the output with the DCE end of cable connected to the 2610  The DTE still connected to the 2521

       

      RouterA#
      09:01:45: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
      09:01:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
      RouterA#sh run
      Building configuration...

      Current configuration : 877 bytes
      !
      version 12.1
      no service single-slot-reload-enable
      service timestamps debug uptime
      service timestamps log uptime
      no service password-encryption
      !
      hostname RouterA
      !
      logging rate-limit console 10 except errors
      enable secret 5 $1$jGOY$Nagu9h1qL7bpttb6opVRS0
      !
      username banbury password 0 ccna
      ip subnet-zero
      !
      !
      no ip finger
      !
      ip audit notify log
      ip audit po max-events 100
      !
      !        
      call rsvp-sync
      !
      !
      !
      !
      !
      !
      !
      !
      interface Loopback0
      ip address 172.16.1.10 255.255.0.0
      !
      interface Loopback1
      ip address 172.20.1.1 255.255.0.0
      !
      interface Ethernet0/0
      no ip address
      shutdown
      half-duplex
      !
      interface Serial0/0
      ip address 192.168.1.1 255.255.255.252
      !        
      interface Serial0/1
      no ip address
      shutdown
      !
      ip classless
      no ip http server
      !
      !
      dial-peer cor custom
      !
      !
      !
      !
      !
      line con 0
      password letmein
      transport input none
      line aux 0
      line vty 0 4
      login local
      !
      no scheduler allocate
      end      

      RouterA#
      09:02:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

        • 1. Re: Help with a lab setup
          Keneil Facey

          Could you post a show run of the DTE router for further analysis.

           

          Thanks

          • 2. Re: Help with a lab setup
            Martin

            not sure if I understand ?

            But

            show run does not tell if interface is up or down;

            show ip int brief or show intreface  will show you status;

            and show controllers  will tell you weather serial is with DCE or DTE cable;

            • 3. Re: Help with a lab setup
              Wayne

              Thanks for taking a stab at this just starting out and will power is being challenged right out of the box.

               

              Here is the show run for the DTE end point 2521 router I've included the Show IP Route also. please note that I had turned the keepalive off at the suggestion of someone else because the protocal wouldn't stay up on the 2521 side I was gettig a Line up Protocal down.

               

              RouterB#sh run
              Building configuration...

              Current configuration:
              !
              version 12.0
              service timestamps debug uptime
              service timestamps log uptime
              no service password-encryption
              !
              hostname RouterB
              !
              enable password cisco
              !
              username banbury password 0 ccna
              ip subnet-zero
              !
              !
              !
              interface Loopback0
              ip address 172.30.1.1 255.255.0.0
              no ip directed-broadcast
              !
              interface Loopback1
              ip address 172.31.1.1 255.255.0.0
              no ip directed-broadcast
              !
              interface Serial0
              ip address 192.168.1.2 255.255.255.252
              no ip directed-broadcast
              no keepalive
              !
              interface Serial1
              no ip address
              no ip directed-broadcast
              shutdown
              !
              interface Serial2
              no ip address
              no ip directed-broadcast
              shutdown
              !
              interface Serial3
              no ip address
              no ip directed-broadcast
              shutdown
              !
              interface TokenRing0
              no ip address
              no ip directed-broadcast
              shutdown
              !
              ip classless
              !
              !
              line con 0
              password letmein
              login
              transport input none
              line aux 0
              line vty 0 4
              login local
              !
              end

              RouterB#sh ip route
              Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                     E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
                     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
                     U - per-user static route, o - ODR

              Gateway of last resort is not set

              C    172.31.0.0/16 is directly connected, Loopback1
              C    172.30.0.0/16 is directly connected, Loopback0
                   192.168.1.0/30 is subnetted, 1 subnets
              C       192.168.1.0 is directly connected, Serial0
              RouterB#

              • 4. Re: Help with a lab setup
                Wayne

                Thanks for picking up on this, I have included the Sh IP Route and the Sh Ip Int Brief

                 

                2610 DCE side

                Router#sh ip route
                Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
                       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
                       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
                       * - candidate default, U - per-user static route, o - ODR
                       P - periodic downloaded static route

                Gateway of last resort is not set

                C    172.16.0.0/16 is directly connected, Loopback0
                C    172.20.0.0/16 is directly connected, Loopback1
                Router#sh ip int brief
                Interface                  IP-Address      OK? Method Status                Protocol
                Ethernet0/0                unassigned      YES unset  administratively down down   
                Serial0/0                  192.168.1.1     YES manual down                  down   
                Serial0/1                  unassigned      YES unset  administratively down down   
                Loopback0                  172.16.1.1      YES manual up                    up     
                Loopback1                  172.20.1.1      YES manual up                    up   

                 

                 

                 

                 

                2521 DTE side

                Router#sh ip route
                Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
                       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
                       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
                       U - per-user static route, o - ODR

                Gateway of last resort is not set

                C    172.31.0.0/16 is directly connected, Loopback1
                C    172.30.0.0/16 is directly connected, Loopback0

                 

                Router#sh ip int brief

                Interface              IP-Address      OK? Method Status                Protocol

                Loopback0              172.30.1.1      YES manual up                    up     

                Loopback1              172.31.1.1      YES manual up                    up     

                Serial0                192.168.1.2     YES manual down                  down   

                Serial1                unassigned      YES unset  administratively down down   

                Serial2                unassigned      YES unset  administratively down down   

                Serial3                unassigned      YES unset  administratively down down   

                TokenRing0

                • 5. Re: Help with a lab setup
                  Keneil Facey

                  I know show run doesnt really help in telling if an interface is up or down, I just needed to see what he had configured if there were any conflicting commands.

                   

                  Ok, seems normal so far, now could you post the output of show interface ser 0/0 and ser 0 on both routers, followed by a show controllers ser 0/0 and ser 0 as what Martin noted earlier.

                   

                  ***UPDATE***

                  I may have overlooked something, since the link is in the down state, it may be a physical problem, check if the cables are properly seated, in the correct interfaces, and in good condition, also try to configure other interfaces on the routers and try the cables in those.

                   

                  Thanks

                  • 6. Re: Help with a lab setup
                    Wayne

                    Thanks Keneil your answer is accepted as the fix. I ripped out all cabling and reconfigured the lab and everything is UP and UP thanks.I had replaced cable and switched to another router and back to the books. Sometime you have to be patient and double and triple check config and connections..

                    • 7. Re: Help with a lab setup
                      Keneil Facey

                      No problem, glad it all worked out.

                      • 8. Re: Help with a lab setup
                        Martin

                        I can Tell you BIG secret; you do not have to check cables in back of a router; sometimes you do not have access to router;

                        But, to see whether your router interface is DTE or DCE , you can do show controllers

                         

                        Edge2#sh controllers serial 0/1/0

                        Interface Serial0/1/0

                        Hardware is PowerQUICC MPC860

                        DTE V.35 TX and RX clocks detected

                        idb at 0x81081AC4, driver data structure at 0x81084AC0

                         

                        Edge2#sh controllers serial 0/1/1

                        Interface Serial0/1/1

                        Hardware is PowerQUICC MPC860

                        DCE V.35, clock rate 64000

                        and

                        if you not sure, just set up clocking any way;
                        DCE will take it and DTE will not;