Skip navigation
Cisco Learning Home > Certifications > Routing & Switching (CCNP) > Discussions

_Communities

This Question is Not Answered 1 Correct Answer available (4 pts) 1 Helpful Answer available (2 pts)
6183 Views 7 Replies Latest reply: Jul 11, 2011 12:34 AM by ISMAIL (CCIE (Written) /CCSP/CCNP/JNCIS-ER/MCSA) RSS

Currently Being Moderated

EtherChannel, PAgP and LACP with Trunk

Jul 10, 2011 7:55 PM

Bernard 44 posts since
Mar 3, 2011

Hi,

 

I was asked to look into core switches and suggests on refinement. I have some questions on etherchannel, pagp and lacp. Can someone advice me on these 3 questions?

 

Q1. According to the below configuration of a pair of Cat4506 switches, can I say it is just running purely EtherChannel? To enable PAgP, I need to set mode to auto or desirable?

 

interface Port-channel1
switchport
switchport mode trunk

!

interface GigabitEthernet3/1
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet3/2
switchport mode trunk
channel-group 1 mode on

Q2. Coming to LACP, what is the advantage of using LACP since both core switches are Cisco and Cisco Proprietary PAgP should work fine?

 

Q3. There are 2 VLANs in the network, these 2 cat4506 core switches are running HSRP for both VLANs, below is config for Core 1 (active):

interface Vlan1

ip address 172.18.204.3 255.255.254.0

ip helper-address 172.18.204.106

no ip redirects

standby 192 ip 172.18.204.1

standby 192 priority 105

standby 192 preempt

!

interface Vlan2

ip address 172.16.204.3 255.255.252.0

ip helper-address 172.16.204.106

no ip redirects

standby 193 ip 172.16.204.1

standby 193 priority 105

standby 193 preempt

 

Looking at the etherchannel configuration (at the top) which sets all ports to trunk but without specifying which vlan to trunk, can I say there is no trunking of vlan 1 and 2 over the etherchannel?

 

To enable etherchannel with trunking, I think I should be configuring these to allow trunking of both vlan and setting vlan 2 as native?:

interface Port-channel1
switchport
switchport mode trunk

!

interface GigabitEthernet3/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet3/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk
channel-group 1 mode on

 

This post is rather long but I need to get everything right before I make proposal and request for network maintenance window.

 

 

Thanks,

Bernard

  • Currently Being Moderated
    1. Jul 10, 2011 8:24 PM (in response to Bernard)
    Re: EtherChannel, PAgP and LACP with Trunk

    Q.1 Its enabled etherchannel without PAgP or LACP,

     

    if you wants to run PAgP (you must enable one side desireable

     

    here is combination for PAgP

     

    Desireable+Auto    = WOrks fine

    Both side desirable = works fine

    Both side Auto = no Etherchannel

     

     

    Q2.      If using cisco, there’s no advantage in using lacp over standard etherchannel.

    Q3.      enable trunking over each VLAN and assigned your Native vlan too

     

    for more details visit this link

    http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_example09186a00800ef797.shtml

  • Currently Being Moderated
    3. Jul 10, 2011 10:11 PM (in response to Bernard)
    Re: EtherChannel, PAgP and LACP with Trunk

      Qu.1 - LACP and PAGP both are ether-channel negotiation protocol, when you configure mode ON , it means your forcing a link to be a ether-channel and disable dynamic protocol negotiation. (It is similer to DTP to negotialte a trunk link and to force a link to trun we use mode Trunk )

     

    Q2 -  lacp and pagp both are same and there is not advantage or lacp over pagp except propraitry .. if you want etherchannel between non-cisco switch , or with server lacp you should user lacp as pagp is cisco propraitry protocol.

     

    Q3 - as per my understanding you want to block vlan 2 - and vlan 3 over the etherchannel . just to help you all the logical config of etherchannel member interface goes on the ether-channel interface like :

     

    interface Port-channel1

    switchport

    switchport mode trunk

    switchport trunk encapsulation dot1q

    switchport trunk allowed vlan all

    switchport trunk native vlan 2

     

    and if you want to remove vlan 2 -3 over the etherchannel interface you can use ..

     

    switchport trunk allowed vlan remove vlan 2 - 3

     

    Thanks |

    aks

  • Currently Being Moderated
    4. Jul 10, 2011 10:23 PM (in response to Bernard)
    Re: EtherChannel, PAgP and LACP with Trunk

    if you wants to use PAgP only enter this command only

     

    #channel-group 1 mode desirable     (use this command at lease one side or can be used both side)

     

    here is example from cisco documents to configure the EtherChannel with PAgP:

     

    ------------------------------------------------------------------------------------------------------------

    A(config)#interface range gigabitethernet 1/0/4 - 5

    A(config-if-range)#channel-group 1 mode desirable

    A(config-if-range)#switchport trunk encapsulation dot1q

    A(config-if-range)#switchport mode trunk

          

    A(config)#interface gigabitethernet 3/0/3

    A(config-if)#channel-group 1 mode desirable

    ------------------------------------------------------------------------------------------------------------

     

     

    further you can visit this link

     

    http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00806cb982.shtml

     

  • Currently Being Moderated
    7. Jul 11, 2011 12:34 AM (in response to Bernard)
    Re: EtherChannel, PAgP and LACP with Trunk

    yes now Etherchannel is PAgP Mode configured in it.

     

    one more thing

     

    by default trunk will permit all VLANs you have created,

     

    no needs for this if you are not restrictiction specific one (switchport trunk allowed vlan all )

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)