1 2 3 4 Previous Next 51 Replies Latest reply: Sep 26, 2011 3:23 AM by kohkokwai RSS

    Switch configuration

    lavanya

      Hi,

       

      Following is the switch configuration I want to use, now can I pump l2 traffic from device A t device B? If yes/No please let me know. Thanks in advance.

      switch comm.JPG

        • 1. Re: Switch configuration
          Philip Esi

          There really isn't enough info in your diagram to give you an answer? First is there some inter-vlan routing going on? If not, are the 2 hosts in the same subnet? Are the configured vlans allowed on the trunk links? Is spanning-tree fowarding for the appropriate vlans? and so on...If you can provide us with more info of your intended network, we would be able to give you a definite answer.

           

          Cheers,

          Philip

          • 2. Re: Switch configuration
            zeroone

            i would say No.

            • 3. Re: Switch configuration
              Alex Presse

              Looks like Sw3 is not participating in Vl2. So strictly staying in Layer2 without performing some wizardry then no.

               

              I suppose you could in theory get at least one-way traffic (A -> B) with RSPAN

               

              EDIT:

              Or, mismatch your native VLANs.

              • 4. Re: Switch configuration
                Sey

                Yes you can pass L2 traffic from device A to device B. You will have to break rules and "misconfigure" native vlans on the trunks for that. The traffic will start in vlan 2 on Switch A, then leak to vlan 3 on Switch B, then leak to vlan 4 on Switch C, and finally arrive at Device B.

                • 5. Re: Switch configuration
                  Abdallah Abdel-Jaber

                  basically it shows No. Cause the vlans are separate and there is no L3 switching or Inter-Vlan. If you could show us more configurations for the native vlans and the trunking vlans.

                   

                  Thanks,

                  Abdallah

                  • 6. Re: Switch configuration
                    ISMAIL (CCIE (Written) /CCSP/CCNP/JNCIS-ER/MCSA)

                    Its possible only if you have both PCs connected VLANs are native for their directly connected switches

                     

                     

                    like A is connected to switch A (VLAN1 same vlan is as native),  Device B connected to VLAN 4 (over switch C, if this VLAN is not native you will not able to communicate, if you wants to do it just configure this VLAN 4 as native over that trunk link then it works fine

                     

                     

                    find attached topology based on your reqirements

                     

                     

                    for testing move over switch c and int connect to pc move over other vlan or over trun link move native vlan to any other vlan and test it will stop functionality.

                     

                     

                    hope this will expains what you are looking for

                     

                    what i configured in it is

                     

                    Switch A Port connected to PC A (as access VLAN 1)

                    Switch A to Switch B trunk

                    Switch B to switch C Trunk

                    Switch C Port connected to PC B( as access VLAN 4)

                     

                    now VLAN1 is native for Switch A, and VLAN 4 is native (manually configured for switch C)

                    • 7. Re: Switch configuration
                      ISMAIL (CCIE (Written) /CCSP/CCNP/JNCIS-ER/MCSA)

                      dear abdullah

                       

                      please download this attachment and check it works (only if both devices connected vlan are native, does not matter same vlan or different but must be native)

                      • 8. Re: Switch configuration
                        Brian

                        Aloha lavanya,

                         

                        As configured in your example NO it will not work as you have "trunk" links between switches and this requires a layer 3 device to perform inter-VLAN routing.  VLAN tags are carried in the frame header on trunks.  However, if you setup the inter-switch links as "Access" links, then yes you can ping from device A to device B providing the PCs belong to the same subnet and the "native" vlans match between switches.  Below are two examples showing this.

                         

                        Simple_Access_Link.JPG

                         

                        SW0#sh vlan

                        VLAN Name                             Status    Ports
                        ---- -------------------------------- --------- -------------------------------
                        1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                                        Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                                        Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                                        Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                                        Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                                        Fa0/22, Fa0/23, Gig1/1, Gig1/2
                        11   VLAN0011                         active    Fa0/1, Fa0/24
                        1002 fddi-default                     act/unsup
                        1003 token-ring-default               act/unsup
                        1004 fddinet-default                  act/unsup
                        1005 trnet-default                    act/unsup

                        SW0#sh ip int br
                        Interface              IP-Address      OK? Method Status                Protocol

                         

                        FastEthernet0/1        unassigned      YES manual up                    up

                        FastEthernet0/24       unassigned      YES manual up                    up

                         

                        SW0#
                        =====================================

                        SW1#sh vlan

                        VLAN Name                             Status    Ports
                        ---- -------------------------------- --------- -------------------------------
                        1    default                          active    Fa0/1, Fa0/3, Fa0/4, Fa0/5
                                                                        Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                                        Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                                        Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                                        Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                                        Fa0/22, Fa0/23, Gig1/1, Gig1/2
                        12   VLAN0012                         active    Fa0/2, Fa0/24
                        1002 fddi-default                     act/unsup
                        1003 token-ring-default               act/unsup
                        1004 fddinet-default                  act/unsup
                        1005 trnet-default                    act/unsup

                        SW1#sh ip int br
                        Interface              IP-Address      OK? Method Status                Protocol

                         

                        FastEthernet0/2        unassigned      YES manual up                    up

                         

                        FastEthernet0/24       unassigned      YES manual up                    up

                         

                        SW1#

                        ======================================

                        PC>ping 192.168.11.2

                        Pinging 192.168.11.2 with 32 bytes of data:

                        Reply from 192.168.11.2: bytes=32 time=438ms TTL=128
                        Reply from 192.168.11.2: bytes=32 time=94ms TTL=128
                        Reply from 192.168.11.2: bytes=32 time=94ms TTL=128
                        Reply from 192.168.11.2: bytes=32 time=94ms TTL=128

                        Ping statistics for 192.168.11.2:
                            Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
                        Approximate round trip times in milli-seconds:
                            Minimum = 94ms, Maximum = 438ms, Average = 180ms

                        PC>

                         

                        So, to make this work the switches must be using the same "native" vlan and the PCs must belong to the same IP subnet.  The inter-switch linbks are configured as "access" links with the "switchport mode access" command.

                         

                        ======================================

                         

                        Three switches as in your original diagram, but with "Access" links between switches.  Notice that only one VLAN exists on each switch.  Meaning both ports on each of the switches belong to the same VLAN, but between switches is where we can change the VLAN.  Why?  Because the VLAN tag is only present when you have "trunk" links.

                         

                        Simple_Access_Link_2.JPG

                         


                        PC>ping 192.168.11.4

                        Pinging 192.168.11.4 with 32 bytes of data:

                        Reply from 192.168.11.4: bytes=32 time=265ms TTL=128
                        Reply from 192.168.11.4: bytes=32 time=125ms TTL=128
                        Reply from 192.168.11.4: bytes=32 time=125ms TTL=128
                        Reply from 192.168.11.4: bytes=32 time=125ms TTL=128

                        Ping statistics for 192.168.11.4:
                            Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
                        Approximate round trip times in milli-seconds:
                            Minimum = 125ms, Maximum = 265ms, Average = 160ms

                        PC>

                         

                        If you have access to Cisco PT you can lab this up for yourself and see the pings in action.


                        Brian

                        • 9. Re: Switch configuration
                          Sey

                          Hi Brian,

                          As configured in your example NO it will not work as you have "trunk" links between switches

                          Yes it will work with trunks between the switches, as long as those are 802.1q trunks which can forward frames untagged (the concept of native vlan). Your topology is one of the solutions to the problem. The other one is to configure dot1q trunks between switches and allow data to leak from one vlan to another through native vlans.

                          VLAN tags are carried in the frame header on trunks

                          True, but there is an exception to this - native vlans.

                          However, if you setup the inter-switch links as "Access" links, then yes you can ping from device A to device B providing the PCs belong to the same subnet and the "native" vlans match between switches

                          A "native vlan" term can be applied to trunks only. There is no native vlan on an access port. So if you configure all inter-switch connections as access ports, it does not matter what native vlans are configured on those ports - they will not be applied anyway.

                          • 10. Re: Switch configuration
                            Abdallah Abdel-Jaber

                            Dear Ismail,

                             

                            The file you provide is not in separated vlans. and when you set a vlan you must address different SM or network IP:

                             

                            you configured the pcs as the same network id and ofcorse the untagged vlans on both sides can met each other and "vwalla" they are connected

                             

                            please use the updated file from me...

                             

                            Sincerely,

                            Abdallah

                            • 11. Re: Switch configuration
                              ISMAIL (CCIE (Written) /CCSP/CCNP/JNCIS-ER/MCSA)

                              Dear abdullah,

                               

                              if subnet is different you cannot communicate even over one switch (L2) you need routing, i made it as user mentions in their question that L2  traffic. but VLANs are different.

                               

                              regards

                              ismail

                              • 12. Re: Switch configuration
                                Brian

                                Aloha Sey and Ismail,

                                 

                                Not sure I following what you guys are saying about the above configuration posted by lavanya, but I have labbed it up and it does not work.  Below are the network diagrams and switch configuration information.  The first diagram is just like what lavanya posted.  You can see the ping is unsuccessful.

                                 

                                switch_trunk_links.jpg

                                 

                                SWA#sh int f0/2 sw
                                Name: Fa0/2
                                Switchport: Enabled
                                Administrative Mode: static access
                                Operational Mode: static access
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: native
                                Negotiation of Trunking: Off
                                Access Mode VLAN: 2 (VLAN0002)
                                Trunking Native Mode VLAN: 2 (VLAN0002)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWA#

                                 

                                SWA#sh int f0/24 sw
                                Name: Fa0/24
                                Switchport: Enabled
                                Administrative Mode: trunk
                                Operational Mode: trunk
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: dot1q
                                Negotiation of Trunking: On
                                Access Mode VLAN: 1 (default)
                                Trunking Native Mode VLAN: 2 (VLAN0002)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWA#

                                 

                                interface FastEthernet0/2
                                switchport access vlan 2
                                switchport trunk native vlan 2
                                switchport mode access
                                !
                                interface FastEthernet0/24
                                switchport trunk native vlan 2
                                switchport mode trunk
                                !

                                ++++++++++

                                SWB#sh int f0/23 switchport
                                Name: Fa0/23
                                Switchport: Enabled
                                Administrative Mode: trunk
                                Operational Mode: trunk
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: dot1q
                                Negotiation of Trunking: On
                                Access Mode VLAN: 1 (default)
                                Trunking Native Mode VLAN: 2 (Inactive)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWB#

                                SWB#sh int f0/24 switchport
                                Name: Fa0/24
                                Switchport: Enabled
                                Administrative Mode: trunk
                                Operational Mode: trunk
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: dot1q
                                Negotiation of Trunking: On
                                Access Mode VLAN: 1 (default)
                                Trunking Native Mode VLAN: 4 (Inactive)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWB#

                                 

                                interface FastEthernet0/23
                                switchport trunk native vlan 2
                                switchport mode trunk
                                !
                                interface FastEthernet0/24
                                switchport trunk native vlan 4
                                switchport mode trunk
                                !

                                ++++++++++

                                SWC#sh int f0/24 sw
                                Name: Fa0/24
                                Switchport: Enabled
                                Administrative Mode: trunk
                                Operational Mode: trunk
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: dot1q
                                Negotiation of Trunking: On
                                Access Mode VLAN: 1 (default)
                                Trunking Native Mode VLAN: 4 (VLAN0004)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWC#

                                 

                                SWC#sh int f0/4 sw
                                Name: Fa0/4
                                Switchport: Enabled
                                Administrative Mode: static access
                                Operational Mode: static access
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: native
                                Negotiation of Trunking: Off
                                Access Mode VLAN: 4 (VLAN0004)
                                Trunking Native Mode VLAN: 1 (default)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWC#

                                 

                                interface FastEthernet0/4
                                switchport access vlan 4
                                switchport trunk native vlan 4
                                switchport mode access
                                !
                                interface FastEthernet0/24
                                switchport trunk native vlan 4
                                switchport mode trunk
                                !

                                ++++++++++

                                PC>ping 192.168.11.4 -n 10

                                Pinging 192.168.11.4 with 32 bytes of data:

                                Request timed out.
                                Request timed out.
                                Request timed out.
                                Request timed out.
                                Request timed out.
                                Request timed out.
                                Request timed out.
                                Request timed out.
                                Request timed out.
                                Request timed out.

                                Ping statistics for 192.168.11.4:
                                    Packets: Sent = 10, Received = 0, Lost = 10 (100% loss),

                                PC>

                                ==========
                                ==========

                                The second diagram is the same configuration, except with "access" links between the switches.

                                 

                                switch_access_links.jpg

                                 

                                SWA#sh int f0/2 sw
                                Name: Fa0/2
                                Switchport: Enabled
                                Administrative Mode: static access
                                Operational Mode: static access
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: native
                                Negotiation of Trunking: Off
                                Access Mode VLAN: 2 (VLAN0002)
                                Trunking Native Mode VLAN: 1 (default)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWA#

                                 

                                SWA#sh int f0/24 sw
                                Name: Fa0/24
                                Switchport: Enabled
                                Administrative Mode: static access
                                Operational Mode: static access
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: native
                                Negotiation of Trunking: Off
                                Access Mode VLAN: 2 (VLAN0002)
                                Trunking Native Mode VLAN: 2 (VLAN0002)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWA#

                                 

                                interface FastEthernet0/2
                                switchport access vlan 2
                                switchport mode access
                                !
                                interface FastEthernet0/24
                                switchport access vlan 2
                                switchport trunk native vlan 2
                                switchport mode access
                                !

                                ++++++++++

                                SWB#sh int f0/23 sw
                                Name: Fa0/23
                                Switchport: Enabled
                                Administrative Mode: static access
                                Operational Mode: static access
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: native
                                Negotiation of Trunking: Off
                                Access Mode VLAN: 3 (VLAN0003)
                                Trunking Native Mode VLAN: 1 (default)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWB#

                                 

                                SWB#sh int f0/24 sw
                                Name: Fa0/24
                                Switchport: Enabled
                                Administrative Mode: static access
                                Operational Mode: static access
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: native
                                Negotiation of Trunking: Off
                                Access Mode VLAN: 3 (VLAN0003)
                                Trunking Native Mode VLAN: 1 (default)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWB#

                                 

                                interface FastEthernet0/23
                                switchport access vlan 3
                                switchport mode access
                                !
                                interface FastEthernet0/24
                                switchport access vlan 3
                                switchport mode access
                                !

                                SWB#
                                %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/23 (1), with SWA FastEthernet0/24 (2).

                                SWB#

                                 

                                Even though these are "access" links between SWA and SWB, you still get the "native" vlan mismatch error when SWA is set for "native vlan 2" and SWB is set for "native vlan 1".  So, this is what I mean by saying the "native" vlans must match between switches.

                                 

                                interface FastEthernet0/23
                                switchport access vlan 3
                                switchport trunk native vlan 2
                                switchport mode access
                                !

                                corrected the vlan mismatch by setting the "native vlan 2" on SWB port f0/23.

                                ++++++++++

                                SWC#sh int f0/24 sw
                                Name: Fa0/24
                                Switchport: Enabled
                                Administrative Mode: static access
                                Operational Mode: static access
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: native
                                Negotiation of Trunking: Off
                                Access Mode VLAN: 4 (VLAN0004)
                                Trunking Native Mode VLAN: 1 (default)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWC#

                                 

                                SWC#sh int f0/4 sw
                                Name: Fa0/4
                                Switchport: Enabled
                                Administrative Mode: static access
                                Operational Mode: static access
                                Administrative Trunking Encapsulation: dot1q
                                Operational Trunking Encapsulation: native
                                Negotiation of Trunking: Off
                                Access Mode VLAN: 4 (VLAN0004)
                                Trunking Native Mode VLAN: 1 (default)
                                Voice VLAN: none
                                Administrative private-vlan host-association: none
                                Administrative private-vlan mapping: none
                                Administrative private-vlan trunk native VLAN: none
                                Administrative private-vlan trunk encapsulation: dot1q
                                Administrative private-vlan trunk normal VLANs: none
                                Administrative private-vlan trunk private VLANs: none
                                Operational private-vlan: none
                                Trunking VLANs Enabled: ALL
                                Pruning VLANs Enabled: 2-1001
                                Capture Mode Disabled
                                Capture VLANs Allowed: ALL
                                Protected: false
                                Appliance trust: none
                                SWC#

                                 

                                interface FastEthernet0/4
                                switchport access vlan 4
                                switchport mode access
                                !
                                interface FastEthernet0/24
                                switchport access vlan 4
                                switchport mode access
                                !

                                ++++++++++

                                PC>ping 192.168.11.4 -n 10

                                Pinging 192.168.11.4 with 32 bytes of data:

                                Reply from 192.168.11.4: bytes=32 time=234ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=124ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=125ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=109ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=78ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=125ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=125ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=125ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=111ms TTL=128
                                Reply from 192.168.11.4: bytes=32 time=94ms TTL=128

                                Ping statistics for 192.168.11.4:
                                    Packets: Sent = 10, Received = 10, Lost = 0 (0% loss),
                                Approximate round trip times in milli-seconds:
                                    Minimum = 78ms, Maximum = 234ms, Average = 125ms

                                PC>

                                 

                                ==========
                                ==========

                                 

                                You can see using "trunk" links between switches does not work, even if I set the native vlans on the switches to match the access vlan.  The configuration only works when the inter-switch links are "access" links.  In addition the "native" vlans must match on the links between switches and the PCs must belong to the same subnet.  If you have a different configuration that works with "trunk" links between switches please share.

                                 

                                Brian

                                • 13. Re: Switch configuration
                                  Brian

                                  Your file needs some work.  Did you verify the ping was successful?  I just upload your file into my PT and the ping is unsuccessful.  In addition, you do not have the configuration as described by lavanya.  The PC on the left should be Vlan 2 and the PC on the right Vlan 4.  You are getting a "native" vlan mismatch on SW0  for the link between SW1 and SW0.  Did you see that?

                                   

                                  I am still waiting for someone to post a "working" conmfiguration as described by lavanya.

                                   

                                  Brian

                                   

                                  • 14. Re: Switch configuration
                                    Brian

                                    This configuration does not work either.  The ping from host A to host B is unsuccessful.

                                     

                                    Can you elaborate on what it is you are configuring to make the diagram posted by lavanya to work.

                                     

                                    Brian

                                     

                                    1 2 3 4 Previous Next