4 Replies Latest reply: Jun 29, 2011 3:43 PM by Brian RSS

    EIGRP Neighbourship

    Kamalpreet

      I assign secondary IP of f0/0 on both R1 and R2. on R2 i publish network 10.0.0.0, 3.0.0.0, 2.0.0.0. Still router is able to create neighbourship as i have not publish 192.168.1.1 network on R2.


      why this happen.

       

       

      R1

       

      interface Loopback0

      ip address 1.1.1.1 255.255.255.0

      !

      interface FastEthernet0/0

      ip address 10.1.1.1 255.255.255.0 secondary

      ip address 192.168.1.1 255.255.255.0

      duplex auto

      speed auto

      !

      router eigrp 1

      network 0.0.0.0

      no auto-summary

      !

      no ip http server

       

       

       

      R2

       

      interface Loopback0

      ip address 2.2.2.3 255.255.255.0 secondary

      ip address 2.2.2.2 255.255.255.0

      !

      interface Loopback3

      ip address 3.3.3.3 255.255.255.0

      !

      interface FastEthernet0/0

      ip address 10.1.1.2 255.255.255.0 secondary

      ip address 192.168.1.2 255.255.255.0

      duplex auto

      speed auto

      !

      router eigrp 1

      network 2.2.2.0 0.0.0.7

      network 3.0.0.0

      network 10.0.0.0

      no auto-summary

        • 1. Re: EIGRP Neighbourship
          ISMAIL (CCIE (Written) /CCSP/CCNP/JNCIS-ER/MCSA)

          in your case R1 you all networks subnets published using 0.0.0.0, means primary address and secondary over R1, where as over R2 you publish only Secondary)

           

          Let's take a look at R2 and R3, which will be using secondary addresses to form an EIGRP adjacency across an ethernet segment.

           

          R2(config)#interface ethernet0

          R2(config-if)#ip address 172.12.23.2 255.255.255.0

          R2(config-if)#ip address 23.23.23.2 255.255.255.0 secondary

          R2(config)#router eigrp 100

          R2(config-router)#no auto-summary

          R2(config-router)#network 23.23.23.0 0.0.0.255          (publised secondary only)

           

           

          R3(config)#interface ethernet0

          R3(config-if)#ip address 172.12.23.3 255.255.255.0

          R3(config-if)#ip address 23.23.23.3 255.255.255.0 secondary

          R3(config)#router eigrp 100

          R3(config-router)#no auto-summary

          R3(config-router)#network 23.23.23.0 0.0.0.255

           

           

          Here's the partial output of show ip eigrp neighbor on R3:

           

           

          R3#show ip eigrp neighbor

           

          IP-EIGRP neighbors for process 100

           

          H Address Interface

           

           

          0 172.12.23.2 Et0

           

          The adjacency has formed! Note the address is actually the primary IP address on the interface, even though we used the secondary network number in the EIGRP network command. Personally, I stay away from secondary network numbers if at all possible, but you should know that secondary IP addresses can be used to create EIGRP adjacencies.

           

          Note: common error with using secondary addresses comes when an address from the same subnet is the primary interface address on one neighbor and the secondary interface address on another.

           

          Let's say we had configured R2 and R3 as follows:

           

          R2(config)#int e0

           

          R2(config-if)#ip address 23.23.23.2 255.255.255.0

           

           

          R3(config)#interface ethernet0

           

          R3(config-if)#ip address 172.12.23.3 255.255.255.0

           

          R3(config-if)#ip address 23.23.23.3 255.255.255.0 secondary

           

           

          On R2, we get this message:

           

           

          01:54:05: IP-EIGRP: Neighbor 172.12.23.3 not on common subnet for Ethernet0 (23.23.23.2 255.255.255.0)

           

           

          Since we configured 23.23.23.2 as a primary interface address on R2, the EIGRP process is looking at the primary interface address on potential neighbors. R3's primary ethernet0 address is 172.12.23.2, so you get the 'not on common subnet' error message - and what you don't get is an adjacency! That's something to be aware of on your 642-901 BSCI exam as well as when working with EIGRP in production networks.

           

           

          vist this link for further details

          http://www.flixya.com/blog/356218/Cisco-CCNP-642-901-BSCI-Exam-Tutorial-EIGRP-Adja

          • 2. Re: EIGRP Neighbourship
            Brian

            bottom line, EIGRP can not form neighbor adjacencies over secondary IP addresses.

             

            HTH

             

            • 3. Re: EIGRP Neighbourship
              ISMAIL (CCIE (Written) /CCSP/CCNP/JNCIS-ER/MCSA)

              neighbors adjacencies can be possible using secondary shows link as made by primary IP, and may have some issues in this case

              • 4. Re: EIGRP Neighbourship
                Brian

                No, EIGRP will not form neighbor adjacencies over secondary addresses.  Check your configuration again.  This is from the EIGRP FAQ.

                 

                EIGRP does support secondary addresses. Since EIGRP always sources data packets from the primary address, Cisco recommends that you configure all routers on a particular subnet with primary addresses that belong to the same subnet. Routers do not form EIGRP neighbors over secondary networks. Therefore, if all of the primary IP addresses of routers do not agree, problems can arise with neighbor adjacencies.

                 

                HTH