7 Replies Latest reply: Apr 11, 2014 4:13 PM by Alex RSS

    (EIGRP) Bandwidth Percent - verification?

    Alex Presse

      Here's my really slick configuration:

       

       

      interface Serial1/0

      bandwidth 192

      no ip address

      ip bandwidth-percent eigrp 15 17

      encapsulation frame-relay

      serial restart-delay 0

      !

      interface Serial1/0.1 point-to-point

      bandwidth 128

      ip address 193.10.25.10 255.255.255.0

      ip authentication mode eigrp 15 md5

      ip authentication key-chain eigrp 15 EIGRPLAB

      frame-relay interface-dlci 101  

      !

      interface Serial1/0.2 point-to-point

      bandwidth 64

      ip address 193.10.26.10 255.255.255.0

      ip authentication mode eigrp 15 md5

      ip authentication key-chain eigrp 15 EIGRPLAB

      frame-relay interface-dlci 201  

       

       

      I've tried googling this a bit, but does anybody know if there is a way to verify how much bandwidth EIGRP is allowed to take per (sub)interface?

      In my example above, I want EIGRP to be limited at each sub-interface to 32kbps which is about 17% of 192. So can I configure the bandwidth-percent on the parent interface or should I be configuring it at each sub-interface? (I know I SHOULD configure it at each sub-interface, but what will happen with what I have configured above?)

       

      Many thanks guys and gals!

        • 1. Re: (EIGRP) Bandwidth Percent - verification?
          Brian

          Aloha Alex,

           

          With EIGRP over FR you want to make sure you configure the bandwidth correctly to avoid possible loss to EIGRP packets.  There three basic rules:

           

          1. EIGRP traffic should not be allowed to exceed the capacity of the VC.
          2. The total EIGRP traffic for all VCs should not exceed the access line rate of the interface.
          3. the bandwidth allowed for EIGRP should be the same on both sides of the link.

           

          In P2P connections, you have maximum control over the bandwidth and is the best configuration if the VCs have different bandwidths.  So, you should configure the bandwidth and the EIGRP "bandwidth-percent" for each P2P link directly under the subinterface rather than the main interface.

           

          Reference: Document ID: 13672, "Configuration Notes for the Implementation of EIGRP over Frame Relay and Low Speed Links"

           

          HTH

           

          Message was edited by: Brian

          • 2. Re: (EIGRP) Bandwidth Percent - verification?
            Keith Barker - CCIE RS/Security, CISSP

            small  Wan tshoot with dlci and IPs.jpg

             

            R1(config-if)#do show ip eigrp int

            IP-EIGRP interfaces for process 1

             

                                    Xmit Queue   Mean   Pacing Time   Multicast    Pending

            Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes

            Lo0                0        0/0         0       0/1            0           0

            Fa0/0              1        0/0        19       0/2           92           0

            Se0/0              1        0/0        10      64/2432      2480           0

            Se0/1              1        0/0        18       0/15          91           0

            Se0/2              2        0/0       224      64/2432      6236           0

            Se0/2.6            1        0/0       231       0/15        1423           0

            Se0/2.7            1        0/0        22       0/15         143           0

             

            Modify bandwidth-percent for ser0/2:

             

            R1(config-if)#ip bandwidth-percent eigrp 1 1

            R1(config-if)#do show ip eigrp int         

            IP-EIGRP interfaces for process 1

             

                                    Xmit Queue   Mean   Pacing Time   Multicast    Pending

            Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes

            Lo0                0        0/0         0       0/1            0           0

            Fa0/0              1        0/0        19       0/2           92           0

            Se0/0              1        0/0        10      64/2432      2480           0

            Se0/1              1        0/0        18       0/15          91           0

            Se0/2              2        0/0       224    3200/121600    6236           0

            Se0/2.6            1        0/0       231       0/15        1423           0

            Se0/2.7            1        0/0        22       0/15         143           0

             

            At least for the pacing time, there is a change, due to the configuration, but the change isn't reflected for the sub interfaces.

             

            It doesn't look like it trickles down.

             

            I am open to other input.

             

            Keith

             

            Here is a Frame Relay/WAN troubleshooting video, based on the above topology.

             

            best viewed full screen, using hd 720p option

            • 3. Re: (EIGRP) Bandwidth Percent - verification?
              Alex Presse

              Thanks Brian!

              I think you have a typo in your first point - "... should be allowed to exceed ..."? Shouldn't it not be allowed to exceed?

               

              I'm still wishing for a way to verify how much BW EIGRP will take up... Without doing a capture and analysis.

              • 4. Re: (EIGRP) Bandwidth Percent - verification?
                Brian

                Yes, thank you.  I will fix the post.

                 

                The default is 50% of the bandwidth.  So, if you configure the "bandwidth-percent" to 17% and the subinterface is set for 64k as you have done, then you can be assured that EIGRP will not use more than 10k or 11k (64k *.17 = 10.88).  I do not know of any command off the top of my head that will show what is used.  I would have to do a quick lab and see.

                 

                HTH

                 

                • 5. Re: (EIGRP) Bandwidth Percent - verification?
                  Alex Presse

                  So that's what the pacing timer is. I like this feeling of having learned something.

                  Upon reading Document 16406 I guess I understand a bit more about this feature... Here's hoping I don't have to compute the corresponding bandwidth-percent command given a pacing-timer value!

                  • 6. Re: (EIGRP) Bandwidth Percent - verification?
                    NuklearKrisis - CCNA

                    WOW Keith Barker might answer your question on this forum!!! NO WAY!! That is INSANE!

                     

                    Keith Barker is the ultimate master of IT...he knows everything. 

                    • 7. Re: (EIGRP) Bandwidth Percent - verification?
                      Alex

                      interface Ethernet0/0.35

                      encapsulation dot1Q 35

                      ip address 172.16.35.3 255.255.252.0

                      ip bandwidth-percent eigrp 35 25

                      ip summary-address eigrp 35 172.16.0.0 255.255.0.0

                      ip ospf 123 area 3

                      end

                       

                      R3#sh ip eigrp int det

                      EIGRP-IPv4 Interfaces for AS(35)

                                                    Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending

                      Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes

                      Et0/0.35                 1        0/0       0/0           6       0/5           50           0

                        Hello-interval is 5, Hold-time is 15

                        Split-horizon is enabled

                        Next xmit serial <none>

                        Packetized sent/expedited: 9/2

                        Hello's sent/expedited: 285/2

                        Un/reliable mcasts: 0/6  Un/reliable ucasts: 8/4

                        Mcast exceptions: 1  CR packets: 1  ACKs suppressed: 0

                        Retransmissions sent: 0  Out-of-sequence rcvd: 0

                        Topology-ids on interface - 0

                        Interface BW percentage is 25

                        Authentication mode is not set

                       

                      That's the fastest way to see the currently configured percentage, then the calc is simple

                       

                      R3#sh int Et0/0.35 | i BW

                        MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,

                       

                      25% x 10000 = 2500 Kbps