10 Replies Latest reply: Apr 22, 2011 7:16 PM by sid RSS

    how ...mpls and vpn on gns3

    sid

      can some one pls give me some links of simple mpls and vpn labs on gns3.i try to practice by creating own but i was not successfull to create so....because as a beginner i don't exactly know how it should run.... thanks

        • 2. Re: how ...mpls and vpn on gns3
          Conwyn

          Hi Sid

           

          See the Advanced Routing and Switching documents section.

           

          Regards Conwyn

          • 3. Re: how ...mpls and vpn on gns3
            Yudha AP
            • 4. Re: how ...mpls and vpn on gns3
              Keith Barker - CCIE RS/Security, CISSP

              Sid-

               

              Any chance you might be at Cisco Live in Vegas this year?

               

              They have some excellent practice walk in labs available at the event, on dozens of topics, including MPLS L3 VPNs.   They run them on IOS on UNIX, and they are fantastic.

               

              I will also be presenting at Cisco Live on the topic of MPLS L3 VPNs, and will have some lab/practice suggestions as part of that presentation.

               

              Keith MPLS VPN overview.png

              http://www.ciscolive.com/us/index.php

              Best wishes,

               

              Keith

              • 5. Re: how ...mpls and vpn on gns3
                Erick

                Hi Keith.

                 

                That looks like a very interesting session.  I wish I could attend.  Have a great time!

                 

                Erick

                • 6. Re: how ...mpls and vpn on gns3
                  Yudha AP

                  Keith Barker - CCIE RS/Security, CISSP, CCSI wrote:

                   

                  Sid-

                   

                  Any chance you might be at Cisco Live in Vegas this year?

                   

                  They have some excellent practice walk in labs available at the event, on dozens of topics, including MPLS L3 VPNs.   They run them on IOS on UNIX, and they are fantastic.

                   

                  I will also be presenting at Cisco Live on the topic of MPLS L3 VPNs, and will have some lab/practice suggestions as part of that presentation.

                   

                  Keith MPLS VPN overview.png

                  http://www.ciscolive.com/us/index.php

                  Best wishes,

                   

                  Keith

                   

                  Thanks for the info, Keith

                  • 7. Re: how ...mpls and vpn on gns3
                    Muhammad Arshad

                    MPLS-VPN.png

                    Dear Sid,

                     

                    I send you topology above and running configuration below.

                    Please note that R2, R3, R4 are running IS-IS first and secondly you have to  BGP as my Configuration shows below,

                    I did this for all bigners of MPLS L3 and L2.

                    I think you must appreciate it.

                     

                    Host-RTR-1#show ip int brief

                    Interface                  IP-Address      OK? Method Status                Protocol

                    FastEthernet0/0            unassigned      YES NVRAM  up                    up

                    FastEthernet0/0.34         192.168.34.1    YES NVRAM  up                    up

                    FastEthernet0/0.35         192.168.35.2    YES NVRAM  up                    up

                    FastEthernet0/1            unassigned      YES NVRAM  administratively down down

                     

                    Host-RTR-1#sh run

                    interface FastEthernet0/0

                    no ip address

                    duplex auto

                    speed auto

                    !

                    interface FastEthernet0/0.34

                    encapsulation dot1Q 34

                    ip address 192.168.34.1 255.255.255.252

                    !

                    interface FastEthernet0/0.35

                    encapsulation dot1Q 35

                    ip address 192.168.35.2 255.255.255.252

                    !

                    interface FastEthernet0/1

                    no ip address

                    shutdown

                    duplex auto

                    speed auto

                    !

                    ip http server

                    ip classless

                    ip route 192.168.36.0 255.255.255.252 192.168.35.1

                    !

                     

                    R2#show run
                    Building configuration...

                    !
                    hostname R2
                    !
                    ip cef

                     

                    !
                    ip vrf two
                    rd 64513:2
                    route-target export 64513:2
                    route-target import 64513:2
                    !
                    interface Loopback10
                    ip address 10.10.10.10 255.255.255.255
                    ip router isis
                    !
                    interface FastEthernet0/0
                    no ip address
                    duplex auto
                    speed auto
                    !
                    interface FastEthernet0/0.34
                    encapsulation dot1Q 34
                    no cdp enable
                    xconnect 30.30.30.30 34 encapsulation mpls
                    !
                    interface FastEthernet0/0.35
                    encapsulation dot1Q 35
                    ip vrf forwarding two
                    ip address 192.168.35.1 255.255.255.252
                    !
                    interface FastEthernet0/1
                    ip address 172.18.19.1 255.255.255.252
                    ip router isis
                    duplex auto
                    speed auto
                    mpls ip
                    !
                    router isis
                    net 49.0001.0000.0000.000a.00
                    !
                    router bgp 64513
                    no synchronization
                    bgp log-neighbor-changes
                    neighbor 30.30.30.30 remote-as 64513
                    neighbor 30.30.30.30 update-source Loopback10
                    no auto-summary
                    !
                    address-family vpnv4
                    neighbor 30.30.30.30 activate
                    neighbor 30.30.30.30 send-community extended
                    exit-address-family
                    !
                    address-family ipv4 vrf two
                    redistribute connected metric 100
                    no synchronization
                    exit-address-family
                    !
                    !
                    no ip http server
                    no ip http secure-server

                    R3#show ip int bri
                    Interface                  IP-Address      OK? Method Status                Protocol
                    FastEthernet0/0            172.18.19.5     YES NVRAM  up                    up
                    FastEthernet0/1            172.18.19.2     YES NVRAM  up                    up
                    Loopback20                 20.20.20.20     YES NVRAM  up                    up
                    R3#sh run
                    Building configuration...

                    Current configuration : 798 bytes
                    !
                    version 12.4
                    service timestamps debug datetime msec
                    service timestamps log datetime msec
                    no service password-encryption
                    !
                    hostname R3
                    !

                     

                    ip cef
                    !
                    interface Loopback20
                    ip address 20.20.20.20 255.255.255.255
                    ip router isis
                    !
                    interface FastEthernet0/0
                    ip address 172.18.19.5 255.255.255.252
                    ip router isis
                    duplex auto
                    speed auto
                    mpls ip
                    !
                    interface FastEthernet0/1
                    ip address 172.18.19.2 255.255.255.252
                    ip router isis
                    duplex auto
                    speed auto
                    mpls ip
                    !
                    router isis
                    net 49.0001.0000.0000.000b.00
                    !

                     

                     

                    R4#show ip int brief
                    Interface                  IP-Address      OK? Method Status                Prot                                             ocol
                    FastEthernet0/0            172.18.19.6     YES NVRAM  up                    up                                              
                    FastEthernet0/1            unassigned      YES NVRAM  up                    up                                              
                    FastEthernet0/1.34         unassigned      YES unset  up                    up                                              
                    FastEthernet0/1.36         192.168.36.1    YES NVRAM  up                    up                                              
                    Loopback30                 30.30.30.30     YES NVRAM  up                    up                                              
                    R4#sh
                    R4#show  run
                    Building configuration...


                    ip vrf two
                    rd 64513:2
                    route-target export 64513:2
                    route-target import 64513:2
                    !
                    interface Loopback30
                    ip address 30.30.30.30 255.255.255.255
                    ip router isis
                    !
                    interface FastEthernet0/0
                    ip address 172.18.19.6 255.255.255.252
                    ip router isis
                    duplex auto
                    speed auto
                    mpls ip
                    !
                    interface FastEthernet0/1
                    no ip address
                    duplex auto
                    speed auto
                    !
                    interface FastEthernet0/1.34
                    encapsulation dot1Q 34
                    no cdp enable
                    xconnect 10.10.10.10 34 encapsulation mpls
                    !
                    interface FastEthernet0/1.36
                    encapsulation dot1Q 36
                    ip vrf forwarding two
                    ip address 192.168.36.1 255.255.255.252
                    !
                    router isis
                    net 49.0001.0000.0000.000c.00
                    !
                    router bgp 64513
                    no synchronization
                    bgp log-neighbor-changes
                    neighbor 10.10.10.10 remote-as 64513
                    neighbor 10.10.10.10 update-source Loopback30
                    no auto-summary
                    !
                    address-family vpnv4
                    neighbor 10.10.10.10 activate
                    neighbor 10.10.10.10 send-community extended
                    exit-address-family
                    !
                    address-family ipv4 vrf two
                    redistribute connected metric 100
                    no synchronization
                    exit-address-family
                    !
                    !

                     

                    Host-RTR-5#sh ip int bri
                    Interface                  IP-Address      OK? Method Status                Protocol
                    FastEthernet0/0            unassigned      YES NVRAM  administratively down down
                    FastEthernet0/1            unassigned      YES NVRAM  up                    up
                    FastEthernet0/1.34         192.168.34.2    YES NVRAM  up                    up
                    FastEthernet0/1.36         192.168.36.2    YES NVRAM  up                    up

                    Host-RTR-5#sh
                    Host-RTR-5#show  run
                    Building configuration...

                    Current configuration : 751 bytes
                    !
                    version 12.3
                    service timestamps debug datetime msec
                    service timestamps log datetime msec
                    no service password-encryption
                    !
                    hostname Host-RTR-5

                     

                    interface FastEthernet0/0
                    no ip address
                    shutdown
                    duplex auto
                    speed auto
                    !
                    interface FastEthernet0/1
                    no ip address
                    duplex auto
                    speed auto
                    !
                    interface FastEthernet0/1.34
                    encapsulation dot1Q 34
                    ip address 192.168.34.2 255.255.255.252
                    !
                    interface FastEthernet0/1.36
                    encapsulation dot1Q 36
                    ip address 192.168.36.2 255.255.255.252
                    !
                    ip http server
                    ip classless
                    ip route 192.168.35.0 255.255.255.252 192.168.36.1
                    !

                     

                    Dear Sid please work on it and enjoy.

                    • 8. Re: how ...mpls and vpn on gns3
                      Conwyn

                      Hi Sid

                       

                      Lots of posts here but nothing from you.

                       

                      Regards Conwyn

                      • 9. Re: how ...mpls and vpn on gns3
                        sid

                        thanks arshad it clear the concept in simple.

                        • 10. Re: how ...mpls and vpn on gns3
                          sid

                          hi conwyn in  future i will post as well.....i am not much familiar with NLP links and all this links of this ..... i am learning then we will share more...thanks