9 Replies Latest reply: Mar 2, 2011 4:33 PM by YapChinHoong RSS

    RIB-Failure?

    Walid

      bgp.png

      Why some routes apear as rib-failure in the sh ip bgo of SanJose1 and SanJose2??


      SanJose1#sh ip bgp

      BGP table version is 6, local router ID is 172.16.64.1

      Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

                    r RIB-failure, S Stale

      Origin codes: i - IGP, e - EGP, ? - incomplete

       

         Network                Next Hop            Metric     LocPrf    Weight Path

      * i172.16.0.0             172.16.32.1             0         100              0   i

      *>                             0.0.0.0                   0                       32768 i

      * i192.168.1.0/30       172.16.32.1             0         100              0  200 i

      *>                            192.168.1.5             0                             0   200 i

      r i192.168.1.4/30       172.16.32.1             0         100              0    200 i

      r>                            192.168.1.5             0                             0   200 i

      * i192.168.100.0        172.16.32.1             0         100               0 200 i

      *>                            192.168.1.5             0                              0 200 i

       

      SanJose2#sh ip bgp

      BGP table version is 6, local router ID is 172.16.32.1

      Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

                    r RIB-failure, S Stale

      Origin codes: i - IGP, e - EGP, ? - incomplete

       

         Network             Next Hop            Metric  LocPrf  Weight Path

      * i172.16.0.0         172.16.64.1              0    100               0 i

      *>                         0.0.0.0                    0                 32768 i

      r i192.168.1.0/30   172.16.64.1              0    100              0 200 i

      r>                        192.168.1.1              0                       0 200 i

      * i192.168.1.4/30   172.16.64.1              0    100             0 200 i

      *>                        192.168.1.1              0                      0 200 i

      * i192.168.100.0    172.16.64.1              0    100             0 200 i

      *>                         192.168.1.1             0                      0 200 i

       

       

      ISP sh run:

      interface Loopback0

      ip address 192.168.100.1 255.255.255.0

      !

      interface Serial0/0

      ip address 192.168.1.5 255.255.255.252

      clock rate 128000

      !

      router bgp 200

      no synchronization

      bgp log-neighbor-changes

      network 192.168.1.0 mask 255.255.255.252

      network 192.168.1.4 mask 255.255.255.252

      network 192.168.100.0

      neighbor 192.168.1.2 remote-as 64512

      neighbor 192.168.1.6 remote-as 64512

      no auto-summary

      !

       

      SanJose1 sh run:

       

       

       

      interface Loopback0

      ip address 172.16.64.1 255.255.255.0

      !

      interface Serial0/0

      ip address 192.168.1.6 255.255.255.252

      clock rate 2000000

      !

      interface Serial0/1

      ip address 172.16.1.1 255.255.255.0

      clock rate 128000

      !

      router eigrp 64512

      network 172.16.0.0

      no auto-summary

      !

      router bgp 64512

      no synchronization

      bgp log-neighbor-changes

      network 172.16.0.0

      neighbor 172.16.32.1 remote-as 64512

      neighbor 172.16.32.1 update-source Loopback0

      neighbor 172.16.32.1 next-hop-self

      neighbor 192.168.1.5 remote-as 200

      no auto-summary

      !

      ip route 172.16.0.0 255.255.0.0 Null0

      !

       

      SanJose2 sh run:

       

      interface Loopback0

      ip address 172.16.32.1 255.255.255.0

      !

      interface Serial0/0

      ip address 192.168.1.2 255.255.255.252

      clock rate 128000

      !

      interface Serial0/1

      ip address 172.16.1.2 255.255.255.0

      clock rate 128000

      !

      router eigrp 64512

      network 172.16.0.0

      no auto-summary

      !

      router bgp 64512

      no synchronization

      bgp log-neighbor-changes

      network 172.16.0.0

      neighbor 172.16.64.1 remote-as 64512

      neighbor 172.16.64.1 update-source Loopback0

      neighbor 172.16.64.1 next-hop-self

      neighbor 192.168.1.1 remote-as 200

      no auto-summary

      !

      ip route 172.16.0.0 255.255.0.0 Null0

      !

        • 1. Re: RIB-Failure?
          Brandon Carroll - CCIE (Security)

          A rib failure usually means that the route has entered the routing table via another source.  If you do a show ip route on the SanJose1 router where did the router learn the 192.168.100.0 route?

          • 2. Re: RIB-Failure?
            Brandon Carroll - CCIE (Security)

            And just to add to that, the rib failure indicates that some other source had a better administrative distance.

             

            HTH

             

            Brandon

            • 3. Re: RIB-Failure?
              Walid

              I know that the rib failure indicates that some other source had a better administrative distance, but i need to know why exactly it happened in this case.

               

              SanJose1#sh ip route

              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                     E1 - OSPF external type 1, E2 - OSPF external type 2

                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                     o - ODR, P - periodic downloaded static route

               

              Gateway of last resort is not set

               

                   172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks

              D       172.16.32.0/24 [90/2297856] via 172.16.1.2, 00:01:05, Serial0/1

              S       172.16.0.0/16 is directly connected, Null0

              C       172.16.1.0/24 is directly connected, Serial0/1

              C       172.16.64.0/24 is directly connected, Loopback0

                   192.168.1.0/30 is subnetted, 2 subnets

              B       192.168.1.0 [20/0] via 192.168.1.5, 00:00:05

              C       192.168.1.4 is directly connected, Serial0/0

              B    192.168.100.0/24 [20/0] via 192.168.1.5, 00:00:05

               

              SanJose2#sh ip route

              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

                     E1 - OSPF external type 1, E2 - OSPF external type 2

                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

                     ia - IS-IS inter area, * - candidate default, U - per-user static route

                     o - ODR, P - periodic downloaded static route

               

              Gateway of last resort is not set

               

                   172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks

              C       172.16.32.0/24 is directly connected, Loopback0

              S       172.16.0.0/16 is directly connected, Null0

              C       172.16.1.0/24 is directly connected, Serial0/1

              D       172.16.64.0/24 [90/2297856] via 172.16.1.1, 00:03:59, Serial0/1

                   192.168.1.0/30 is subnetted, 2 subnets

              C       192.168.1.0 is directly connected, Serial0/0

              B       192.168.1.4 [20/0] via 192.168.1.1, 00:02:59

              B    192.168.100.0/24 [20/0] via 192.168.1.1, 00:02:59

              • 4. Re: RIB-Failure?
                Babatunde

                Do a "Sho ip rou "prefix showing as rib"

                 

                example on SANJOSE 1:  SanJose1#Sho ip rou 192.168.1.4

                 

                this will tell you how the router knows about the prefix.  Then review your route source metric table. connected = 0, static = 1, Eigrp = 90, ext EIgrp = 170 you know the rest of the story.  That will tell you why the result of the command above is prefered.  Assuming you also remember that the router will always prefer lower admin distance except you the adminitrator alter it.

                • 5. Re: RIB-Failure?
                  sreenivas_naidu

                  Walid,

                  Try "show ip bgp rib-failure" to identify what is the cause of the rib failure.

                  Most  possibly due to to route introduced by another soure having a lower admin distance like Brandon Carroll has suggested.

                   

                  HTH

                  • 6. Re: RIB-Failure?
                    Walid

                    The 192.168.1.0 is appearing as "r" at SanJose 2 sh ip bgp, with SanJose2 directly connected to 192.168.1.0.

                     

                    The 192.168.1.4 is appearing as "r" at SanJose 1 sh ip bgp, with SanJose1 directly connected to 192.168.1.4.

                     

                    connected AD=0< eBGP AD=20.

                     

                    Is this the reason??

                    • 7. Re: RIB-Failure?
                      sreenivas_naidu

                      Walid,

                       

                      Please check the ISP router config,

                      The BGP configuration statements:

                      router bgp 200
                      no synchronization
                      bgp log-neighbor-changes

                      network 192.168.1.0 mask 255.255.255.252
                      network 192.168.1.4 mask 255.255.255.252

                      network 192.168.100.0
                      neighbor 192.168.1.2 remote-as 64512
                      neighbor 192.168.1.6 remote-as 64512
                      no auto-summary

                      Is there any particular reason you want to advertise these networks into BGP?

                      Since they have been advertised into bgp the SanJose1 & SanJose2 receive the route with an AD of 20,additionally since they are directly connected networks to SanJose1 & SanJose2 its already in the routing table with an AD 0, hence you see the rib failure on SanJose1 & SanJose2.

                       

                      HTH

                       

                       

                      Sreeni

                      • 8. Re: RIB-Failure?
                        Walid

                        I was advertising both networks as patr of the lab scenario, but now i removed both of them and rib failure is gone.

                        Thanks a lot.

                        • 9. Re: RIB-Failure?
                          YapChinHoong

                          You may be interested about suppressing RIB-failure routes as well. Thanks.

                          http://www.itcertnotes.com/2011/02/suppressing-inactive-bgp-route.html