4 Replies Latest reply: Feb 6, 2011 7:12 PM by Scott Morris - CCDE/4xCCIE/2xJNCIE RSS

    Frame relay: IPv4 vs IPv6

    Trony

      I know this is simple but I can't figure this out.  I have the same configuration with IPv4 and IPv6 in regards to the frame relay setup but I CAN'T ping R3 <--> R2 using IPv6 but I can via IPv4.  It could be my config but I could be wrong or it might be how IPv6 behaves but at the moment I can't see why.

       

      Configs below.

       

      Thanks in advance.

       

      print.png

       

      R1#show run int s0/0

      Building configuration...

       

       

      Current configuration : 335 bytes

      !

      interface Serial0/0

      ip address 172.16.123.1 255.255.255.0

      encapsulation frame-relay

      ipv6 address FEC0::123:1/120

      ipv6 enable

      serial restart-delay 0

      frame-relay map ipv6 FEC0::123:2 102

      frame-relay map ipv6 FEC0::123:3 103

      frame-relay map ip 172.16.123.2 102

      frame-relay map ip 172.16.123.3 103

      no frame-relay inverse-arp

      end

       

       

      R1#

       

       

       

       

      R2#show run int s0/0

      Building configuration...

       

       

      Current configuration : 335 bytes

      !

      interface Serial0/0

      ip address 172.16.123.2 255.255.255.0

      encapsulation frame-relay

      ipv6 address FEC0::123:2/120

      ipv6 enable

      serial restart-delay 0

      frame-relay map ipv6 FEC0::123:1 201

      frame-relay map ipv6 FEC0::123:3 201

      frame-relay map ip 172.16.123.1 201

      frame-relay map ip 172.16.123.3 201

      no frame-relay inverse-arp

      end

       

       

      R2#

       

       

      R3#show run int s0/0

      Building configuration...

       

       

      Current configuration : 335 bytes

      !

      interface Serial0/0

      ip address 172.16.123.3 255.255.255.0

      encapsulation frame-relay

      ipv6 address FEC0::123:3/120

      ipv6 enable

      serial restart-delay 0

      frame-relay map ipv6 FEC0::123:1 301

      frame-relay map ipv6 FEC0::123:2 301

      frame-relay map ip 172.16.123.1 301

      frame-relay map ip 172.16.123.2 301

      no frame-relay inverse-arp

      end

       

       

      R3#

        • 1. Re: Frame relay: IPv4 vs IPv6
          tnewshott

          With IPv6 on Frame relay, you'll need two mappings.  Both for the link-local IPv6 address, as well as the next-hop IP. 

           

          Also, did you enable ipv6 routing on your devices?

          • 2. Re: Frame relay: IPv4 vs IPv6
            Trony

            Hi Travis.  First thing I did was enable IPv6 routing and that did the trick.  I guess just like IPv4, its automatically presumed IPv6 routing is turned on.  Well, now its stuck in my head regarding that.

             

            Thanks for your help!!!

            • 3. Re: Frame relay: IPv4 vs IPv6
              Conwyn

              Hi Trony

               

              Travis may be speaking of something specific to your setup but below only has a single map.

               

              Regards Conwyn

               

               

              interface Serial0/0

              no ip address

              encapsulation frame-relay

              ipv6 address 2001:DB8:AAAA::1/64

              ipv6 address my-prefix 2001:DB8:0:7272::72/64

              ipv6 rip cisco enable

              clock rate 64000

              cdp enable

              frame-relay map ipv6 2001:DB8:AAAA::2 16

              frame-relay interface-dlci 16

              frame-relay intf-type dce

               

              Frame#show cdp entry * pro

              Protocol information for Spoke :

                IPv6 address: 2001:DB8:AAAA::2  (global unicast)

                IPv6 address: FE80::C201:1EFF:FEC8:0  (link-local)

              • 4. Re: Frame relay: IPv4 vs IPv6
                Scott Morris - CCDE/4xCCIE/2xJNCIE

                One neat thing to think about (other than the parts that you have already discovered here!) is that you can use "debug ipv6 packet" very much like you do "debug ip packet" so you can receive those exciting messages about "encapsulation failed", which will at least lead you towards a mapping issue!

                 

                HTH,

                 

                Scott