1 2 Previous Next 22 Replies Latest reply: Apr 2, 2015 2:15 PM by npad002 RSS

    mpls ospf pe-ce vrf

    ASHABU

      Did anyone come across the error message (%VRF specified does not match existing route)
      im trying to configure mpls-vpn, im running ospf 1 in the mpls cloud, and between the PE and CE I want to run :
      router ospf 2 vrf test 
      but I keep getting the message (
      %VRF specified does not match existing route)
      note: the vrf test is already configured
      and ospf 1 is the only ospf process running in the router

      any ideas?????

        • 1. Re: mpls ospf pe-ce vrf
          Conwyn

          Hi Ashabu

           

          show ip protocols

           

          Regards Conwyn

          • 2. Re: mpls ospf pe-ce vrf
            ASHABU

            R4#SHOW IP PROtocols
            Routing Protocol is "ospf 1"
              Outgoing update filter list for all interfaces is not set
              Incoming update filter list for all interfaces is not set
              Router ID 4.4.4.4
              Number of areas in this router is 1. 1 normal 0 stub 0 nssa
              Maximum path: 4
              Routing for Networks:
                4.4.4.4 0.0.0.0 area 0
                125.25.80.0 0.0.0.255 area 0
            Reference bandwidth unit is 100 mbps
              Routing Information Sources:
                Gateway         Distance      Last Update
                2.2.2.2              110      06:45:25
                1.1.1.1              110      06:45:25
              Distance: (default is 110)

             

             

             

             

             

            show run

             

            !
            hostname R4
            !
            boot-start-marker
            boot-end-marker
            !
            !
            no aaa new-model
            memory-size iomem 5
            ip cef
            !
            !
            !
            !
            ip vrf ASH
            !
            ip vrf CISNET
            rd 100:10
            route-target export 400:40
            route-target import 100:10
            !
            no ip domain lookup
            !
            !
            interface Loopback4
            ip address 4.4.4.4 255.255.255.255
            !
            interface FastEthernet0/0
            ip address 125.25.80.4 255.255.255.0
            duplex auto
            speed auto
            mpls label protocol ldp
            mpls ip
            !
            interface FastEthernet0/1
            ip vrf forwarding CISNET
            ip address 125.25.46.4 255.255.255.0
            duplex auto
            speed auto
            !
            !
            router ospf 1
            log-adjacency-changes
            network 4.4.4.4 0.0.0.0 area 0
            network 125.25.80.0 0.0.0.255 area 0
            !
            !
            !
            no ip http server
            no ip http secure-server
            !
            !
            !
            mpls ldp router-id Loopback4 force
            !
            !
            control-plane
            !
            !
            line con 0
            exec-timeout 0 0
            logging synchronous
            line aux 0
            line vty 0 4
            login
            !
            !
            end

             

            Message was edited by: ASHABU

            • 3. Re: mpls ospf pe-ce vrf
              Conwyn

              Hi Ashabu

               

              Where is vrf test?

               

              Regards Conwyn

              • 4. Re: mpls ospf pe-ce vrf
                ASHABU

                sorry about that

                 

                this is a new configs, i just removed vrf test and used CISNET instead just to see it  will work..i still get the same message

                 

                R4(config)#ROUteR OS
                R4(config)#ROUteR OSpf 2 VR
                R4(config)#ROUteR OSpf 2 VRf CISNET
                %VRF specified does not match this router

                 

                Message was edited by: ASHABU

                • 5. Re: mpls ospf pe-ce vrf
                  Conwyn

                  Hi Ashabu

                   

                  Can you try this

                   

                  Regards Conwyn

                   

                  ip vrf FIRST

                  rd 10:10

                  route-target export 100:100

                  !       

                  ip vrf SECOND

                  rd 20:20

                  route-target export 200:200

                  !       

                  interface FastEthernet0/0.100

                  encapsulation dot1Q 100

                  ip vrf forwarding FIRST

                  ip address 10.0.100.1 255.255.255.252

                  !       

                  interface FastEthernet0/0.200

                  encapsulation dot1Q 200

                  ip vrf forwarding SECOND

                  ip address 10.0.200.1 255.255.255.252

                   

                  !       

                  router ospf 100 vrf FIRST

                  router-id 100.100.100.100

                  log-adjacency-changes

                  !       

                  router ospf 200 vrf SECOND

                  router-id 200.200.200.200

                  log-adjacency-changes

                  !       

                   

                   

                  ip vrf FIRST
                  rd 10:10
                  route-target export 100:100
                  !       
                  ip vrf SECOND
                  rd 20:20
                  route-target export 200:200
                  !       
                  interface FastEthernet0/0.100
                  encapsulation dot1Q 100
                  ip vrf forwarding FIRST
                  ip address 10.0.100.1 255.255.255.252
                  !       
                  interface FastEthernet0/0.200
                  encapsulation dot1Q 200
                  ip vrf forwarding SECOND
                  ip address 10.0.200.1 255.255.255.252
                  !       
                  router ospf 100 vrf FIRST
                  router-id 100.100.100.100
                  log-adjacency-changes
                  !       
                  router ospf 200 vrf SECOND
                  router-id 200.200.200.200
                  log-adjacency-changes
                  !       
                  • 6. Re: mpls ospf pe-ce vrf
                    ASHABU

                    hi agin
                    i did what u ask for..im still geting that messge

                     

                     

                     

                    R4(config)#ROUTeR OSpf 100 VRf FIRST

                     

                    %VRF specified does not match this router

                     

                    R4(config)#ROUteR OSPf 200 VRf SECOND

                     

                    %VRF specified does not match this router

                     

                     

                    !

                     

                    version 12.4

                     

                    service timestamps debug datetime msec

                     

                    service timestamps log datetime msec

                     

                    no service password-encryption

                     

                    !

                     

                    hostname R4

                     

                     

                     

                    ip vrf ASH

                     

                    !

                     

                    ip vrf CISNET

                     

                    rd 100:10

                     

                    route-target export 400:40

                     

                    route-target import 100:10

                     

                    !

                     

                    ip vrf FIRST

                     

                    rd 10:10

                     

                    route-target export 100:100

                     

                    !

                     

                    ip vrf SECOND

                     

                    rd 20:20

                     

                    route-target export 200:200

                     

                    !

                     

                    no ip domain lookup

                     

                    !

                     

                     

                    interface Loopback4

                     

                    ip address 4.4.4.4 255.255.255.255

                     

                    !

                     

                    interface FastEthernet0/0

                     

                    ip address 125.25.80.4 255.255.255.0

                     

                    duplex auto

                     

                    speed auto

                     

                    mpls label protocol ldp

                     

                    mpls ip

                     

                    !

                     

                    interface FastEthernet0/1

                     

                    no ip address

                     

                    duplex auto

                     

                    speed auto

                     

                    !

                     

                    interface FastEthernet0/1.100

                     

                    encapsulation dot1Q 100

                     

                    ip vrf forwarding FIRST

                     

                    ip address 10.0.100.1 255.255.255.252

                     

                    !

                     

                    interface FastEthernet0/1.200

                     

                    encapsulation dot1Q 200

                     

                    ip vrf forwarding SECOND

                     

                    ip address 10.0.200.1 255.255.255.252

                     

                    !

                     

                     

                    router ospf 1

                     

                    log-adjacency-changes

                     

                    network 4.4.4.4 0.0.0.0 area 0

                     

                    network 125.25.80.0 0.0.0.255 area 0

                     

                    !

                     

                     

                    no ip http server

                     

                    no ip http secure-server

                     

                    !

                     

                    mpls ldp router-id Loopback4 force

                    • 7. Re: mpls ospf pe-ce vrf
                      Keith Barker - CCIE RS/Security, CISSP

                      At least the error message is different than before. 

                       

                      Seriously though, I loaded your exact configs, and did NOT get the errors you are getting.   It must be platform and/or IOS specific.

                       

                      You may want to look for it in the bug tracker, based on the exact version you are running and on the specific router that is running it.

                       

                      Best wishes,

                       

                      Keith

                      • 8. Re: mpls ospf pe-ce vrf
                        Conwyn

                        Hi Keith

                         

                        That is was I thinking because I could not re-create it.

                         

                        Regards Conwyn

                        • 9. Re: mpls ospf pe-ce vrf
                          ASHABU

                          thanks guys..and sorry i did not reply faster

                          I tried to use different image and platform but I get the same result, one thing I forget to mention is that im using GNS3, so I think it’s a GNS issue, so I will try it do this lab using real router I should it will work fine there..

                          Agai,n thank for the help

                          • 10. Re: mpls ospf pe-ce vrf
                            Keith Barker - CCIE RS/Security, CISSP

                            I labbed this up in GNS3, and didn't have the same issue.

                             

                            What version of IOS is running?    Can you post the results of show version?

                             

                            Keith

                            • 11. Re: mpls ospf pe-ce vrf
                              ASHABU

                              im using gns3 0.7.3

                               

                              R4>SHOW VERsion
                              Cisco IOS Software, 2600 Software (C2691-ADVENTERPRISEK9_SNA-M), Version 12.4(13                                                                             b), RELEASE SOFTWARE (fc3)
                              Technical Support: http://www.cisco.com/techsupport
                              Copyright (c) 1986-2007 by Cisco Systems, Inc.
                              Compiled Tue 24-Apr-07 15:33 by prod_rel_team

                               

                              ROM: ROMMON Emulation Microcode
                              ROM: 2600 Software (C2691-ADVENTERPRISEK9_SNA-M), Version 12.4(13b), RELEASE SOF                                                                             TWARE (fc3)

                               

                              R4 uptime is 1 minute
                              System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0                                                                             x0, BOOT_COUNT 0, BOOTDATA 19
                              System image file is "tftp://255.255.255.255/unknown"

                               


                              This product contains cryptographic features and is subject to United
                              States and local country laws governing import, export, transfer and
                              use. Delivery of Cisco cryptographic products does not imply
                              third-party authority to import, export, distribute or use encryption.
                              Importers, exporters, distributors and users are responsible for
                              compliance with U.S. and local country laws. By using this product you
                              agree to comply with applicable laws and regulations. If you are unable
                              to comply with U.S. and local laws, return this product immediately.

                               

                              A summary of U.S. laws governing Cisco cryptographic products may be found at:
                              http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

                               

                              If you require further assistance please contact us by sending email to
                              export@cisco.com.

                               

                              Cisco 2691 (R7000) processor (revision 0.1) with 124928K/6144K bytes of memory.
                              Processor board ID XXXXXXXXXXX
                              R7000 CPU at 160MHz, Implementation 39, Rev 2.1, 256KB L2, 512KB L3 Cache
                              2 FastEthernet interfaces
                              DRAM configuration is 64 bits wide with parity enabled.
                              55K bytes of NVRAM.
                              16384K bytes of ATA System CompactFlash (Read/Write)

                               

                              Configuration register is 0x2102

                               

                              R4(config)#DO SHOW RUN

                              Building configuration...

                               

                              Current configuration : 1020 bytes

                              !

                              version 12.4

                              service timestamps debug datetime msec

                              service timestamps log datetime msec

                              no service password-encryption

                              !

                              hostname R4

                              !

                              boot-start-marker

                              boot-end-marker

                              !

                              !

                              no aaa new-model

                              memory-size iomem 5

                              ip cef

                              !

                              !

                              !

                              !

                              ip vrf ASH

                              !

                              ip vrf CISNET

                              rd 100:10

                              route-target export 400:40

                              route-target import 100:10

                              !

                              no ip domain lookup

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              interface Loopback4

                              ip address 4.4.4.4 255.255.255.255

                              !

                              interface FastEthernet0/0

                              ip address 125.25.80.4 255.255.255.0

                              duplex auto

                              speed auto

                              mpls label protocol ldp

                              mpls ip

                              !

                              interface FastEthernet0/1

                              ip vrf forwarding CISNET

                              ip address 125.25.46.4 255.255.255.0

                              duplex auto

                              speed auto

                              !

                              !

                              router ospf 1

                              log-adjacency-changes

                              network 4.4.4.4 0.0.0.0 area 0

                              network 125.25.80.0 0.0.0.255 area 0

                              !

                              !

                              !

                              no ip http server

                              no ip http secure-server

                              !

                              !

                              !

                              mpls ldp router-id Loopback4 force

                              !

                              !

                              control-plane

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              !

                              line con 0

                              exec-timeout 0 0

                              logging synchronous

                              line aux 0

                              line vty 0 4

                              login

                              !

                              !

                              end

                               

                              R4(config)#

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                              MPLS D.PNG

                              i also tried to use another version :

                               

                              R4#SHOW VERsion
                              Cisco Internetwork Operating System Software
                              IOS (tm) C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.3(26), RELEASE SOF                                                                             TWARE (fc2)
                              Technical Support: http://www.cisco.com/techsupport
                              Copyright (c) 1986-2008 by cisco Systems, Inc.
                              Compiled Mon 17-Mar-08 15:23 by dchih

                               

                              ROM: ROMMON Emulation Microcode
                              ROM: C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.3(26), RELEASE SOFTWAR                                                                             E (fc2)

                               

                              R4 uptime is 1 minute
                              System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0                                                                             x0, BOOT_COUNT 0, BOOTDATA 19
                              System image file is "tftp://255.255.255.255/unknown"

                               


                              This product contains cryptographic features and is subject to United
                              States and local country laws governing import, export, transfer and
                              use. Delivery of Cisco cryptographic products does not imply
                              third-party authority to import, export, distribute or use encryption.
                              Importers, exporters, distributors and users are responsible for
                              compliance with U.S. and local country laws. By using this product you
                              agree to comply with applicable laws and regulations. If you are unable
                              to comply with U.S. and local laws, return this product immediately.

                               

                              A summary of U.S. laws governing Cisco cryptographic products may be found at:
                              http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

                               

                              If you require further assistance please contact us by sending email to
                              export@cisco.com.

                               

                              cisco 2621 (MPC860) processor (revision 0x202) with 111616K/19456K bytes of memory.
                              Processor board ID 00000000000 (1880125456)
                              M860 processor: part number 0, mask 0
                              Bridging software.
                              X.25 software, Version 3.0.0.
                              SuperLAT software (copyright 1990 by Meridian Technology Corp).
                              TN3270 Emulation software.
                              2 FastEthernet/IEEE 802.3 interface(s)
                              128K bytes of non-volatile configuration memory.
                              8192K bytes of processor board System flash (Read/Write)

                               

                              Configuration register is 0x2102

                               

                              R4#
                              *Mar  1 00:01:11.715: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
                              R4#

                              • 12. Re: mpls ospf pe-ce vrf
                                Keith Barker - CCIE RS/Security, CISSP

                                I used the 3700 IOS, and it worked fine.

                                 

                                You may want to try that flavor.

                                 

                                Keith

                                • 13. Re: mpls ospf pe-ce vrf
                                  Conwyn

                                  Hi Keith

                                   

                                  C2600 Software (C2600-I-M), Version 12.2(7) also OK

                                   

                                  Regards Conwyn

                                  • 14. Re: mpls ospf pe-ce vrf
                                    ASHABU

                                    Hi guys

                                    Ok..please look to the diagram and tell me if there is a any difference between the 2 lines. The first time I was applying vrf to ospf 2 with the caps look on (plus using the tap key), it did not take it, the second time the caps look is off and it did take it. Does that make sense   to you? Since when there is a difference between using small letters and capital letters?  Capture.PNG

                                    1 2 Previous Next