8 Replies Latest reply: Nov 17, 2010 5:58 PM by jaadam1977 RSS

    Voice lab in Packet tracer?

    simplyccna

      Hi friends

       

      I want to make an voice lab but cant figure it out how...can u pls share urs one basic and one advance lab with me?

       

       

      Thanks++

        • 1. Re: Voice lab in Packet tracer?
          Martin

          1. Drag 2811 router, switch, 5 pcs ( will use CIPC on PCs, not IPphones)

           

          copy this:

          !
          version 12.4
          no service timestamps log datetime msec
          no service timestamps debug datetime msec
          no service password-encryption
          !
          hostname Router
          !
          ip dhcp excluded-address 192.168.0.1 192.168.0.5
          !
          ip dhcp pool IPPHONES
           network 192.168.0.0 255.255.255.0
           default-router 192.168.0.1
           option 150 ip 192.168.0.1
           dns-server 192.168.0.2
          clock timezone CST 0
          !
          !
          !
          !
          !
          !
          interface FastEthernet0/0
           ip address 192.168.0.1 255.255.255.0
           duplex auto
           speed auto
          !
          interface FastEthernet0/1
           no ip address
           duplex auto
           speed auto
           shutdown
          !
          interface Vlan1
           no ip address
           shutdown
          !
          router rip
          !
          ip classless
          !
          !
          telephony-service
           max-ephones 25
           max-dn 50
           ip source-address 192.168.0.1 port 2000
           auto assign 3 to 25
          !
          ephone-dn 1
           number 4000
          !
          ephone-dn 5
           number 4005
          !
          ephone-dn 2
           number 4002
          !
          ephone-dn 3
           number 4003
          !
          ephone-dn 4
           number 4004
          !
          ephone-dn 6
           number 4006
          !
          ephone-dn 7
           number 4007
          !
          ephone-dn 8
           number 4008
          !
          ephone-dn 9
           number 4009
          !
          ephone-dn 10
           number 4010
          !
          ephone-dn 11
           number 4011
           !
          !
          line con 0
          line vty 0 4
           login
          !
          !
          !
          end
          
          
          
          

           

           

          I created 11 numbers but only 3 to 25 will be auto assigned to phones.

           

          Configure PCs to get IP from DHCP on router, not static ip ( on Pc select IP configuration and then click on DHCP radio )

           

          You should  see messeage on router :

          %IPPHONE-6-REGISTER: ephone-4 IP:192.168.0.100 Socket:2 DeviceType:Phone has registered.

           

          and do sh run to see phones registered under ephone 1 (with MAC, button #s, etc). Alternatively, you could set phones manually.
          device-security-mode none
          mac-address 0001.C723.289B
          type CIPC
          button 1:3

          • 2. Re: Voice lab in Packet tracer?
            simplyccna

            Thanks Martin

             

            Can you pls share yours packet tracer lab with iam not able understand how to add CIPC module in pc.

             

            Ty

            • 3. Re: Voice lab in Packet tracer?
              Martin

              I will upload it later,  CIPC is already in PCs, no need to do anything.

              did you try it?

              • 4. Re: Voice lab in Packet tracer?
                Rickey

                I use packet tracer for a CCNA voice class I teach.  You can do 70% of the stuff that you need to know in it.  I do not believe in 5.3 you can do dial peers or preferences or other DN priority stuff.  But with each release packet tracer is getting better and better!

                • 5. Re: Voice lab in Packet tracer?
                  simplyccna

                  Hi Rickey

                   

                  Can u pls share any of voice lab u have made in PT with me?

                   

                   

                  Thanks

                  • 6. Re: Voice lab in Packet tracer?
                    Rickey

                    I make up my labs as we go that way each time I teach the class it is a little different and doesn't get old for myself.  If I think about it I'll make sure to write them down and toss them to you.

                    • 7. Re: Voice lab in Packet tracer?
                      Martin

                      here it is. My IP phone lab with auto registration for ip phones on PCs (cisco IP communicator ones).

                      The 7960 ip phones do not work there yet. PT 5.3

                      • 8. Re: Voice lab in Packet tracer?
                        jaadam1977

                        Why do they even put the 7960's on the Packet Tracer if you cant get them to pull ip's or register with the CME?