10 Replies Latest reply: Jul 2, 2012 6:44 AM by Aaron Francis RSS

    Difference between Local VLANs and End-to-End VLANs?

    Dada Khalander

      Hi All,

       

      Can you please brief the difference between Local VLANs and End-to-End VLANs? And which is used under what condition/circumstance?

       

       

       

      Thanks & Regards,

      S. Dada Khalander.

        • 1. Re: Difference between Local VLANs and End-to-End VLANs?
          Conwyn

          Hi Dada

           

          I am guessing local vlans are the vlans within a group of connected switches but there is no reason why you can not use fibre optics to connect switches many miles / kilometres apart.

           

          End to End vlans - I guess this is where you have a vlan at one site connected to a vlan at another site. This can be achieved by using frame-relay circuits or QinQ technology or MPLS  if the option above is not available

           

          Regards Conwyn

          • 2. Re: Difference between Local VLANs and End-to-End VLANs?
            Dada Khalander

            Hi Conwyn,

             

            As per your guess, End-to-End VLANS are the vlans which are connected at two different locations using Frame Relay / MPLS etc. But how can i use VTP here to replicate VLAN changes on all switches at two different locations? I believe VTP runs only on Trunk links. We can achieve Inter-vlan communication between the two different locations using a layer 3 device but how can the VLAN replication happens between the two locations?

             

            If the WAN/MAN link does not carry VTP frames, is it mean that the VTP domain is specific to a single site/location? Please advice.

             

             

            Thanks & Regards,

            S. Dada Khalander.

            • 3. Re: Difference between Local VLANs and End-to-End VLANs?
              Conwyn

              Hi Dada

               

              VTP runs at L2. These technologies carry the L2 packets transparently. So VTP would be unaware generally but QinQ requires specific attention to the configuration.  I have run L2  over GRE over PPP over ISDN so you can have physically seperate vlans with VTP.

               

              Regards Conwyn

              • 4. Re: Difference between Local VLANs and End-to-End VLANs?
                Dada Khalander

                Hi Conwyn,

                 

                Thank you very much for your answer. But, how can i run VTP over PPP or ISDN? Does it require any special configuration?

                Is it preferable/advisable to have Inter-VLAN data travel across WAN/MAN links? Or it should be localized to the same location?

                 

                 

                 

                Thanks & Regards,

                S. Dada Khalander.

                • 5. Re: Difference between Local VLANs and End-to-End VLANs?
                  Conwyn

                  Hi Dada

                   

                  You do not. You use them to provide a carrier. For example bridging. This takes the Ethernet packet from one location and takes it to another.

                   

                  Since VTP is an Ethernet packet. It carries the VTP information to the other end.

                   

                  Before IP bridging was the norm for connecting networks together and Cisco still supports it in many ways.

                   

                  Regards Conwyn

                  • 6. Re: Difference between Local VLANs and End-to-End VLANs?
                    Dada Khalander

                    Hi Conwyn,

                     

                    Thanks for the answer. But, as per the documents which i have gone thorugh, a port has to be configured as #switchport mode Trunk to enable a Multi-Vlan traffic on the ethernet connection. But the MAN links are not operating on Trunk mode. Moreover, we configure the switch as #no switchport --- IP address A.B.C.D for Ethernet MAN link connection on both the sides(locations). How does the VTP work now? Please advice. Thanks.

                     

                     

                    Thanks & Regards,

                    S. Dada Khalander.

                    • 7. Re: Difference between Local VLANs and End-to-End VLANs?
                      Conwyn

                      Hi Dada

                       

                      I have never tried this on a switch.

                       

                      bridge irb

                      int port-channel64

                      no ip address

                      interface port-channel64.1

                      encapsulation dot1q 1 native

                      bridge-group 1

                      int fa1/0

                      no switchport

                      no ip address

                      channel-group 64

                      int bvi1

                      ip address A.B.C.D 255.255.255.252

                      bridge 1 protocol ieee

                      bridge 1 route ip

                       

                      This should carry all the native vlan traffic between the two switches over the link. Note that CDP/VTP are technically not in a vlan but it is easier to pretend they are in vlan native.

                       

                      If you only want VTP/CDP traffic then put a ACL on the interface. If you want multiple vlans you will have to replicate all the "1"s

                       

                      Regards Conwyn

                       

                      Extracted from http://www.cisco.com/en/US/products/hw/switches/ps607/products_configuration_example09186a008014c203.shtml

                      • 8. Re: Difference between Local VLANs and End-to-End VLANs?
                        Conwyn

                        Hi Dada

                         

                        I took a 2691 with a switch module NM-ESW  and defined fa1/0 as a trunk

                        I connected this to a 7200 and put bridging on fa0/1

                        I connected using fa0/0 to second 7200 fa0/0 and defined a port channel with BVI between them.

                        I connected the second 7200 fa0/1 to the second 2691.

                        I ran VTP on both 2691 as VTP masters and vlans were replicated quite happily.

                        So I think your switch configuration should work but remember you are joining the vlans together.

                         

                        Regards Conwyn

                         

                        SWITCHA
                        !
                        interface FastEthernet1/0
                        switchport mode trunk

                         

                        SWITCHA#show vtp counters
                        VTP statistics:
                        Summary advertisements received    : 6
                        Subset advertisements received     : 5
                        Request advertisements received    : 1
                        Summary advertisements transmitted : 6
                        Subset advertisements transmitted  : 5
                        Request advertisements transmitted : 0

                        !
                        7200A
                        !
                        bridge irb
                        interface Port-channel64
                        no ip address
                        bridge-group 1
                        !
                        interface FastEthernet0/0
                        no ip address
                        duplex full
                        speed 100
                        channel-group 64
                        !        
                        interface FastEthernet0/1
                        no ip address
                        duplex full
                        speed 100
                        bridge-group 1
                        !        
                        interface BVI1
                        ip address 10.0.0.1 255.255.255.252
                        !        
                        bridge 1 protocol ieee
                        bridge 1 route ip

                         

                        7200B
                        !
                        bridge irb
                        !interface Port-channel64
                        no ip address
                        bridge-group 1
                        !
                        interface FastEthernet0/0
                        no ip address
                        duplex full
                        speed 100
                        channel-group 64
                        !
                        interface FastEthernet0/1
                        no ip address
                        duplex full
                        speed 100
                        bridge-group 1
                        !
                        interface BVI1
                        ip address 10.0.0.2 255.255.255.252

                        bridge 1 protocol ieee
                        bridge 1 route ip

                         

                        SWITCHB
                        !
                        interface FastEthernet1/0
                        switchport mode trunk

                         

                        SWITCHB#show vtp counters
                        VTP statistics:
                        Summary advertisements received    : 5
                        Subset advertisements received     : 4
                        Request advertisements received    : 0
                        Summary advertisements transmitted : 7
                        Subset advertisements transmitted  : 5
                        Request advertisements transmitted : 1

                        • 9. Re: Difference between Local VLANs and End-to-End VLANs?
                          Dada Khalander

                          Hi Conwyn,

                           

                          Thank you very much.

                           

                           

                          Thanks & Regards,

                          S. Dada Khalander.

                          • 10. Re: Difference between Local VLANs and End-to-End VLANs?
                            Aaron Francis

                            Umm I figured Id comment here just in case anyone else stopped pulls this up in a Google search. End-to-end VLANS are actually vlans that cross teh enterprise network say frmo closet to closet or building to building...(ex. Vlan 10 exists on 5 or 6 switches spanning numerous closets or buildings). Local VLANs are VLANs that are configured on a per switch basis (possibly a few switches based on geographic location) and DO NOT span across teh network. (ex. Vlan 10-User on sw_1, Vlan11_user on sw_2, Vlan 12_user on sw_3, etc.) The idea is to break up what was once a large vlan into smaller vlan segments for troubleshooting purposes amongst other things.