Skip navigation
Cisco Learning Home > Certifications > Routing & Switching (CCNP) > Discussions

_Communities

5402 Views 8 Replies Latest reply: Sep 6, 2011 10:58 AM by waqas RSS

Currently Being Moderated

VPN configuration example for GNS3 required

Aug 20, 2010 11:11 PM

hi everybody,

 

i needs some  VPN configuration examples  to practice in GNS3.

 

thanks in advance

  • Conwyn 7,907 posts since
    Sep 10, 2008
    Currently Being Moderated
    1. Aug 20, 2010 11:39 PM (in response to Sheju)
    Re: VPN configuration example for GNS3 required

    Hi Sheju

     

    With GNS 0.7 you can try the following.

     

    Two routers connected back to back with a Static Virtual Tunnel Interface.

    You can try we AH only, Static keys, Dynamic keys, and various ESP NULL, ESP DES

     

    Two routers back to back with crypto map and the above options

     

    Two routers back to back and one acting as the certificate server

     

    You can use PIX 8.0 with single and multiple context.  PIX to PIX or PIX to Router

     

    You can use the ASA simulator

     

    You can use DMVPN with a Hub and Spoke over Frame Relay and PPPoE

     

    Many of these are within CLN discussions but if you would like to try them you could publish them on CLN for others to try.

     

    Regards Conwyn

  • Conwyn 7,907 posts since
    Sep 10, 2008
    Currently Being Moderated
    2. Aug 20, 2010 11:41 PM (in response to Sheju)
    Re: VPN configuration example for GNS3 required

    Hi Sheju

     

    And our course you can try MPLS/VPN examples which you will find on CLN.

     

    Paul might have some other ideas for you.

     

    Regards Conwyn

  • Conwyn 7,907 posts since
    Sep 10, 2008
    Currently Being Moderated
    4. Aug 22, 2010 12:33 AM (in response to Sheju)
    Re: VPN configuration example for GNS3 required

    Hi Sheju

     

    Below is an example of using the AUX port on two router. It has a speed of 38K. It uses ESP-NULL so no encryption just authentication. It uses static keys. There is a GRE tunnel over the crypto link so it can carry multicast traffic.

     

    This is an example of the many forms a VPN can take.

     

    Paul ran a weekly Security Discussion a few months ago it might be worth reading those discussions.

     

    Regards Conwyn

     

     

    interface Async65
    ip address 192.168.1.2 255.255.255.0
    encapsulation ppp
    async default routing
    async mode dedicated
    keepalive 5
    crypto map CM

     

    crypto ipsec transform-set T1 esp-null esp-sha-hmac
    !
    crypto map CM 10 ipsec-manual
    set peer 192.168.1.3
    set session-key inbound esp 300 authenticator 9988776655443322110099887766554433221100
    set session-key outbound esp 300 authenticator 9988776655443322110099887766554433221100
    set transform-set T1
    match address 100

     

    !
    router rip
    version 2
    passive-interface Async65
    network 0.0.0.0
    no auto-summary

     

    interface Tunnel0
    ip address 10.0.0.5 255.255.255.252
    tunnel source 192.168.1.2
    tunnel destination 192.168.1.3

     

    access-list 100 permit ip any any

  • Conwyn 7,907 posts since
    Sep 10, 2008
    Currently Being Moderated
    6. Aug 24, 2010 2:13 AM (in response to Sheju)
    Re: VPN configuration example for GNS3 required

    Hi Sheju

     

    Sorry I forgot the GNS requirement. You can use AUX on real routers.

     

    Regards Conwyn

  • waqas 10 posts since
    May 20, 2011
    Currently Being Moderated
    8. Sep 6, 2011 10:58 AM (in response to Sheju)
    Re: VPN configuration example for GNS3 required

    Also chech out my site to site vpn configuration lab on gns3..

    thanks

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)