8 Replies Latest reply: Oct 13, 2010 11:09 AM by hoangsinh RSS

    MPLS TE tunnel

    Karthik Kumar Thatikonda

      Hello,

       

      I trying to configure MPLS TE  on 6500's. I have a layer 3 port channel configured between two  switches. I am bundling two links. I had issues giving this command on a  layer 3 port channel (mpls traffic-eng tunnels). Do I need to use layer  2 port channel instead? That way it allowed me to enable that command  on SVI. I guess, we cannot configure TE tunnel between switches using  different interfaces such as layer 3 port channel. Any suggestions  please post.

       

       

       

      Thanks,

      Karthik

        • 1. Re: MPLS TE tunnel
          Scott Morris - CCDE/4xCCIE/2xJNCIE

          Well, I have to admit that I have never tried to do that...  I'm going to have to wrangle me up a pair of 6500's not in a production network and do some playing around!

           

          My guess (completely off my head here) would be that you're asking the device to do something in software that normally would be ASIC supported and it's not really happy about that.  Which SUP were you using?  Which IOS were you using?

           

          I'd think it WOULD be possible, but perhaps in later IOS versions and/or newer SUPs?  Otherwise, I'd go with L2 LAGs and see what you can scare up that way.

           

          I found some docs talking about load balancing to 8 paths with the 3CBXL, but that appeared to be talking about LSPs, nothing specific yay or nay about LAGs.

           

          Scott

          • 2. Re: MPLS TE tunnel
            Karthik Kumar Thatikonda

            Thanks for the reply. I did configure layer 2 port channel and tunnel came up fine. I haven't researched about how to configure using layer 3 port channels.

            • 3. Re: MPLS TE tunnel
              Scott Morris - CCDE/4xCCIE/2xJNCIE

              Glad to hear it worked for you.   I asked a couple other folks about the L3 LAG and they hadn't heard about it, but like me, hadn't ever tried...     So I suspect there's a few of us who are going to lab it when we manage to find available equipment to mess around with! (grin)

               

              Scott

              • 4. Re: MPLS TE tunnel
                Conwyn

                Hi Scott

                 

                TE is a subject of which I know nothing. I threw four routers together in GNS so I had two tunnels  using routers 1+2+4 and 1+3+4 using the ethernet ports on the 7200 and it worked quite happily but I was struggling to understand if that was L2 or L3 in the context of this posting.

                 

                Regards Conwyn

                 

                hostname R1
                ip cef
                mpls traffic-eng tunnels
                interface Loopback0
                ip address 1.1.1.1 255.255.255.255
                !
                interface Tunnel1
                ip unnumbered Loopback0
                tunnel destination 4.4.4.4
                tunnel mode mpls traffic-eng
                tunnel mpls traffic-eng autoroute announce
                tunnel mpls traffic-eng priority 1 1
                tunnel mpls traffic-eng bandwidth  1000
                tunnel mpls traffic-eng path-option 1 explicit identifier 1
                  no routing dynamic
                !
                interface Tunnel2
                ip unnumbered Loopback0
                tunnel destination 4.4.4.4
                tunnel mode mpls traffic-eng
                tunnel mpls traffic-eng autoroute announce
                tunnel mpls traffic-eng priority 1 1
                tunnel mpls traffic-eng bandwidth  500
                tunnel mpls traffic-eng path-option 2 explicit identifier 2
                no routing dynamic
                !
                interface FastEthernet0/0
                ip address 10.0.0.1 255.255.255.252
                shutdown
                duplex auto
                speed auto
                mpls traffic-eng tunnels
                ip rsvp bandwidth 1000
                !
                interface FastEthernet0/1
                ip address 10.0.0.5 255.255.255.252
                duplex auto
                speed auto
                mpls traffic-eng tunnels
                ip rsvp bandwidth 1000
                !
                router ospf 1
                mpls traffic-eng router-id Loopback0
                mpls traffic-eng area 0
                log-adjacency-changes
                network 0.0.0.0 255.255.255.255 area 0


                ip explicit-path identifier 1 enable
                next-address 10.0.0.1
                next-address 10.0.0.9
                !
                ip explicit-path identifier 2 enable
                next-address 10.0.0.5
                next-address 10.0.0.13

                • 5. Re: MPLS TE tunnel
                  Scott Morris - CCDE/4xCCIE/2xJNCIE

                  You're looking for the "mpls traffic-engineering tunnels" command set.

                   

                  But more importantly (as you are doing L3 links there), it would be on line cards for a 6500 switch:

                   

                  interface fa1/1

                  no switchport

                  no ip address

                  channel-group 1 mode on

                   

                  interface fa1/2

                  no switchport

                  no ip address

                  channel-group 1 mode on

                   

                  interface port-channel 1

                  ip address 10.10.10.1 255.255.255.0

                  mpls ip

                  mpls traffic-engineering tunnels

                   

                  and working from there..   That's the part he's having difficulty with is the L3 etherchannel AND the mpls TE command sets.  In GNS, I haven't used it enough to know whether or not it's possible to truly emulate a LAG connection between multiple interfaces or not.

                   

                  Scott

                  • 6. Re: MPLS TE tunnel
                    Conwyn

                    Hi Scott

                     

                    Is this what you mean? Four 7200 in a line connected with two fastethernet in each port group

                     

                    Regards conwyn

                     

                    R1#show ip route
                    Gateway of last resort is not set

                         1.0.0.0/32 is subnetted, 1 subnets
                    C       1.1.1.1 is directly connected, Loopback0
                         2.0.0.0/32 is subnetted, 1 subnets
                    O       2.2.2.2 [110/2] via 10.0.0.2, 00:00:16, Port-channel1
                         3.0.0.0/32 is subnetted, 1 subnets
                    O       3.3.3.3 [110/3] via 10.0.0.2, 00:00:16, Port-channel1
                         4.0.0.0/32 is subnetted, 1 subnets
                    O       4.4.4.4 [110/4] via 0.0.0.0, 00:00:16, Tunnel1
                         10.0.0.0/30 is subnetted, 3 subnets
                    O       10.0.0.8 [110/3] via 10.0.0.2, 00:00:16, Port-channel1
                    C       10.0.0.0 is directly connected, Port-channel1
                    O       10.0.0.4 [110/2] via 10.0.0.2, 00:00:16, Port-channel1
                    R1#trace 4.4.4.4

                    Type escape sequence to abort.
                    Tracing the route to 4.4.4.4

                      1 10.0.0.2 [MPLS: Label 16 Exp 0] 912 msec 608 msec 720 msec
                      2 10.0.0.6 [MPLS: Label 16 Exp 0] 616 msec 648 msec 696 msec
                      3 10.0.0.10 1012 msec 552 msec 616 msec

                     

                    service timestamps debug datetime msec
                    service timestamps log datetime msec
                    no service password-encryption
                    !
                    hostname R1

                     

                    ip cef
                    !
                    !
                    mpls traffic-eng tunnels
                    !
                    interface Loopback0
                    ip address 1.1.1.1 255.255.255.255
                    !
                    interface Tunnel1
                    ip unnumbered Loopback0
                    tunnel destination 4.4.4.4
                    tunnel mode mpls traffic-eng
                    tunnel mpls traffic-eng autoroute announce
                    tunnel mpls traffic-eng priority 1 1
                    tunnel mpls traffic-eng bandwidth  1000
                    tunnel mpls traffic-eng path-option 1 explicit identifier 1
                    no routing dynamic
                    !
                    interface Port-channel1
                    ip address 10.0.0.1 255.255.255.252
                    mpls traffic-eng tunnels
                    hold-queue 150 in
                    ip rsvp bandwidth 1000
                    !
                    interface FastEthernet0/0
                    no ip address
                    duplex auto
                    speed auto
                    channel-group 1
                    !
                    interface FastEthernet0/1
                    no ip address
                    duplex auto
                    speed auto
                    channel-group 1
                    !
                    interface FastEthernet1/0
                    no ip address
                    shutdown
                    duplex auto
                    speed auto
                    !
                    interface FastEthernet1/1
                    no ip address
                    shutdown
                    duplex auto
                    speed auto
                    !
                    router ospf 1
                    mpls traffic-eng router-id Loopback0
                    mpls traffic-eng area 0
                    log-adjacency-changes
                    network 0.0.0.0 255.255.255.255 area 0
                    !
                    !
                    no ip http server
                    no ip http secure-server
                    !
                    !
                    ip explicit-path identifier 1 enable
                    next-address 10.0.0.1
                    next-address 10.0.0.5
                    next-address 10.0.0.9
                    !
                    !
                    !
                    !

                    • 7. Re: MPLS TE tunnel
                      Scott Morris - CCDE/4xCCIE/2xJNCIE

                      Yup, that would do.

                       

                      Now, we have a concept of it being completely possible. Although GNS is completely software, as is a 7200 anyway.  Whereas a 6500 is a handoff between software-controlled and ASIC-controlled.  Therein lies many of the difficulties in life. 

                       

                      But conceptually, that's correct.

                       

                      Scott

                      • 8. Re: MPLS TE tunnel
                        hoangsinh

                        Hi Karthik

                         

                        Can you post your configuration for reference?

                         

                        What's IOS version you are using on 6500

                         

                        Cheer