1 2 Previous Next 24 Replies Latest reply: Aug 14, 2010 4:37 AM by Deepak RSS

    Two default routes...

    Deepak

      Hi!

       

      Lets say we've following topology

       


      (Loopback1) R1 (s1)<---->(s1) R2 (s0)<---->(s0) R3 (Loopback2)

       

      All router interfaces are configured with respective ip addresses so that neighbors can ping each other. NO other configuration made other than TWO static default routes on R2..1st one is pointing towards R1 and 2nd one is pointing towards R3, with both next hop ip and routers own interface options used that are present while creating default routes.

       

      If I ping Loopback1 or Loopback2 it fails...Please explain the behaviour of routers here...why its happaning the way it is happaning.

       

       

      Regards,

      Deepak

        • 1. Re: Two default routes...
          Conwyn

          Hi Deepak

           

          Are you using ping 1.2.3.4 source interface-name?

           

          Regards Conwyn

          • 2. Re: Two default routes...
            Wendell Odom

            Deepak,

             

            I agree with Conwyn about the source interface, since R1 or R3 will need to route with which to send back the Echo Reply.

             

            Another thing to check: if you have <no ip classless> configured on R2. If so, change it to <ip classless> and try it again. That may do the trick.

             

            Regards,

            Wendell

            • 3. Re: Two default routes...
              Claudius

              Hi Deepak,

               

              If you ping from Lo1 (R1) to lo2 (R2)

               

              It's needed that all routers on the way could handle the destination and/or source of ping packet. As I understand there's no routing configured but 2 static routes on R2. If I am correct, neither R1 nor R3 are aware of remote loopback networks, so...

               

              How Can it ber delivered? How Can it be Delivered Back?

               

              Unreachable Destination.

               

              Regards,

               

              Carlos

              • 4. Re: Two default routes...
                Deepak

                Dear all!

                 

                Thanks for your responces...

                 

                Conwyn and Wendell I've tried the stuff you suggested, but ping is still not working, Carlos, I'm not pinging from R1 to R3, Im trying pining R3/R1's loopback from R2.

                 

                Here I've tried building lab, please let me know if I misses somthing...

                 

                R1 config

                -------------

                interface Loopback0
                ip address 1.1.1.1 255.255.255.255
                !
                interface FastEthernet0/0
                ip address 10.1.1.2 255.255.255.0
                duplex auto
                speed auto
                !

                ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 10.1.1.1

                !

                 

                Gateway of last resort is 10.1.1.1 to network 0.0.0.0

                 

                     1.0.0.0/32 is subnetted, 1 subnets
                C       1.1.1.1 is directly connected, Loopback0
                     10.0.0.0/24 is subnetted, 1 subnets
                C       10.1.1.0 is directly connected, FastEthernet0/0
                S*   0.0.0.0/0 [1/0] via 10.1.1.1, FastEthernet0/0

                 

                 

                 

                 

                R2 config

                -------------

                interface FastEthernet0/0
                ip address 10.1.1.1 255.255.255.0
                duplex auto
                speed auto
                !
                interface FastEthernet0/1
                ip address 20.1.1.2 255.255.255.0
                duplex auto
                speed auto
                !
                ip forward-protocol nd
                ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 20.1.1.1
                ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 10.1.1.2
                !

                 

                Gateway of last resort is 20.1.1.1 to network 0.0.0.0

                 

                     20.0.0.0/24 is subnetted, 1 subnets
                C       20.1.1.0 is directly connected, FastEthernet0/1
                     10.0.0.0/24 is subnetted, 1 subnets
                C       10.1.1.0 is directly connected, FastEthernet0/0
                S*   0.0.0.0/0 [1/0] via 20.1.1.1, FastEthernet0/1
                               [1/0] via 10.1.1.2, FastEthernet0/0

                 

                 

                 

                R3 config

                -------------

                interface Loopback0
                ip address 3.3.3.3 255.255.255.255
                !
                interface FastEthernet0/1
                ip address 20.1.1.1 255.255.255.0
                duplex auto
                speed auto
                !
                ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 20.1.1.2

                !

                 

                Gateway of last resort is 20.1.1.2 to network 0.0.0.0

                 

                     3.0.0.0/32 is subnetted, 1 subnets
                C       3.3.3.3 is directly connected, Loopback0
                     20.0.0.0/24 is subnetted, 1 subnets
                C       20.1.1.0 is directly connected, FastEthernet0/1
                S*   0.0.0.0/0 [1/0] via 20.1.1.2, FastEthernet0/1

                 

                 

                 

                Motive behind doing this is, I'm trying to find out...will this work IF YES then how? and IF NOT then how?

                 

                 

                Thanks

                Deepak

                • 5. Re: Two default routes...
                  Sonu Khandelwal

                  Hi Deepak,

                  Lets say You want to ping 3.3.3.3 from R2. R2 wont have any way to know if packet should be send to R1 or R3 becuase it has both the routes in its table. Lets say if it sent to R3 and its doing per prefix loadbalancing then your ping will succeed.

                  If R2 is doing per packet load balancing then alternate ping packets will succeed.

                   

                  Experts can correct me, If I am wrong here.

                   

                  Thanks,

                  Sonu

                  • 6. Re: Two default routes...
                    Chad Spears CCNP CCDA CCNAS

                    Deepak-

                     

                         I agree with Sonu; it appears that you should have the following on R2:

                     

                    ip route 1.1.1.1 (*Subnet Mask*) FastEthernet 0/0

                    ip route 3.3.3.3 (*Subnet Mask*) FastEthernet 0/1

                     

                     

                    This should work....As always Experts let me know if I am wrong.

                     

                    Thanks,

                    CS

                    • 7. Re: Two default routes...
                      Chad Spears CCNP CCDA CCNAS

                      nevermind I just read the title of the post. .....Oops!

                      • 8. Re: Two default routes...
                        DelVonte

                        I don't think you can have two static default routes, how will R2 know which one to use. Also, in order to be able to ping the loopback interfaces, you will have to provide a route to those interfaces.

                         

                        I wasn't really sure how configuring two default routes would work, so I put it together in Packet Tracer:

                         

                        R2#ping 3.3.3.3

                        Type escape sequence to abort.
                        Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
                        ..!.!
                        Success rate is 40 percent (2/5), round-trip min/avg/max = 3/3/3 ms

                        R2#ping 3.3.3.3

                        Type escape sequence to abort.
                        Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
                        .!.!.
                        Success rate is 40 percent (2/5), round-trip min/avg/max = 4/4/5 ms

                        R2#ping 1.1.1.1

                        Type escape sequence to abort.
                        Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
                        .!.!.
                        Success rate is 40 percent (2/5), round-trip min/avg/max = 3/4/5 ms

                        R2#

                         

                        I was really surprised that I got any response. Heres the output after removing one default route and configuring static routes to the loopback interfaces:

                         

                        R2#
                        R2#
                        R2#config t
                        Enter configuration commands, one per line.  End with CNTL/Z.
                        R2(config)#no ip route 0.0.0.0 0.0.0.0 20.1.1.2
                        R2(config)#ip route 1.1.1.1 255.255.255.255 10.1.1.2
                        R2(config)#ip route 3.3.3.3 255.255.255.255 20.1.1.2
                        R2(config)#^Z
                        R2#
                        %SYS-5-CONFIG_I: Configured from console by console

                        R2#ping 3.3.3.3

                        Type escape sequence to abort.
                        Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
                        !!!!!
                        Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/6 ms

                        R2#ping 1.1.1.1

                        Type escape sequence to abort.
                        Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
                        !!!!!
                        Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms

                        R2#

                         

                         

                        HTH

                        DelVonte

                        • 9. Re: Two default routes...
                          Claudius

                          Hi Deepak,

                           

                          I see, I misunderstood the question, but there's not only 2 default routes, actually they're all over the place... Interesting scenario.

                           

                          I belive that the point in this case is how packets will be processed, try to disable ip cef, that would work.

                           

                          Let me know if I am on the way .

                           

                          Regards,

                           

                          Carlos.

                          • 10. Re: Two default routes...
                            Wendell Odom

                            Deepak and DelVonte,

                            Actually, the results DelVonte sees with the defaults is what I would have expected. You can have multiple default routes in the routing table at the same time, but I agree it's not useful for real life. Deepak, I'm sure you mention somewhere that you're just testing to see what happens.

                             

                            Backing up a step, Deepak... any chance the cabling differs from your figure? EG, R2's Fa0/1 is actually cabled to R1's Fa0/0? That would fit the symptoms at least. One other thought: I've not used the syntax "ip route 0.0.0.0 0.0.0.0 fa0/0 10.1.1.2" often, instead just listing the next-hop IP address (ip route 0.0.0.0 0.0.0.0 10.1.1.2) in such cases. May be worth a shot. Last suggestion, and I'll stop: shut down one LAN interface on R2, and see if you can at least ping the router that's still possibly reachable, and get that working before adding back the other side.

                             

                            That's all I can think to try. I'll be curious to see your results.

                            Thanks,

                            Wendell

                            • 11. Re: Two default routes...
                              DelVonte

                              I'm not really sure if any of us know exactly what is being asked

                              • 12. Re: Two default routes...
                                Deepak

                                Thanks for replies friends.

                                 

                                @CS: I'll never

                                 

                                @DelVonte, I wanted to use static DEFAULT routes to  check how packets are sent or received, you are using static routes in your scenario. I've built this  topology on GNS3, my results are different, I've not received any echo reply (100% loss),  while using two static Default routes, maybe PT is acting in your case.

                                 

                                @Wandell..I'm just testing it. I'm very much correct with my posted topology,  and sure enough if I shutdown one interface I can ping other side.


                                @Sonu,  your suggestion worked..but I get a 100% ping success while using  either of the method (per packet or destination), as you said per packet  should return alternate pings (means say 40% success), any clue why and  how this happened?

                                 

                                @Carlos...Your suggestion, disabling  cef also worked and yes  "I belive that the point in this case is how  packets will be processed" you are correct here I'm trying to find exactly what you have mentioned.

                                 

                                What  I concluded is:- While having two default routes in two different  direction then router will not be able to pass traffic, eventhough both  the default routes exist in routing table, because of it is not able to take decision which route to use.

                                 


                                Please let me  know IF I'm right or if you would like to add any findings with my conclusion Considering above mentioned  topology, and configs OR will it happen in any case?

                                 

                                 

                                Thanks,

                                 

                                Deepak

                                • 13. Re: Two default routes...
                                  Conwyn

                                  Hi Deepak

                                   

                                  You might find this interesting especially Toor's post.

                                   

                                  See https://learningnetwork.cisco.com/message/39389#39389

                                   

                                  Regards Conwyn

                                  • 14. Re: Two default routes...
                                    DelVonte

                                    That is interesting and enlightening, I never thought about it from that perspective. Always assumed just one default route, now I have to play around with this. Thanks for the post Deepak, and thanks for the link Conwyn. I learn quite a bit on CLN everyday.

                                     

                                    Regards

                                    DelVonte

                                    1 2 Previous Next