3 Replies Latest reply: Jul 17, 2010 1:23 AM by Conwyn RSS

    ATM

    rocrowe

      I guess I could see how this message could be construed.

       

      Message was edited by: rocrowe

        • 1. Re: ATM
          Conwyn

          Hi R

           

          You are a brave man

           

          Regards conwyn

          • 2. Re: ATM
            Conwyn

            Hi R

             

            I have visions of the Proctor waiting for you with a very special lab.

             

            Regards Conwyn

            • 3. Re: ATM
              Conwyn

              Hi R

               

              Just in case he is waiting I have prepared this very simple example of MPLS VRF over ATM just for you. Enjoy!

               

              R1CE---R2PE----R3PE---R4CE.

               

              Regards Conwyn

               


              R1CE#ping 4.4.4.4

              Type escape sequence to abort.
              Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
              !!!!!
              Success rate is 100 percent (5/5), round-trip min/avg/max = 512/681/880 ms

               

               

              hostname R1CE

              interface Loopback0
              ip address 1.1.1.1 255.255.255.255

              interface ATM1/0
              no ip address
              no atm ilmi-keepalive
              !
              interface ATM1/0.1 mpls
              ip address 10.0.0.1 255.255.255.252
              no snmp trap link-status
              mpls ip
              mpls atm vpi 100-101 vci-range 33-65535
              !
              router bgp 65001
              no synchronization
              bgp log-neighbor-changes
              redistribute connected
              neighbor 10.0.0.2 remote-as 65000
              no auto-summary
              * * *
              hostname R2PE
              ip vrf cisco
              rd 100:100
              route-target export 100:100
              route-target import 100:100

              interface Loopback0
              ip address 2.2.2.2 255.255.255.255
              !
              interface ATM1/0
              no ip address
              no atm ilmi-keepalive
              !
              interface ATM1/0.1 mpls
              ip vrf forwarding cisco
              ip address 10.0.0.2 255.255.255.252
              no snmp trap link-status
              mpls ip
              mpls atm vpi 100-101 vci-range 33-65535
              !
              interface ATM2/0
              no ip address
              no atm ilmi-keepalive
              !
              interface ATM2/0.1 mpls
              ip address 10.0.0.5 255.255.255.252
              no snmp trap link-status
              mpls ip
              mpls atm vpi 200-201 vci-range 33-65535
              !
              router bgp 65000
              no synchronization
              bgp log-neighbor-changes
              neighbor 3.3.3.3 remote-as 65000
              neighbor 3.3.3.3 update-source Loopback0
              no auto-summary
              !
              address-family vpnv4
              neighbor 3.3.3.3 activate
              neighbor 3.3.3.3 send-community both
              neighbor 3.3.3.3 next-hop-self
              exit-address-family
              !
              address-family ipv4 vrf cisco
              neighbor 10.0.0.1 remote-as 65001
              neighbor 10.0.0.1 activate
              neighbor 10.0.0.1 as-override
              no synchronization
              exit-address-family
              !
              ip route 3.3.3.3 255.255.255.255 10.0.0.6
              * * *
              hostname R3PE

              ip vrf cisco
              rd 100:100
              route-target export 100:100
              route-target import 100:100
              interface Loopback0
              ip address 3.3.3.3 255.255.255.255

              interface ATM1/0
              no ip address
              no atm ilmi-keepalive
              !
              interface ATM1/0.1 mpls
              ip vrf forwarding cisco
              ip address 10.0.0.9 255.255.255.252
              no snmp trap link-status
              mpls ip
              mpls atm vpi 250-251 vci-range 33-65535
              !
              interface ATM2/0
              no ip address
              no atm ilmi-keepalive
              !
              interface ATM2/0.1 mpls
              ip address 10.0.0.6 255.255.255.252
              no snmp trap link-status
              mpls ip
              mpls atm vpi 200-201 vci-range 33-65535
              !
              router bgp 65000
              no synchronization
              bgp log-neighbor-changes
              neighbor 2.2.2.2 remote-as 65000
              neighbor 2.2.2.2 update-source Loopback0
              no auto-summary
              !
              address-family vpnv4
              neighbor 2.2.2.2 activate
              neighbor 2.2.2.2 send-community both
              neighbor 2.2.2.2 next-hop-self
              exit-address-family
              !
              address-family ipv4 vrf cisco
              neighbor 10.0.0.10 remote-as 65001
              neighbor 10.0.0.10 activate
              neighbor 10.0.0.10 as-override
              no synchronization
              exit-address-family
              !
              ip route 2.2.2.2 255.255.255.255 10.0.0.5
              * * *
              hostname R4CE
              interface Loopback0
              ip address 4.4.4.4 255.255.255.255
              !
              interface ATM1/0
              no ip address
              no atm ilmi-keepalive
              !
              interface ATM1/0.1 mpls
              ip address 10.0.0.10 255.255.255.252
              no snmp trap link-status
              mpls ip
              mpls atm vpi 250-251 vci-range 33-65535
              !
              router bgp 65001
              no synchronization
              bgp log-neighbor-changes
              redistribute connected
              neighbor 10.0.0.9 remote-as 65000
              no auto-summary
              !