Skip navigation
Login   |   Register
Cisco Learning Home > CCNP R&S Study Group > Discussions
This Question is Not Answered 1 Correct Answer available (4 pts) 2 Helpful Answers available (2 pts)
9174 Views 4 Replies Latest reply: Aug 15, 2011 12:15 AM by Martin RSS

Currently Being Moderated

EIGRP auto summarization?

Jun 18, 2010 3:13 PM

Mohammed 115 posts since
May 27, 2010

10.10.10.0/24------R1----------172.16.10.0/24--------------------R2---------------192.168.20.0/24---------------------R3

if  the configuration on R1

router eigrp 100

net 10.0.0.0

net  172.16.0.0

no auto-summary

and on all other routers  auto-summary is enabled

which routes will be at R2

 

-10.0.0.0/8

10.10.10.0/24

-172.16.0.0/16

172.16.10.0/24

 

i  mean r2 will receive 10.10.10.0/24 from R1 will it auto summerize it  before sending to R3 or will it send it as it is ?

  • Scott Morris - CCDE/4xCCIE/2xJNCIE 8,426 posts since
    Oct 7, 2008
    Currently Being Moderated
    1. Jun 18, 2010 4:56 PM (in response to Mohammed)
    Re: EIGRP auto summarization?

    This is either a duplicate post or I'm going insane....

     

    It's all about the perspective of ownership....

     


    I  modified your diagram a little since my R2 was doing other things.  


    10.10.10.1    \
    10.10.12.1-----R1----172.16.10.0/24-----R4-----192.168.20.0/24------R3-----200.200.200.3
    1.1.1.1        /                   (45.45.45.4)
                                          (4.4.4.4)

     

    R1
    router eigrp 100
    network 10.0.0.0
    network 1.0.0.0
    network 172.16.0.0
    passive default
    no passive fa0/0
    no auto-summary

     

    R4
    router eigrp 100
    network 172.16.0.0
    network 192.168.20.0
    network 45.0.0.0
    network 4.0.0.0
    passive s0/1/0
    passive lo0

     

    R3
    router eigrp 100
    network 192.168.20.0
    network 200.200.200.0
    passive default
    no passive f0/0

     

     

     

    R1:
    Uber-Geek-R1(config-router)#do sh ip ro  ei
    D    200.200.200.0/24 [90/33280] via 172.16.10.4, 00:02:16,  FastEthernet0/0
    D    4.0.0.0/8 [90/156160] via 172.16.10.4, 00:01:41, FastEthernet0/0
    D    20.0.0.0/8 [90/20517120] via 172.16.10.4, 00:00:06, FastEthernet0/0
    D    192.168.20.0/24 [90/30720] via 172.16.10.4, 00:02:16,  FastEthernet0/0
    D    45.0.0.0/8 [90/2172416] via 172.16.10.4, 00:02:16, FastEthernet0/0
    Uber-Geek-R1(config-router)#

     

    So it sees summarized routes coming FROM R4 (R2 in your diagram)

     

    R4:

     

    Uber-Geek-R4(config-router)#do  sh ip ro ei
    D    200.200.200.0/24 [90/30720] via 192.168.20.3, 00:02:41,  FastEthernet0/1
          1.0.0.0/24 is subnetted, 1 subnets
    D       1.1.1.0 [90/156160] via 172.16.10.1, 00:02:32, FastEthernet0/0
          4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    D       4.0.0.0/8 is a summary, 00:01:58, Null0
    D    20.0.0.0/8 [90/20514560] via 192.168.20.3, 00:00:23,  FastEthernet0/1
          172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    D       172.16.0.0/16 is a summary, 00:02:43, Null0
          10.0.0.0/24 is subnetted, 2 subnets
    D       10.10.10.0 [90/2172416] via 172.16.10.1, 00:02:32,  FastEthernet0/0
    D       10.10.12.0 [90/2172416] via 172.16.10.1, 00:02:32,  FastEthernet0/0
          45.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
    D       45.0.0.0/8 is a summary, 00:02:43, Null0
    Uber-Geek-R4(config-router)#

     

    R4 sees pre-summarized routes coming FROM R3, but sees SPECIFIC  routes from R1.

     

    Uber-Geek-R3(config-router)#do  sh ip ro ei
          1.0.0.0/24 is subnetted, 1 subnets
    D       1.1.1.0 [90/158720] via 192.168.20.4, 00:03:14, FastEthernet0/0
    D    4.0.0.0/8 [90/156160] via 192.168.20.4, 00:02:39, FastEthernet0/0
          20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    D       20.0.0.0/8 is a summary, 00:01:04, Null0
    D    172.16.0.0/16 [90/30720] via 192.168.20.4, 00:03:22,  FastEthernet0/0
          10.0.0.0/24 is subnetted, 2 subnets
    D       10.10.10.0 [90/2174976] via 192.168.20.4, 00:03:14,  FastEthernet0/0
    D       10.10.12.0 [90/2174976] via 192.168.20.4, 00:03:14,  FastEthernet0/0
    D    45.0.0.0/8 [90/2172416] via 192.168.20.4, 00:03:22, FastEthernet0/0
    Uber-Geek-R3(config-router)#

     

    Interestingly enough, the specific 10.10.x.0/24 and 1.1.1.0/24  networks are NOT summarized by R4.  A learned EIGRP route is not  authoritative in summarizing.

    Since R1 did not auto-summarize, then it didn't happen.

     

    HTH,

     

    Scott

    Join this discussion now: Login / Register
  • hoangsonptit 1 posts since
    Jan 21, 2010
    Currently Being Moderated
    2. Aug 8, 2011 12:30 PM (in response to Mohammed)
    Re: EIGRP auto summarization?
    When a router has multiple working interfaces, and those interfaces use IP addresses in different classful networks, the router advertises a summary route for each classful network on interfaces attached to a different classful network.

    CCNP ROUTE 642-902 Official Certification Guide - Wendell Odom, Key Topic, Page 124

     

    When R1 advertise 10.10.10.0/24 network to R2, but R2 not directly connected to this one, so it send this network in classless form to R3. Otherwise, 172.16.10.0/24 network which connected to R2, it will be summarized before send to R3.

     

    I think EIGRP routers only summarize routes that correspond to network which their interfaces attached to.

     

    Regard,

    HS

    Join this discussion now: Login / Register
  • naresh 49 posts since
    Jun 10, 2011
    Currently Being Moderated
    3. Aug 15, 2011 12:04 AM (in response to Mohammed)
    Re: EIGRP auto summarization?

    no r2 cannot summarize because it is himself depend on r1 for this routes.so until r1 summaries it there is no router in eigrp which can summaries it because they dont know about those routes without r1.

    Join this discussion now: Login / Register
  • Martin 13,882 posts since
    Jan 16, 2009
    Currently Being Moderated
    4. Aug 15, 2011 12:15 AM (in response to Mohammed)
    Re: EIGRP auto summarization?

    and I am confused

    Join this discussion now: Login / Register

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)