5 Replies Latest reply: Jan 21, 2020 6:17 AM by Tyler RSS

    packet.net master salt server issue

    Max

      Hey,
      I am using VIRL on packet.net. https://www.packet.com/resources/guides/cisco-virl-on-packet/
      I'm having issues with the license configuration. Private key and filename are provided correctly.
      BUT: after booting the master salt servers are wrong.
      It is: ipxe-load-ams1.virl.info, ipxe-load-ams2.virl.info
      but should be one of these here:

      vsm-us-51.virl.info, vsm-us-52.virl.info, vsm-us-53.virl.info, vsm-us-54.virl.info

      vsm-eu-51.virl.info, vsm-eu-52.virl.info, vsm-eu-53.virl.info, vsm-eu-54.virl.info

      vsm-ap-51.virl.info, vsm-ap-52.virl.info, vsm-ap-53.virl.info, vsm-ap-54.virl.info

       

      I tried to fix that with some userdata information in packet api. But does not work.
      Only workaround: change it in the VIRL GUI.


      Can someone correct that in the PXE Boot image or tell me how to change that parameter in userdata?

       

      Thanks a lot

      Markus

        • 1. Re: packet.net master salt server issue
          Karlo Bobiles

          Hello Max,

           

          Looping in alegalle and rrozar for further investigation. Please stand by.


          Thank you,

          Karlo Bobiles

          Cisco Learning Network

          • 2. Re: packet.net master salt server issue
            Max

            Hey Karlo,
            Thanks a lot.  But I still got no update on this.

             

            Best regards

            Markus

            • 3. Re: packet.net master salt server issue
              Tyler

              Did you download your .pem license file from your VIRL account? If so, go to your UWM admin portal and click on Salt and Configuration Status, located in the left pane.

               

              After this page loads, click on the Reset keys and ID button located toward the top left of the page.

               

              Below the text box for the minion private key, you should see a button that says Load config file. Click this button, then upload your .pem file. This will populate your private key and Salt ID and domain. You may then enter your customer email address, then click the US button to populate the List of Cisco salt masters. Unless you've otherwise been told, make sure the Master sign public key field is set to eft.pub. Once completed, click the reset button. It will take a few moments to complete the reset. After this completes, re-check your connection status.

               

              This is what worked for me.

              • 4. Re: packet.net master salt server issue
                Max

                Hey Tyler,

                 

                First of all thanks a lot for your answer.
                As I wrote above, all the steps work fine for me. So the license is there.
                And I wrote above:  "Only workaround: change it in the VIRL GUI."

                But this is really a bad workaround when dealing with VIRL in an automated testing environment.
                It is not possible to do any GUI interactions when handling automated tests.


                It seems that this setting is a bug in the Packet image or somewhere else.
                And as long as VIRL does not provide an API to fix that from outside, I am very much dependent on your help and fixing this issue.


                thanks a lot

                Max

                • 5. Re: packet.net master salt server issue
                  Tyler

                  I've not messed with the nuts and bolts of VIRL on Packet. I encountered a licensing issue myself when spinning up an instance on Packet.com last week, and I think when I responded to your post, my issues were fresh in mind. Have you reached out to Packet's team regarding the issue you're encountering? Perhaps it's something they can fix?