6 Replies Latest reply: Nov 13, 2019 10:32 AM by Ing_Percy RSS

    problema con stack

    harima1

      hola, en la empresa donde trabajo estoy implementando una conexión entre switches y para eso puse dos switches en stack

      stack10.JPG

      Pero veo que no se logra el stack:

       

      SW1#show switch
      Switch/Stack Mac Address : 381c.1ad8.7b00
                                                 H/W   Current
      Switch#  Role   Mac Address     Priority Version  State
      ---------------------------------------------------------------------------
      *1       Master 381c.1ad8.7b00       1     4       Ready
      2       Member 0000.0000.0000     0      0       Provisioned

       

      SW1#show switch stack-ports
        Switch #    Port 1       Port 2
        ----------    -----------    ------------
            1          Down         Down

       

      Cual podría ser problema?

        • 1. Re: problema con stack
          Ing_Percy

          Hola!

           

          Por lo que se ve en la salida, es claro que no se ha establecido el Stack correctamente


          Debes tener en cuenta estas pautas para aplicar Stack en los switches:

          *Todos los switches tienen que tener la misma versión de IOS.

          *Se recomienda configurar la prioridad mas alta en uno de los switches para que sea elegido como "master". El comando sería: "switch X priority number", donde "X" es el número de Switch y "number" es el número de prioridad.

          *Colocar correctamente con el cable stack. Por ejemplo:

          stack11.JPG

          Saludos!

          • 2. Re: problema con stack
            harima1

            gracias, si había puesto la misma versión de ios en mis switches, le acabo de configurar una prioridad mas alta a mi SW1, pero igual no se forma el stack:

             

            Switch/Stack Mac Address : 381c.1ad8.7b00

                                                       H/W   Current

            Switch#  Role   Mac Address     Priority Version  State

            ---------------------------------------------------------------------------

            *1       Master 381c.1ad8.7b00       15     4        Ready

            2       Member 0000.0000.0000     0       0        Provisioned

            • 3. Re: problema con stack
              Ing_Percy

              Hola!

               

              Probablemente no has conectado bien el cable stack, anteriormente tuve una experiencia similar cuando estuve supervisando un proyecto donde se instalaron switches en stack. Trata de re-ajustarlo nuevamente.

              Asimismo por el diagrama que has puesto veo que has realizado una conexión Etherchannel, revisa el cableado y las configuraciones en ambos switches extremos,

               

              Saludos!

              • 4. Re: problema con stack
                harima1

                gracias!, reajuste mi cable stack, solo tenía 1 a mi disposición y ahora si funciona el stack

                 

                SW1#show switch stack-ports
                  Switch #    Port 1       Port 2
                  --------     -----------   -------------
                    1             Down          Ok
                    2              Ok          Down

                 

                SW1#show switch
                Switch/Stack Mac Address : 381c.1ad8.7b00
                                                           H/W   Current
                Switch#  Role   Mac Address     Priority Version  State
                ---------------------------------------------------------------------------
                *1       Master 381c.1ad8.7b00     15      4       Ready
                2       Member c800.8411.5b80     1       4       Ready

                 

                mi etherchannel si esta funcionando, con un puerto de cada switch que esta en stack

                 

                SW1#show etherchannel summary
                Flags:  D - down        P - bundled in port-channel
                        I - stand-alone s - suspended
                        H - Hot-standby (LACP only)
                        R - Layer3      S - Layer2
                        U - in use      f - failed to allocate aggregator

                        M - not in use, minimum links not met
                        u - unsuitable for bundling
                        w - waiting to be aggregated
                        d - default port


                Number of channel-groups in use: 1
                Number of aggregators:           1

                Group  Port-channel  Protocol    Ports
                ---------+----------------+-----------+-----------------------------------------------
                1            Po1(SU)             -         Te1/0/1(P)  Te2/0/2(P)

                • 5. Re: problema con stack
                  Ing_Percy

                  Hola!

                   

                  Que bueno que hayas solucionado tu problema, aquí en la comunidad Cisco Learning Network estamos para apoyar y con gusto lo hago en mi idioma.

                   

                  Aqui te coloco un enlace en español sobre un ejemplo de diseño de red corporativa donde incluye consideraciones para la conexión en Stack:

                  http://openaccess.uoc.edu/webapps/o2/bitstream/10609/28625/6/aobisTFC0114memoria.pdf

                   

                  Saludos!

                  • 6. Re: problema con stack
                    harima1

                    Estaba haciendo un mantenimiento preventivo de los equipos y del cableado  y al reiniciar tuve ese problema, había probado con un cable stack que no había usado y lo tenia en almacén, pero veo que igual como todo cable pueden romperse o no conectarse bien, gracias por las sugerencias. slds.