1 Reply Latest reply: Nov 11, 2019 12:01 PM by Jeffrey RSS

    failed upgrade to 1.6 from 1.5

    Jeffrey

      I went though the steps listed for the upgrade and came back to a 503 error on apache. going through the CLI process that was outlined in the 1.6 "Start Here", I ran the "sudo vinstall upgrade" command :

       

       

      result:

          ----------

          pid:

              3259

          retcode:

              100

          stderr:

              Running scope as unit run-raca37cf6fdb54988b3268b47fcee8c29.scope.

              E: Sub-process /usr/bin/dpkg returned an error code (1)

          stdout:

              Reading package lists...

              Building dependency tree...

              Reading state information...

              Calculating upgrade...

              The following packages were automatically installed and are no longer required:

                aufs-tools libllvm5.0 linux-headers-4.4.0-87 linux-headers-4.4.0-87-generic

                linux-image-4.4.0-116-generic linux-image-4.4.0-87-generic

                linux-image-extra-4.4.0-116-generic linux-image-extra-4.4.0-87-generic

              Use 'sudo apt autoremove' to remove them.

              0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

              2 not fully installed or removed.

              After this operation, 0 B of additional disk space will be used.

              Setting up python-horizon-physical-topology-plugin-juniper (3.0.0-1) ...

              Running post install template copy ...

              cp: cannot create regular file '/usr/share/openstack-dashboard/openstack_dashboard/enabled/': Not a directory

              dpkg: error processing package python-horizon-physical-topology-plugin-juniper (--configure):

               subprocess installed post-installation script returned error exit status 1

              Setting up python-horizon-static-route-plugin-juniper (3.0.0-1) ...

              Running post install template copy ...

              cp: cannot create regular file '/usr/share/openstack-dashboard/openstack_dashboard/enabled/': Not a directory

              dpkg: error processing package python-horizon-static-route-plugin-juniper (--configure):

               subprocess installed post-installation script returned error exit status 1

              Errors were encountered while processing:

               python-horizon-physical-topology-plugin-juniper

               python-horizon-static-route-plugin-juniper

      ), "cmd_|-force salt version_|-apt-get -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" install -y --allow-downgrades salt-common=2017.7.2+ds-1 salt-minion=2017.7.2+ds-1 salt-master=2017.7.2+ds-1_|-run" (Command "apt-get -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" install -y --allow-downgrades salt-common=2017.7.2+ds-1 salt-minion=2017.7.2+ds-1 salt-master=2017.7.2+ds-1" run)

      Upgrade failed on common.distuptodate

       

       

      Any help fixing would be appreciated. I'd rather not rebuild/redeploy if possible.

       

      Thanks

        • 1. Re: failed upgrade to 1.6 from 1.5
          Jeffrey

          Think I solved my own issue:

           

          cp: cannot create regular file '/usr/share/openstack-dashboard/openstack_dashboard/enabled/': Not a directory


          I created this directory and ran the apt-get update on the 2 "juniper" packages that were looking to be updated. Once I did this, and ran the vinstall update again, it didn't fail on any components to upgrade.