10 Replies Latest reply: Nov 10, 2019 2:26 AM by ciscodaze1 RSS

    How STP work with speed Mismatch

    Mohamed

      Hi CLN

      Untitled.png

       

       

      on this topology , SW-2 only supports Legacy Ethernet ports which is 10Mbps speed

      what will make SW-1 will change all his ports to be like this :-


      F0/0 100Mbps ---------------------> 10Mbps , Half

      F0/1 100Mbps ----------------------> 10Mbps , Half

      G0/2 1000Mbps ------------------> 10Mbps ,  Half

       

       

      STP will use costs on SW-1 based on  100Mbps  = 4  and 1000 Mbps  = 2 ? OR after auto nego works with 10Mbps which is cost = 100 ?

       

      clin

        • 1. Re: How STP work with speed Mismatch
          Parvesh

          Hi Mohamed,

          The Spanning Tree Cost Value is inversely proportional to the associated bandwidth of the path and therefore a path with a low cost value is more preferable than a path with high cost value.


          Path Cost is accumulated port costs from a switch  to reach the Root Switch.  The switch receives a Bridge Protocol Data Unit (BPDU) generated by Root switch at its port, it increments the path cost with the cost of the incoming port.


          how is the cost calculated ? how are port roles selected ?

          Ans - See this :

          https://networklessons.com/spanning-tree/spanning-tree-cost-calculation.

          Spanning Tree Path Cost Value and How is Spanning Tree Path Cost Value Calculated


          Remember - bandwidth of the interface, post autoneg is the local value to STP used while calculating accumulated cost to Root. This is communicated using BPDUs.



          Happy to discuss further.

          • 2. Re: How STP work with speed Mismatch
            Martin

            note from previous post, if you start messing with speed of a link, link may be down;  so be careful.

             

            but if interface is up and you  have 1 Gig on sw 1 and 100 on sw 2  (or 100 -vs 10), switch will agree on the lower speed of two speeds and set STP cost respectively.  Port cost is Speed of interface that is towards the Root switch.

             

            I think cost vales are as follow:

            10 Mbps = cost is 100

            100Mbps  = 19 

            1000 Mbps  = 4

            10 Gig = 2

            • 3. Re: How STP work with speed Mismatch
              Mohamed

              Martin

              Thanks martin , but i think you still don`t understand my question yet

              look , my question is :-

              interface G0/2 before run (auto-negotiation) has cost = 2 because speed =1000Mbps ,  and after run (auto-negotiation) speed will be lower and will 100Mbps


              my question :-

              Does STP care about this change of speed ? i mean which one STP cost will choose ? before OR after the (Auto nego) running ?

              • 4. Re: How STP work with speed Mismatch
                Ing_Percy

                Hi!

                 

                STP cost is after negotiation of links

                I implemented a topology with real devices:

                stp-link1.JPG

                 

                SB_P06_A#sh run int g0/24

                Building configuration...

                Current configuration : 163 bytes

                !

                interface GigabitEthernet0/24

                description Link_SBORJA_P06_B

                switchport trunk encapsulation dot1q

                switchport trunk native vlan 96

                switchport mode trunk

                end

                 

                SB_P06_B#sh run int f0/24

                Building configuration...

                Current configuration : 116 bytes

                !

                interface FastEthernet0/24

                description SBORJA_P06_A

                switchport trunk native vlan 96

                switchport mode trunk

                end

                 

                Both switches have the speed and duplex as auto. Then, when I connected the switches between them:

                 

                SB_P06_A#sh int g0/24 status

                Port                Name                        Status       Vlan       Duplex  Speed Type

                Gi0/24    Link_SBORJA_P06_B  connected    trunk          a-full   a-100 10/100/1000BaseTX

                 

                SB_P06_B#sh int f0/24 status

                Port          Name                          Status       Vlan       Duplex  Speed Type

                Fa0/24    SBORJA_P06_A       connected    trunk      a-full      a-100 10/100BaseTX

                 

                Now in STP, for SB_P06_A

                stp-link2.JPG

                 

                The cost ot the f0/24 on the SB_P06_B is the same of the first switch

                stp-link3.JPG

                Regards!

                • 5. Re: How STP work with speed Mismatch
                  Mohamed

                  Ing_Percy

                  Thanks Sir, but try to change the background color .  the background back is NOT good.please change it

                  • 6. Re: How STP work with speed Mismatch
                    Ing_Percy

                    Excuse me friend, I had this register. If I have another opportunity of get access to another device, I will put another background.

                    • 7. Re: How STP work with speed Mismatch
                      Martin

                      here are Percy's post and pictures with changed color

                       

                      Both switches have the speed and duplex as auto. Then, when I connected the switches between them:

                       

                      SB_P06_A#sh int g0/24 status

                      Port                Name                        Status       Vlan       Duplex  Speed Type

                      Gi0/24    Link_SBORJA_P06_B  connected    trunk          a-full   a-100 10/100/1000BaseTX

                       

                      SB_P06_B#sh int f0/24 status

                      Port          Name                          Status       Vlan       Duplex  Speed Type

                      Fa0/24    SBORJA_P06_A       connected    trunk      a-full      a-100 10/100BaseTX

                       

                      Now in STP, for SB_P06_A

                       

                      The cost ot the f0/24 on the SB_P06_B is the same of the first switch

                       

                      • 8. Re: How STP work with speed Mismatch
                        Samer

                        Mohamed wrote:

                         

                        Martin

                        Thanks martin , but i think you still don`t understand my question yet

                        look , my question is :-

                        interface G0/2 before run (auto-negotiation) has cost = 2 because speed =1000Mbps ,  and after run (auto-negotiation) speed will be lower and will 100Mbps


                        my question :-

                        Does STP care about this change of speed ? i mean which one STP cost will choose ? before OR after the (Auto nego) running ?

                        speed mismatch will cause the link to be in UP/DOWN state, which means STP BPDU messages will not be exchanged, when the links are UP/UP after negotiation process is done, BPDU's will be flowing again with costs and everything.

                        • 9. Re: How STP work with speed Mismatch
                          Parvesh

                          As I said in another post, STP cost is calculated post speed negotiation.

                          • 10. Re: How STP work with speed Mismatch
                            ciscodaze1

                            I cant read that, can you please put in on black background.