2 Replies Latest reply: Jun 11, 2019 10:00 AM by Miroslav Los RSS

    VIRL 1.5.145 bare metal ISO boot install - fails during installation

    GYAN

      Hello VIRL Community

       

      I am trying to install VIRL bare metal ISO boot image from USB onto my new HP Z820 server and I get an install script error

       

      I followed the procedure to install bare metal server.

       

      I used rufus to build the ISO Boot USB which worked great.  I ran windows cert util MD5 chek

       

      VIRL Personal Edition 1.5.145 release OVA. Deployment of this OVA requires one of these minimum host-based hypervisor versions before proceeding: VMware Fusion Pro v5.02, VMware Workstation v8.02, VMware Player v5.02.

      Release : VIRL 1.5.145

      Release Date : 08-Mar-2018

      FileName : virl.1.5.145.pc.ova

      Size : 5281.35 MB ( 5537891840 bytes)

      MD5 Checksum : e81ed563be2b88b19cf2efb22980b32d

      SHA512 Checksum : 27e4d14d10fb8e1989dd5e5bde6f4fb1 ..

       

       

      MD5

      e81ed563be2b88b19cf2efb22980b32d

      e81ed563be2b88b19cf2efb22980b32d

       

       

      certutil -hashfile virl.1.5.145.iso md5

       

       

      SHA512

       

       

      27e4d14d10fb8e1989dd5e5bde6f4fb1efeda27566d8f4915fd6331324793c50f80fd12567cd72c2e81ba5812a93c01538c74fde1f3d97c63e2edf5406bf4e76

      27e4d14d10fb8e1989dd5e5bde6f4fb1efeda27566d8f4915fd6331324793c50f80fd12567cd72c2e81ba5812a93c01538c74fde1f3d97c63e2edf5406bf4e76

       

       

       

       

      certutil -hashfile virl.1.5.145.iso sha512

       

       

      *********results of certuitl hash************

       

       

      D:\virl bare metal & vm workstation troubleshooting>certutil -hashfile virl.1.5.145.pc.ova  md5

      MD5 hash of file virl.1.5.145.pc.ova:

      e81ed563be2b88b19cf2efb22980b32d

      CertUtil: -hashfile command completed successfully.

       

       

      D:\virl bare metal & vm workstation troubleshooting>certutil -hashfile virl.1.5.145.pc.ova  sha512

      SHA512 hash of file virl.1.5.145.pc.ova:

      27e4d14d10fb8e1989dd5e5bde6f4fb1efeda27566d8f4915fd6331324793c50f80fd12567cd72c2e81ba5812a93c01538c74fde1f3d97c63e2edf5406bf4e76

      CertUtil: -hashfile command completed successfully.

       

      I have attached the error I am seeing.

       

      I did google on error message which is as follows looks like something is not set in the path  an idea I had is while the install is occuring I get debug in terminal session and try to fix dependency error.......before it gets to the error

       

      https://www.linuxquestions.org/questions/showthread.php?s=9f0088cb7abc069c3532f0e7d2edca3a&p=4830422#post4830422

       

      I ended up doing dual boot - linux (ISO bare metal) 1G SSD & Windows 1G SSD partition for future if I can ever get the bare metal to work but in the mean time I am using Windows 10 - VM Workstation player and run the OVA VM as a workaround.  The only major caveat is I have this high powered server with 256Gig of memory with dual sockets 16 cores per socket and I can only run 64Gig VM is limit.  I tried Virtualbox but that is not supported trying to tinker with it but could not get it to work since it did not have VT-x VT-d embedded passthrough support.

       

      Please feel free to call me if you have any ideas on how to get my bare metal install to work.

       

      I am using this primarily for my SP CCIE but which for now the vmware workstation 64G is working for this but in the future for consulting would like to be able to do massive simulations.

       

      Gyan Mishtra

      Cell-202 734-1000

       

      Deploy VIRL PE Using ISO

         
        • 1. Re: VIRL 1.5.145 bare metal ISO boot install - fails during installation
          Karlo Bobiles

          Hello GYAN,

           

          Looping in alegalle and mirlos for further insight. Please stand by.


          Thank you,

          Karlo Bobiles

          Cisco Learning Network

          • 2. Re: VIRL 1.5.145 bare metal ISO boot install - fails during installation
            Miroslav Los

            Hi,

             

            please try installing the machine without internet access. The iso install will try to download updates while installing, and it need not be doing it well. Alternatively, if the issue is with the USB installer, burn the ISO you downloaded to a DVD and install via a USB DVD-ROM drive, if your server supports that.

             

            Now, only from memory, to get to the actual install issue, you might need to

            1) get to a console while having the installer booted. You might try Crtl+Alt+F2 to do that. Ctrl+Alt+F1 should bring you back.

            2) be root in that console, if it's not already

            3) run this to enter the shell the installed partition: chroot /target /bin/bash

            4) try fixing problems with the installation; errors may appear that bring us closer: apt-get install -f

             

            I'm confused by the 1G SSD comment - the VIRL system when installed to baremetal requires significantly more space for its root partition (~60-ish is a good start). Were those 1T, perhaps?