2 Replies Latest reply: Jun 7, 2019 8:18 AM by MiltonVieira RSS

    BFD config on interface and BGP for 1 router 2 ISP setup

    Oreoloveboss

      Hello, I have an ASR1001x connected to 2 ISP where one is failover only, how should BFD be configured on the interfaces and neighbor fall-over?

      For example

       

      interface GigabitEthernet0/0/1

      ip address 10.10.20.21

      description ISP_primary

      !

      interface GigabitEthernet0/0/2

      ip address 30.30.60.61

      description ISP_backup

      !

      router BGP 100

      neighbor 10.10.20.20 remote as 200

      neighbor 30.30.60.60 remote as 300

      neighbor 30.30.60.60 route-map ISP_backup_in

      neighbor 30.30.60.60 route-map ISP_backup_out

      !

      routemap ISP_backup_in

      set local-preference 50

      !

      routemap ISP_backup_out

      set as-path prepend 100 100 100

      !

       

      So in this scenario I want to setup BFD so that when ISP_primary has an outage, it fails over to ISP_backup, however I do not need BFD configured on ISP_backup (so that it would failover back to the primary).

       

      Do I only configure BFD on Gigabitethernet0/0/1 (ISP_primary)? ie:


      bfd-template single-hop ISP_primary_outage

      interval min-tx 50 min-rx 50 multiplier 5

      !

      interface Gigabitethernet0/0/1

      bfd-template ISP_primary_outage

      !

       

      Do I need anything on the interface for the backup ISP? And I'm a little confused at the format to link it to the BGP session
      Do I add a neighbor fall-over bfd to ISP_primary or ISP_backup? Or would it need to be on both to accomplish this?

        • 2. Re: BFD config on interface and BGP for 1 router 2 ISP setup
          MiltonVieira

          Dear Oreoloveboss

          Really you must enable BFD on both sides (you must agree that with your ISP).

          Below an example that I'm using and working fine over %BGP. I added the BFD multihop that I knew recently during some studies.

           

          interface GigabitEthernet2

          ip address 192.168.17.1 255.255.255.252

          bfd interval 100 min_rx 100 multiplier 3

          !

          router bgp 100

          address-family ipv4

             neighbor 192.168.17.2 fall-over bfd

           

           

          For BFD Multihop

          !

          bfd map ipv4  <destination-loopback/32>  <source-loopback/32> bfd-multihop-bgp-ipv4

          bfd-template multi-hop bfd-multihop-bgp-ipv4

          !

          router bgp 100

          address-family ipv4

             neighbor 1.1.1.1 fall-over bfd multi-hop strict-mode

          !

          !

          PE_BKP_07#show bfd neighbors

           

           

          IPv4 Sessions

          NeighAddr                              LD/RD         RH/RS     State     Int

          192.168.17.2                         4111/4101       Up        Up        Gi2

           

          IPv6 Sessions

          NeighAddr                              LD/RD         RH/RS     State     Int

          2001:192:168:17::7                      1/3          Up        Up        Gi2

           

          IPv4 Multihop Sessions

          NeighAddr[vrf]                                LD/RD         RH/RS     State

          1.1.1.1                                     4118/4160       Up        Up     

          PE_BKP_07#